aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-12-28 16:58:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-12-28 16:58:50 +0000
commite3e5aa139840c78ef50b0728517c59237eff1742 (patch)
tree2e32086ea8aadd55c5db1d5baa7b6b3b273063d0 /dns
parent991c774d9493db7aa1dad81e6eedae1f0dd73654 (diff)
downloadports-e3e5aa139840c78ef50b0728517c59237eff1742.tar.gz
ports-e3e5aa139840c78ef50b0728517c59237eff1742.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/noip/Makefile2
-rw-r--r--dns/noip/distinfo6
-rw-r--r--dns/noip/files/patch-Makefile8
-rw-r--r--dns/noip/files/patch-noip2.c14
4 files changed, 15 insertions, 15 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index b26c613e33ed..6289a1e72573 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= noip
-PORTVERSION= 2.1.4
+PORTVERSION= 2.1.7
CATEGORIES= dns
MASTER_SITES= http://www.no-ip.com/client/linux/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/dns/noip/distinfo b/dns/noip/distinfo
index 16b32dba9331..20cb1e887d4e 100644
--- a/dns/noip/distinfo
+++ b/dns/noip/distinfo
@@ -1,3 +1,3 @@
-MD5 (noip-2.1.4.tar.gz) = d65e221016a61cd4e412242c34c71ff1
-SHA256 (noip-2.1.4.tar.gz) = 8912301be611b842d0cf1a335275c367f3a80d507bc53c7460c68b52d71b1a7c
-SIZE (noip-2.1.4.tar.gz) = 102789
+MD5 (noip-2.1.7.tar.gz) = 7b6b64c08708c2b147c375dda074a8dc
+SHA256 (noip-2.1.7.tar.gz) = 1105a23cb0a957c4b1e7c47bd9bfed00f1a089bdddd2a69f69bf4f8047f7a237
+SIZE (noip-2.1.7.tar.gz) = 147640
diff --git a/dns/noip/files/patch-Makefile b/dns/noip/files/patch-Makefile
index db28f5529f7d..6e2a312f68e3 100644
--- a/dns/noip/files/patch-Makefile
+++ b/dns/noip/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Wed Oct 18 11:13:47 2006
-+++ Makefile Wed Oct 18 11:16:45 2006
+--- Makefile.orig 2007-08-11 20:35:34.000000000 +0200
++++ Makefile 2007-12-24 12:18:38.000000000 +0100
@@ -1,13 +1,13 @@
TGT=noip2
-CC=gcc
@@ -9,8 +9,8 @@
-CONFDIR=${PREFIX}/etc
-BINDIR=${PREFIX}/bin
+MYPREFIX=${PREFIX}
-+CONFDIR=${MYPREFIX}/etc
-+BINDIR=${MYPREFIX}/bin
++MYCONFDIR=${PREFIX}/etc
++MYBINDIR=${PREFIX}/bin
# these defines are for Linux
-LIBS=
diff --git a/dns/noip/files/patch-noip2.c b/dns/noip/files/patch-noip2.c
index f745e1aabb76..ad0fe024bb59 100644
--- a/dns/noip/files/patch-noip2.c
+++ b/dns/noip/files/patch-noip2.c
@@ -1,15 +1,15 @@
---- noip2.c.orig Tue Feb 20 22:12:22 2007
-+++ noip2.c Sun Feb 25 18:47:38 2007
-@@ -176,7 +176,7 @@
+--- noip2.c.orig 2007-08-27 23:54:19.000000000 +0200
++++ noip2.c 2007-12-24 12:25:18.000000000 +0100
+@@ -185,7 +185,7 @@
#define CLIENT_IP_PORT 8245
- #define VERSION "2.1.4"
+ #define VERSION "2.1.7"
-#define USER_AGENT "User-Agent: Linux-DUC/"VERSION
+#define USER_AGENT "User-Agent: FreeBSD-DUC/"VERSION
#define SETTING_SCRIPT "settings.php?"
#define USTRNG "username="
#define PWDSTRNG "&pass="
-@@ -283,7 +283,7 @@
+@@ -292,7 +292,7 @@
#define CMSG21 "Please select the Internet interface from this list.\n"
#define CMSG22 "By typing the number associated with it."
#define CMSG23 "Too many network devices. Limit is %d"
@@ -18,7 +18,7 @@
#define CMSG25 "Can't create config file (%s)"
#define CMSG25a "Re-run noip, adding '-c configfilename' as a parameter."
#define CMSG26 "Can't rename config file (%s)"
-@@ -490,7 +490,7 @@
+@@ -502,7 +502,7 @@
fprintf(stderr, "[ -d][ -D pid]");
#endif
fprintf(stderr, "[ -i addr][ -S][ -M][ -h]");
@@ -27,7 +27,7 @@
fprintf(stderr, "Options: -C create configuration data\n");
fprintf(stderr, " -F force NAT off\n");
fprintf(stderr, " -Y select all hosts/groups\n");
-@@ -2058,17 +2058,12 @@
+@@ -2119,17 +2119,12 @@
dq = (unsigned char *)devs; // point at name list
for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
if (ifa->ifa_addr->sa_family == AF_LINK) {