aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 07:43:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 07:43:14 +0000
commit445b2bb748b866784772ca8db55f96f42542702f (patch)
treec2dd0a1d70cc7ba2c89a87e500191735fe0ebec4 /dns
parentfbac3292631736883755ea0f9ebca8b72d440fe6 (diff)
downloadports-445b2bb748b866784772ca8db55f96f42542702f.tar.gz
ports-445b2bb748b866784772ca8db55f96f42542702f.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind97-sdb/Makefile46
-rw-r--r--dns/djbdns/Makefile64
-rw-r--r--dns/powerdns-recursor/Makefile23
3 files changed, 55 insertions, 78 deletions
diff --git a/dns/bind97-sdb/Makefile b/dns/bind97-sdb/Makefile
index 8877b9a6186c..185047ea9f3e 100644
--- a/dns/bind97-sdb/Makefile
+++ b/dns/bind97-sdb/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: bind97-sdb-postgresql
-# Date created: 2011-06-10
-# Whom: Josh Carroll <josh.carroll@gmail.com>
-#
+# Created by: Josh Carroll <josh.carroll@gmail.com>
# $FreeBSD$
PORTNAME= bind97-sdb
@@ -15,9 +12,12 @@ CONFLICTS= bind9? host-*
# the user may pick one and only one SDB driver. Depending on which
# option the user picks, the appropriate patches will be applied
# so bind is built with the proper driver
-OPTIONS= PGSQL "Build with PostgreSQL SDB support" on \
- LDAP "Build with LDAP SDB support" off
-
+OPTIONS_SINGLE= SDB
+OPTIONS_SINGLE_SDB= PGSQL LDAP
+OPTIONS_DEFAULT= PGSQL
+PGSQL_DESC= PostgreSQL SDB support
+LDAP_DESC= LDAP SDB support
+#
# Future use
# DIRDB "Build with dirdb SDB support" off \
# BDB "Build with bdb SDB support" off \
@@ -32,9 +32,7 @@ OUR_PATCHDIR:=${.CURDIR}/files
# check that one and ONLY one of the SDB options is set
# the value of SDB_DRIVER should match the name of the
# contrib/sdb dir
-num_sdb_types:=SDB
-.if defined(WITH_PGSQL)
-num_sdb_types+=1
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
EXTRA_PATCHES+= ${OUR_PATCHDIR}/patch-pgsql-bin__named__Makefile.in \
${OUR_PATCHDIR}/patch-pgsql-bin__named__main.c \
@@ -43,8 +41,7 @@ SDB_DRIVER=pgsql
SDB_DRIVER_FILES=pgsqldb.c pgsqldb.h
.endif
-.if defined(WITH_LDAP)
-num_sdb_types+=1
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
EXTRA_PATCHES+= ${OUR_PATCHDIR}/patch-ldap-bin__named__Makefile.in \
${OUR_PATCHDIR}/patch-ldap-bin__named__main.c
@@ -52,51 +49,36 @@ SDB_DRIVER=ldap
SDB_DRIVER_FILES=ldapdb.c
.endif
-.if defined(WITH_DIRDB)
-num_sdb_types+=1
+.if ${PORT_OPTIONS:MDIRDB}
SDB_DRIVER=dir
SDB_DRIVER_FILES=
IGNORE=This port does not yet support SDB DIRDB
.endif
-.if defined(WITH_BDB)
-num_sdb_types+=1
+.if ${PORT_OPTIONS:MBDB}
SDB_DRIVER=bdb
SDB_DRIVER_FILES=
IGNORE=This port does not yet support SDB BDB
.endif
-.if defined(WITH_SQLITE)
-num_sdb_types+=1
+.if ${PORT_OPTIONS:MSQLITE}
SDB_DRIVER=sqlite
SDB_DRIVER_FILES=
IGNORE=This port does not yet support SDB SQLITE
.endif
-.if defined(WITH_TCL)
-num_sdb_types+=1
+.if ${PORT_OPTIONS:MTCL}
SDB_DRIVER=tcldb
SDB_DRIVER_FILES=
IGNORE=This port does not yet support SDB TCLDB
.endif
-.if defined(WITH_TIMEDB)
-num_sdb_types+=1
+.if ${PORT_OPTIONS:MTIMEDB}
SDB_DRIVER=timedb
SDB_DRIVER_FILES=
IGNORE=This port does not yet support SDB TIMEDB
.endif
-# if one and only 1 of the SDB options is set
-# then the value of ${num_sdb_types} will be "SDB 1"
-.if ${num_sdb_types} == "SDB"
-IGNORE=You must select one SDB database type : DEBUG 1: ->${num_sdb_types}<-
-.else
-. if ${num_sdb_types} != "SDB 1"
-IGNORE=You have selected more than one SDB database type : DEBUG 2: ->${num_sdb_types}<-
-. endif
-.endif
-
pre-patch:
.for FILE in ${SDB_DRIVER_FILES}
@${CP} ${WRKSRC}/contrib/sdb/${SDB_DRIVER}/${FILE} ${WRKSRC}/bin/named
diff --git a/dns/djbdns/Makefile b/dns/djbdns/Makefile
index df7159c87d13..b29d0bcb742e 100644
--- a/dns/djbdns/Makefile
+++ b/dns/djbdns/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dnscache
-# Date created: 24 Jan 2000
-# Whom: Neil Blakey-Milner
-#
+# Created by: Neil Blakey-Milner
# $FreeBSD$
-#
PORTNAME?= djbdns
PORTVERSION?= ${DJBDNS_VER}
@@ -20,20 +16,22 @@ COMMENT?= A collection of secure and reliable DNS tools
RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools \
tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-OPTIONS= DUMPCACHE "persistent cache for dnscache" off \
- IPV6 "IPv6 support by Felix von Leitner" off \
- IGNOREIP "ignoreip2 patch by Russell Nelson" off \
- JUMBO "jumbo patch by Claudiu Costin" off \
- MAN "manual pages by Gerritt Pape" on \
- PERSISTENT_MMAP "persistent mmap patch by Lennert Buytenhek" off \
- SRV "SRV record patch by Michael Handler" off \
- DNSCURVE "DNSCurve support by Matthew Dempsky" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_JUMBO)
-.if defined(WITH_IPV6) || defined(WITH_IGNOREIP) || defined(WITH_SRV) || \
- defined(WITH_DNSCURVE)
+OPTIONS_DEFINE= DUMPCACHE IPV6 IGNOREIP JUMBO MAN PERSISTENT_MMAP SRV DNSCURVE
+OPTIONS_DEFAULT= MAN
+DUMPCACHE_DESC= persistent cache for dnscache
+IPV6_DESC= IPv6 support by Felix von Leitner
+IGNOREIP_DESC= ignoreip2 patch by Russell Nelson
+JUMBO_DESC= jumbo patch by Claudiu Costin
+MAN_DESC= manual pages by Gerritt Pape
+PERSISTENT_MMAP_DESC= persistent mmap patch by Lennert Buytenhek
+SRV_DESC= SRV record patch by Michael Handler
+DNSCURVE_DESC= DNSCurve support by Matthew Dempsky
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MJUMBO}
+.if ${PORT_OPTIONS:MIPV6} || ${PORT_OPTIONS:MIGNOREIP} || ${PORT_OPTIONS:MSRV} || \
+ ${PORT_OPTIONS:MDNSCURVE}
BROKEN= The jumbo patch currently conflicts with the IPv6, ignoreip2, SRV and DNSCURVE patches
.endif
@@ -41,12 +39,12 @@ PATCH_SITES+= http://people.FreeBSD.org/~roam/ports/dns/djbdns/:jumbo \
${MASTER_SITE_LOCAL:S/%SUBDIR%\//roam\/dns\/djbdns\/:jumbo/}
PATCHFILES+= jumbo-p13.patch.gz:jumbo
PATCH_DIST_STRIP= -p1
-.if defined(WITH_DUMPCACHE)
+.if ${PORT_OPTIONS:MDUMPCACHE}
CFLAGS+= -DDUMPCACHE
.endif
.endif
-.if defined(WITH_MAN)
+.if ${PORT_OPTIONS:MMAN}
MANDATE= -20031023
MASTER_SITES+= http://smarden.org/pape/djb/manpages/:manpages
DISTFILES+= ${DISTNAME}-man${MANDATE}.tar.gz:manpages
@@ -61,7 +59,7 @@ MAN8= axfr-get.8 axfrdns.8 axfrdns-conf.8 dnscache-conf.8 \
MANCOMPRESSED= no
.endif
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
PKGNAMESUFFIX= -ipv6
PORTVERSION= ${DJBDNS_VER}.${DJBDNS_V6_VER:S/test/b/:S/diff//}
PATCH_SITES+= http://www.fefe.de/dns/:ipv6
@@ -70,8 +68,8 @@ PATCH_DIST_STRIP= -p1
EXTRA_PATCHES+= ${FILESDIR}/uint32.patch ${FILESDIR}/djbdns-ipv6-ooyama.patch
.endif
-.if defined(WITH_DUMPCACHE) && !defined(WITH_JUMBO)
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MDUMPCACHE} && ! ${PORT_OPTIONS:MJUMBO}
+.if ${PORT_OPTIONS:MIPV6}
BROKEN= The IPv6 and dnscache-dumpcache patches are currently in conflict
.endif
PATCH_SITES+= http://efge.free.fr/djbdns/:dumpcache
@@ -80,8 +78,8 @@ PATCH_DIST_STRIP= -p1
CFLAGS+= -DDUMPCACHE
.endif
-.if defined(WITH_IGNOREIP)
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIGNOREIP}
+.if ${PORT_OPTIONS:MIPV6}
BROKEN= The IPv6 patch already includes the ignoreip2 functionality
.endif
PATCH_SITES+= http://tinydns.org/:ignoreip
@@ -89,20 +87,20 @@ PATCHFILES+= djbdns-1.05-ignoreip2.patch:ignoreip
PATCH_DIST_STRIP= -p1
.endif
-.if defined(WITH_PERSISTENT_MMAP)
+.if ${PORT_OPTIONS:MPERSISTENT_MMAP}
PATCH_SITES+= http://people.FreeBSD.org/~roam/ports/patches/dns/:persistent
PATCHFILES+= tinydns-persistmmap-20040418.patch:persistent
PATCH_DIST_STRIP= -p1
.endif
-.if defined(WITH_SRV)
+.if ${PORT_OPTIONS:MSRV}
PATCH_SITES+= http://tinydns.org/:srv
PATCHFILES+= srv-patch:srv
PATCH_DIST_STRIP= -p1
.endif
-.if defined(WITH_DNSCURVE)
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MDNSCURVE}
+.if ${PORT_OPTIONS:MIPV6}
BROKEN= The IPv6 and DNSCurve patches are currently in conflict
.endif
PATCH_SITES+= http://shinobi.dempsky.org/~matthew/patches/:dnscurve
@@ -119,7 +117,7 @@ DJBDNS_V6_VER= test23
ALL_TARGET= it
INSTALL_TARGET= setup check
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
PLIST_SUB+= WITH_IPV6=""
.else
PLIST_SUB+= WITH_IPV6="@comment "
@@ -130,10 +128,10 @@ post-patch:
@echo "${CC} ${STRIP} ${LDFLAGS}" > ${WRKSRC}/conf-ld
@echo "${PREFIX}" > ${WRKSRC}/conf-home
-.if defined(WITH_MAN)
+.if ${PORT_OPTIONS:MMAN}
post-install:
@${INSTALL_MAN} ${WRKDIR}/djbdns-man/*.1 ${PREFIX}/man/man1/
@${INSTALL_MAN} ${WRKDIR}/djbdns-man/*.8 ${PREFIX}/man/man8/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 75f275527fd3..f1090a59858d 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: powerdns-recursor
-# Date Created: 14.Nov 2006
-# Whom: sten@blinkenlights.nl
-#
+# Created by: sten@blinkenlights.nl
# $FreeBSD$
-#
PORTNAME= powerdns-recursor
PORTVERSION= 3.3
@@ -21,9 +17,10 @@ BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
USE_BZIP2= yes
USE_GMAKE= yes
-OPTIONS= SETUID "Run as pdns_recursor user" on \
- LUA "Enable Lua bindings" off \
- STATIC "Build static binaries" off
+OPTIONS_DEFINE= SETUID LUA STATIC
+OPTIONS_DEFAULT= SETUID
+SETUID_DESC= Run as pdns_recursor user
+STATIC_DESC= Build static binaries
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -31,7 +28,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN8= rec_control.8 pdns_recursor.8
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
@@ -39,13 +36,13 @@ BROKEN= Does not compile on sparc64
USE_RC_SUBR+= pdns-recursor
-.if defined(WITH_SETUID)
+.if ${PORT_OPTIONS:MSETUID}
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-setuid
USERS= pdns_recursor
GROUPS= pdns
.endif
-.if defined(WITH_LUA)
+.if ${PORT_OPTIONS:MLUA}
USE_LUA=5.1
LUA_COMPS=lua
MAKE_ENV+=LUA=1
@@ -53,7 +50,7 @@ MAKE_ENV+=LUA_CPPFLAGS_CONFIG=-I${LOCALBASE}/include/lua51
MAKE_ENV+="LUA_LIBS_CONFIG=-L${LOCALBASE}/lib/lua51/ -llua"
.endif
-.if defined(WITH_STATIC)
+.if ${PORT_OPTIONS:MSTATIC}
MAKE_ENV+=STATIC=full
.endif
@@ -81,4 +78,4 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/*.8 ${PREFIX}/man/man8/
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>