aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-05-17 21:30:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-05-17 21:30:24 +0000
commit3d3897ed7d0dc33327efdb9b1e3221d226372b20 (patch)
tree01de60d3f79d9dcff23458449fd688d94dd791b0 /dns
parent8e4282ffe63ea028c7fb47ddca3a33fb2de11b10 (diff)
downloadports-3d3897ed7d0dc33327efdb9b1e3221d226372b20.tar.gz
ports-3d3897ed7d0dc33327efdb9b1e3221d226372b20.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind910/Makefile7
-rw-r--r--dns/bind910/pkg-help10
-rw-r--r--dns/bind98/Makefile8
-rw-r--r--dns/bind98/pkg-help8
-rw-r--r--dns/bind99/Makefile10
-rw-r--r--dns/bind99/pkg-help9
6 files changed, 47 insertions, 5 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 33c4b6577c97..3dcef20d1e5e 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.10.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -56,7 +56,7 @@ FILTER_AAAA_DESC= Enable filtering of AAAA records
CRYPTO_DESC= Choose which crypto engine to use
NATIVE_PKCS11_DESC= Use PKCS\#11 native API (**READ HELP**)
GEOIP_DESC= Allow geographically based ACL.
-GOST_DESC= Enable GOST ciphers (DSO incompatible with chroot)
+GOST_DESC= Enable GOST ciphers, needs SSL (see help)
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -154,6 +154,9 @@ PLIST_SUB+= NOBASE="" BASE="@comment "
SUB_LIST+= NOBASE="" BASE="@comment "
USE_RC_SUBR+= named
SUB_FILES+= named.conf
+.if ${PORT_OPTIONS:MGOST}
+WITH_OPENSSL_PORT=yes
+.endif
.else
ETCDIR= ${PREFIX}/etc
PLIST_SUB+= NOBASE="@comment " BASE=""
diff --git a/dns/bind910/pkg-help b/dns/bind910/pkg-help
index 7d1aac91087a..c6c4a4ac20e6 100644
--- a/dns/bind910/pkg-help
+++ b/dns/bind910/pkg-help
@@ -11,3 +11,13 @@ used for DNSSEC validations, and the HSM is likely to be
slower than the CPU for this purpose. Additionally, the HSM
might not support all of the PKCS#11 API functions needed
for signature verification.
+
+
+ GOST
+If using a chrooted instance of BIND, the OpenSSL engines
+need to be accessible from within the chroot. If BIND
+is chrooted in /var/named, this can be achieved by either
+copying content of /usr/local/lib/engines into
+/var/named/usr/local/lib/engines, or by creating that
+directory and adding this line to /etc/fstab:
+/usr/local/lib/engines /var/named/usr/local/lib/engines nullfs ro 0 0
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 0734dcc64dbf..951074cd8293 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.8.7
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -156,8 +156,14 @@ SUB_LIST+= BIND_DESTETC="${BIND_DESTETC}"
PLIST_SUB+= NOBASE="" BASE="@comment "
USE_RC_SUBR+= named
SUB_FILES+= named.conf
+.if ${PORT_OPTIONS:MGOST}
+WITH_OPENSSL_PORT=yes
+.endif
.else
PLIST_SUB+= NOBASE="@comment " BASE=""
+.if ${PORT_OPTIONS:MSSL}
+WITH_OPENSSL_PORT= yes
+.endif
.endif
post-patch:
diff --git a/dns/bind98/pkg-help b/dns/bind98/pkg-help
new file mode 100644
index 000000000000..af49ace19efb
--- /dev/null
+++ b/dns/bind98/pkg-help
@@ -0,0 +1,8 @@
+ GOST
+If using a chrooted instance of BIND, the OpenSSL engines
+need to be accessible from within the chroot. If BIND
+is chrooted in /var/named, this can be achieved by either
+copying content of /usr/local/lib/engines into
+/var/named/usr/local/lib/engines, or by creating that
+directory and adding this line to /etc/fstab:
+/usr/local/lib/engines /var/named/usr/local/lib/engines nullfs ro 0 0
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index dc8a019ce44f..c8ac92d7f27c 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.9.5
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -47,7 +47,7 @@ LARGE_FILE_DESC= 64-bit file support
FIXED_RRSET_DESC= Enable fixed rrset ordering
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
FILTER_AAAA_DESC= Enable filtering of AAAA records
-GOST_DESC= Enable GOST ciphers (DSO incompatible with chroot)
+GOST_DESC= Enable GOST ciphers, needs SSL (see help)
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -168,8 +168,14 @@ SUB_LIST+= BIND_DESTETC="${BIND_DESTETC}"
PLIST_SUB+= NOBASE="" BASE="@comment "
USE_RC_SUBR+= named
SUB_FILES+= named.conf
+.if ${PORT_OPTIONS:MGOST}
+WITH_OPENSSL_PORT=yes
+.endif
.else
PLIST_SUB+= NOBASE="@comment " BASE=""
+.if ${PORT_OPTIONS:MSSL}
+WITH_OPENSSL_PORT= yes
+.endif
.endif
.if !defined(BIND_TOOLS_SLAVE)
diff --git a/dns/bind99/pkg-help b/dns/bind99/pkg-help
new file mode 100644
index 000000000000..224b241884da
--- /dev/null
+++ b/dns/bind99/pkg-help
@@ -0,0 +1,9 @@
+
+ GOST
+If using a chrooted instance of BIND, the OpenSSL engines
+need to be accessible from within the chroot. If BIND
+is chrooted in /var/named, this can be achieved by either
+copying content of /usr/local/lib/engines into
+/var/named/usr/local/lib/engines, or by creating that
+directory and adding this line to /etc/fstab:
+/usr/local/lib/engines /var/named/usr/local/lib/engines nullfs ro 0 0