aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2017-06-07 10:34:30 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2017-06-07 10:34:30 +0000
commitd1c99f2ebf7931ca4c47273158a006c5f5dd17c3 (patch)
treeeb065288bd84d5b985c3fcdddd190aeb8fb8888d /dns
parent3d2aec017827875392b377d6827926482f6dc807 (diff)
downloadports-d1c99f2ebf7931ca4c47273158a006c5f5dd17c3.tar.gz
ports-d1c99f2ebf7931ca4c47273158a006c5f5dd17c3.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-idna/Makefile2
-rw-r--r--dns/py3-idna/Makefile8
-rw-r--r--dns/py3-idna/distinfo3
-rw-r--r--dns/py3-idna/pkg-descr10
5 files changed, 23 insertions, 1 deletions
diff --git a/dns/Makefile b/dns/Makefile
index da0d2e509c7a..555903f1c00e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -186,6 +186,7 @@
SUBDIR += py-tldextract
SUBDIR += py-twistedNames
SUBDIR += py3-dnspython
+ SUBDIR += py3-idna
SUBDIR += radns
SUBDIR += rbldnsd
SUBDIR += rbllookup
diff --git a/dns/py-idna/Makefile b/dns/py-idna/Makefile
index 4e7383794faa..5bcb4dae5eb3 100644
--- a/dns/py-idna/Makefile
+++ b/dns/py-idna/Makefile
@@ -10,7 +10,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
COMMENT= Internationalized Domain Names in Applications (IDNA)
-USES= python # Actually, 2.6-2.7,3.3-3.6
+USES?= python # Actually, 2.6-2.7,3.3-3.6
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py3-idna/Makefile b/dns/py3-idna/Makefile
new file mode 100644
index 000000000000..02e14e4224fb
--- /dev/null
+++ b/dns/py3-idna/Makefile
@@ -0,0 +1,8 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-idna
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"
diff --git a/dns/py3-idna/distinfo b/dns/py3-idna/distinfo
new file mode 100644
index 000000000000..3892fed6c802
--- /dev/null
+++ b/dns/py3-idna/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496221751
+SHA256 (idna-2.5.tar.gz) = 3cb5ce08046c4e3a560fc02f138d0ac63e00f8ce5901a56b32ec8b7994082aab
+SIZE (idna-2.5.tar.gz) = 130211
diff --git a/dns/py3-idna/pkg-descr b/dns/py3-idna/pkg-descr
new file mode 100644
index 000000000000..dd2b68ff56ca
--- /dev/null
+++ b/dns/py3-idna/pkg-descr
@@ -0,0 +1,10 @@
+A library to support the Internationalised Domain Names in Applications
+(IDNA) protocol as specified in RFC 5891. This version of the protocol
+is often referred to as "IDNA2008" and can produce different res
+lts from the earlier standard from 2003.
+
+The library is also intended to act as a suitable drop-in replacement
+for the "encodings.idna" module that comes with the Python standard
+library but currently only supports the older 2003 specification.
+
+WWW: https://github.com/kjd/idna