aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-10 03:15:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-10 03:15:21 +0000
commit172e0995d7e5d1ac8780cd6c3951ce43a5223429 (patch)
tree38fd98b2e2da50166d7b48d145151030892a1558 /dns
parentbe1e931a1b700536d73ee8e9fe75f1e3844429c9 (diff)
downloadports-172e0995d7e5d1ac8780cd6c3951ce43a5223429.tar.gz
ports-172e0995d7e5d1ac8780cd6c3951ce43a5223429.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/rubygem-public_suffix_service/Makefile20
-rw-r--r--dns/rubygem-public_suffix_service/distinfo2
-rw-r--r--dns/rubygem-public_suffix_service/pkg-descr17
4 files changed, 40 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index d56da191248c..ec483cbb1215 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -134,6 +134,7 @@
SUBDIR += rbllookup-ng
SUBDIR += rubygem-dnsruby
SUBDIR += rubygem-net-dns
+ SUBDIR += rubygem-public_suffix_service
SUBDIR += scavenge
SUBDIR += sheerdns
SUBDIR += skadns
diff --git a/dns/rubygem-public_suffix_service/Makefile b/dns/rubygem-public_suffix_service/Makefile
new file mode 100644
index 000000000000..5403dd6d8b85
--- /dev/null
+++ b/dns/rubygem-public_suffix_service/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: rubygem-public_suffix_service
+# Date created: 2011-11-10
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= public_suffix_service
+PORTVERSION= 0.9.0
+CATEGORIES= dns ruby
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse and decompose domain names into TLD, domain and subdomains
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/dns/rubygem-public_suffix_service/distinfo b/dns/rubygem-public_suffix_service/distinfo
new file mode 100644
index 000000000000..e42ebcdc4db8
--- /dev/null
+++ b/dns/rubygem-public_suffix_service/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/public_suffix_service-0.9.0.gem) = 8cb33dd396a9d8e0242e239be8e63f834f181dea5051151ae53027821a8c4d49
+SIZE (rubygem/public_suffix_service-0.9.0.gem) = 45056
diff --git a/dns/rubygem-public_suffix_service/pkg-descr b/dns/rubygem-public_suffix_service/pkg-descr
new file mode 100644
index 000000000000..a82eb3295f40
--- /dev/null
+++ b/dns/rubygem-public_suffix_service/pkg-descr
@@ -0,0 +1,17 @@
+Public Suffix Service is a Ruby domain name parser based on the Public Suffix
+List.
+
+The Public Suffix Service is a cross-vendor initiative to provide an accurate
+list of domain name suffixes.
+
+The Public Suffix Service is an initiative of the Mozilla Project, but is
+maintained as a community resource. It is available for use in any software, but
+was originally created to meet the needs of browser manufacturers.
+
+A "public suffix" is one under which Internet users can directly register names.
+Some examples of public suffixes are ".com", ".co.uk" and "pvt.k12.wy.us". The
+Public Suffix List is a list of all known public suffixes.
+
+WWW: http://www.simonecarletti.com/code/public_suffix_service/
+WWW: https://github.com/weppos/public_suffix_service
+WWW: https://rubygems.org/gems/public_suffix_service