aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-05 20:18:30 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-05 20:18:30 +0000
commit54e44467d7a2aed3673c0a14dbbb8e6dd1bee7be (patch)
tree3b1d1321b78dcf4a659d95ca332649d8253316c1 /dns
parent454b9ce076de33c963302ac6c86affcddce681dd (diff)
downloadports-54e44467d7a2aed3673c0a14dbbb8e6dd1bee7be.tar.gz
ports-54e44467d7a2aed3673c0a14dbbb8e6dd1bee7be.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind96/Makefile3
-rw-r--r--dns/bind98/Makefile3
-rw-r--r--dns/bind99/Makefile3
-rw-r--r--dns/idnkit/Makefile2
-rw-r--r--dns/idnkit2/Makefile11
5 files changed, 9 insertions, 13 deletions
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index c42c30305f0e..ebea70cc582c 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -69,7 +69,8 @@ CONFIGURE_ARGS+= --without-libxml2
.endif
.if ${PORT_OPTIONS:MIDN}
-CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
+USES+= iconv
+CONFIGURE_ARGS+= --with-idn=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
.else
CONFIGURE_ARGS+= --without-idn
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 5e0bfd918b73..37fdb310a51f 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -72,7 +72,8 @@ CONFIGURE_ARGS+= --without-libxml2
.endif
.if ${PORT_OPTIONS:MIDN}
-CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
+USES+= iconv
+CONFIGURE_ARGS+= --with-idn=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
.else
CONFIGURE_ARGS+= --without-idn
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 9a21b1de4c81..370218e1d622 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -81,7 +81,8 @@ CONFIGURE_ARGS+= --without-libxml2
.endif
.if ${PORT_OPTIONS:MIDN}
-CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
+USES+= iconv
+CONFIGURE_ARGS+= --with-idn=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
.else
CONFIGURE_ARGS+= --without-idn
diff --git a/dns/idnkit/Makefile b/dns/idnkit/Makefile
index eb63b3346b32..ce39ae91466a 100644
--- a/dns/idnkit/Makefile
+++ b/dns/idnkit/Makefile
@@ -18,7 +18,7 @@ COMMENT= A library to handle internationalized domain names
USE_AUTOTOOLS= libtool
USES= iconv
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE} \
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE} \
--enable-runidn \
--enable-extra-ace
diff --git a/dns/idnkit2/Makefile b/dns/idnkit2/Makefile
index 9b27efe4ae79..83326e48d29b 100644
--- a/dns/idnkit2/Makefile
+++ b/dns/idnkit2/Makefile
@@ -20,6 +20,7 @@ USE_AUTOTOOLS= libtool
USES= iconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
USE_LDCONFIG= yes
@@ -32,16 +33,8 @@ MAN3= idn_checkname.3 idn_comparenames.3 idn_comparenames2.3 \
MAN5= idn2.conf.5 idn2rc.5 idnalias.conf.5 idnlang.conf.5
MANCOMPRESSED= no
-.include <bsd.port.pre.mk>
-
-.if empty(ICONV_LIB)
-CONFIGURE_ARGS= --with-libiconv=/usr
-.else
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>