aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-06-10 12:30:03 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-06-10 12:30:03 +0000
commit8d842276fc1a0e24831e1ceffeae30e3a7580b38 (patch)
treec653c56d4c459d40104a721aefb9f89cd548dd7a /dns
parent7d9a6edc952cc0f6b23cbfc1ca39a29ccf473edf (diff)
downloadports-8d842276fc1a0e24831e1ceffeae30e3a7580b38.tar.gz
ports-8d842276fc1a0e24831e1ceffeae30e3a7580b38.zip
Update to latest commit.
Notes
Notes: svn path=/head/; revision=503895
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h29
5 files changed, 17 insertions, 46 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index c4d1bbcdbe01..ece62484ada9 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -41,13 +41,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.0a0.2019.06.03
+ISCVERSION= 9.15.0a0.2019.06.10
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= bae12f569d19ce02e32718c5f7e55be93bef1f21
+GL_COMMIT= 32c86e29e23c6829290086f919fed3cf124fe348
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 98157afcdd82..19dd07275642 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1559556042
-SHA256 (isc-projects-bind9-bae12f569d19ce02e32718c5f7e55be93bef1f21_GL0.tar.gz) = da35b424687c38b82961b16bfc2722c936a4e0b254edadc87a39fd7da97e9825
-SIZE (isc-projects-bind9-bae12f569d19ce02e32718c5f7e55be93bef1f21_GL0.tar.gz) = 6304252
+TIMESTAMP = 1560165640
+SHA256 (isc-projects-bind9-32c86e29e23c6829290086f919fed3cf124fe348_GL0.tar.gz) = 99f93cc71e75a5f0a4826c40eb76d2435a17b54ab4bb01ad13648ed5e74e8673
+SIZE (isc-projects-bind9-32c86e29e23c6829290086f919fed3cf124fe348_GL0.tar.gz) = 6310334
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index aa291b688f2e..93b6ccc2c410 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2019-06-03 05:32:29 UTC
+--- bin/named/config.c.orig 2019-06-10 04:29:24 UTC
+++ bin/named/config.c
-@@ -176,6 +176,7 @@ options {\n\
+@@ -175,6 +175,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -8,9 +8,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-06-03 05:32:29 UTC
+--- bin/named/server.c.orig 2019-06-10 04:29:24 UTC
+++ bin/named/server.c
-@@ -4231,6 +4231,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4226,6 +4226,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-06-03 05:32:29 UTC
+--- lib/dns/include/dns/view.h.orig 2019-06-10 04:29:24 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -32,7 +32,7 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-06-03 05:32:29 UTC
+--- lib/dns/resolver.c.orig 2019-06-10 04:29:24 UTC
+++ lib/dns/resolver.c
@@ -6048,6 +6048,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
@@ -47,9 +47,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-06-03 05:32:29 UTC
+--- lib/isccfg/namedconf.c.orig 2019-06-10 04:29:24 UTC
+++ lib/isccfg/namedconf.c
-@@ -1899,6 +1899,7 @@ view_clauses[] = {
+@@ -1910,6 +1910,7 @@ view_clauses[] = {
#endif
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index ca050e859bf4..ad94169b6ce9 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-06-03 05:32:29 UTC
+--- configure.orig 2019-06-10 04:29:24 UTC
+++ configure
-@@ -16656,27 +16656,9 @@ done
+@@ -16660,27 +16660,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16719,47 +16701,7 @@ $as_echo "no" >&6; } ;;
+@@ -16723,47 +16705,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21310,7 +21252,7 @@ $as_echo "" >&6; }
+@@ -21311,7 +21253,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h b/dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h
deleted file mode 100644
index c44460fc4c2a..000000000000
--- a/dns/bind9-devel/files/patch-lib_isc_include_isc_endian.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- lib/isc/include/isc/endian.h.orig 2019-06-03 12:08:25 UTC
-+++ lib/isc/include/isc/endian.h
-@@ -43,14 +43,26 @@
-
- # include <sys/endian.h>
-
-+#ifndef be16toh
- # define be16toh(x) betoh16(x)
-+#endif
-+#ifndef le16toh
- # define le16toh(x) letoh16(x)
-+#endif
-
-+#ifndef be32toh
- # define be32toh(x) betoh32(x)
-+#endif
-+#ifndef le32toh
- # define le32toh(x) letoh32(x)
-+#endif
-
-+#ifndef be64toh
- # define be64toh(x) betoh64(x)
-+#endif
-+#ifndef le64toh
- # define le64toh(x) letoh64(x)
-+#endif
-
- #elif defined(_WIN32)
- /* Windows is always little endian */