aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-06-25 17:11:08 +0000
committerDon Lewis <truckman@FreeBSD.org>2018-06-25 17:11:08 +0000
commitbd0fc6b05ddf450f0fd3bbdaa07b46e52fc6d7ac (patch)
tree0b2ffaa36204620680d1df99a11a5bd869c06608 /dns
parent0b82056c9a2575c6ea4e7a14d501925f8cdd1866 (diff)
downloadports-bd0fc6b05ddf450f0fd3bbdaa07b46e52fc6d7ac.tar.gz
ports-bd0fc6b05ddf450f0fd3bbdaa07b46e52fc6d7ac.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/dnstable/Makefile15
-rw-r--r--dns/dnstable/distinfo5
-rw-r--r--dns/dnstable/files/patch-dnstable_query.c11
-rw-r--r--dns/dnstable/files/patch-src_dnstable__convert.c10
-rw-r--r--dns/dnstable/files/patch-src_dnstable__lookup.c10
-rw-r--r--dns/dnstable/pkg-plist2
6 files changed, 7 insertions, 46 deletions
diff --git a/dns/dnstable/Makefile b/dns/dnstable/Makefile
index f61dfa5d2b72..605cb3ef5758 100644
--- a/dns/dnstable/Makefile
+++ b/dns/dnstable/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= dnstable
-PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTVERSION= 0.10.1
CATEGORIES= dns
MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
@@ -12,21 +11,15 @@ COMMENT= Encoding format, library, and utilities for passive DNS data
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-BUILD_DEPENDS= sie-nmsg>0:net/sie-nmsg
LIB_DEPENDS= libmtbl.so:devel/mtbl \
libyajl.so:devel/yajl \
- libwdns.so:dns/wdns \
- libnmsg.so:net/nmsg
-RUN_DEPENDS= sie-nmsg>0:net/sie-nmsg
+ libwdns.so:dns/wdns
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
USES= gmake libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/yajl
-LDFLAGS+= -L${LOCALBASE}/lib
-
post-install:
.for i in 1 3 5 7
${INSTALL_MAN} ${WRKSRC}/man/*.${i} ${STAGEDIR}/${PREFIX}/man/man${i}
diff --git a/dns/dnstable/distinfo b/dns/dnstable/distinfo
index bcb24dcc6005..c388b3b2ae8b 100644
--- a/dns/dnstable/distinfo
+++ b/dns/dnstable/distinfo
@@ -1,2 +1,3 @@
-SHA256 (dnstable-0.9.1.tar.gz) = 392033297fa2a6e58ace6343bb4da6360ba4728b821c3e52118753e85930f26d
-SIZE (dnstable-0.9.1.tar.gz) = 409874
+TIMESTAMP = 1529893785
+SHA256 (dnstable-0.10.1.tar.gz) = a38ee2bb4121b8abd3689c7095c6d7af976591630ae55e1e5783d1ec710a51a8
+SIZE (dnstable-0.10.1.tar.gz) = 408504
diff --git a/dns/dnstable/files/patch-dnstable_query.c b/dns/dnstable/files/patch-dnstable_query.c
deleted file mode 100644
index a3b909ab78ed..000000000000
--- a/dns/dnstable/files/patch-dnstable_query.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- dnstable/query.c.orig 2014-05-21 21:37:25 UTC
-+++ dnstable/query.c
-@@ -15,6 +15,8 @@
- */
-
- #include <arpa/inet.h>
-+#include <sys/socket.h>
-+#include <sys/endian.h>
-
- #include "dnstable-private.h"
-
diff --git a/dns/dnstable/files/patch-src_dnstable__convert.c b/dns/dnstable/files/patch-src_dnstable__convert.c
deleted file mode 100644
index c83b1d1672e7..000000000000
--- a/dns/dnstable/files/patch-src_dnstable__convert.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/dnstable_convert.c.orig 2014-05-21 21:37:25 UTC
-+++ src/dnstable_convert.c
-@@ -24,6 +24,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
-+#include <sys/endian.h>
-
- #include <dnstable.h>
- #include <mtbl.h>
diff --git a/dns/dnstable/files/patch-src_dnstable__lookup.c b/dns/dnstable/files/patch-src_dnstable__lookup.c
deleted file mode 100644
index 9cda1c2c7206..000000000000
--- a/dns/dnstable/files/patch-src_dnstable__lookup.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/dnstable_lookup.c.orig 2014-04-02 00:26:43 UTC
-+++ src/dnstable_lookup.c
-@@ -23,6 +23,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
-+#include <sys/endian.h>
-
- #include <dnstable.h>
- #include <mtbl.h>
diff --git a/dns/dnstable/pkg-plist b/dns/dnstable/pkg-plist
index c0c1c9f4c591..3a72323e77a2 100644
--- a/dns/dnstable/pkg-plist
+++ b/dns/dnstable/pkg-plist
@@ -1,4 +1,3 @@
-bin/dnstable_convert
bin/dnstable_dump
bin/dnstable_lookup
bin/dnstable_merge
@@ -8,7 +7,6 @@ lib/libdnstable.so
lib/libdnstable.so.0
lib/libdnstable.so.0.0.0
libdata/pkgconfig/libdnstable.pc
-man/man1/dnstable_convert.1.gz
man/man1/dnstable_dump.1.gz
man/man1/dnstable_lookup.1.gz
man/man1/dnstable_merge.1.gz