aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2005-10-29 07:13:29 +0000
committerDoug Barton <dougb@FreeBSD.org>2005-10-29 07:13:29 +0000
commitcfda064524df95df7a3a4bcc39d53de830654a3a (patch)
tree0b5d354ef722c309198f41c36abd681847e2234f /dns
parent4aa008339dac2682d3d541f91c3b92cab1323cd4 (diff)
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind8/Makefile11
-rw-r--r--dns/bind8/distinfo4
-rw-r--r--dns/bind84/Makefile7
-rw-r--r--dns/bind9/Makefile6
-rw-r--r--dns/bind94/Makefile6
-rw-r--r--dns/bind95/Makefile6
-rw-r--r--dns/bind96/Makefile6
-rw-r--r--dns/fpdns/Makefile6
8 files changed, 44 insertions, 8 deletions
diff --git a/dns/bind8/Makefile b/dns/bind8/Makefile
index f0ea22eeb1d9..72497326f109 100644
--- a/dns/bind8/Makefile
+++ b/dns/bind8/Makefile
@@ -13,10 +13,13 @@
PORTNAME= bind
PORTVERSION= 8.3.7
CATEGORIES?= dns net
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind/src/${PORTVERSION}
-DISTFILES= bind-src.tar.gz bind-doc.tar.gz
+DISTFILES= bind-src.tar.gz bind-doc.tar.gz \
+ bind-src.tar.gz.asc bind-doc.tar.gz.asc
DIST_SUBDIR= bind-${PORTVERSION}
+EXTRACT_ONLY= bind-src.tar.gz bind-doc.tar.gz
MAINTAINER?= DougB@FreeBSD.org
COMMENT= The Berkeley Internet Name Domain, an implementation of DNS
@@ -53,6 +56,10 @@ PATCH_DIST_ARGS= -s -d ${WRKDIR}
WRKSRC= ${WRKDIR}/src
+verify: checksum
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-src.tar.gz.asc
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-doc.tar.gz.asc
+
post-patch:
@${SED} -e "s#\'DESTETC=.*#'DESTETC=${BIND_DESTETC}'#" \
-e "s#-O2 -g#${CFLAGS}#" \
diff --git a/dns/bind8/distinfo b/dns/bind8/distinfo
index 454da4fbcd5a..0fe316310d6a 100644
--- a/dns/bind8/distinfo
+++ b/dns/bind8/distinfo
@@ -2,3 +2,7 @@ MD5 (bind-8.3.7/bind-src.tar.gz) = 36cc1660eb7d73e872a1e5af6f832167
SIZE (bind-8.3.7/bind-src.tar.gz) = 1417083
MD5 (bind-8.3.7/bind-doc.tar.gz) = b7ccbde30d8c43202eabf61a51366852
SIZE (bind-8.3.7/bind-doc.tar.gz) = 1492990
+MD5 (bind-8.3.7/bind-src.tar.gz.asc) = f4814a77210b1035706702abd76e2df8
+SIZE (bind-8.3.7/bind-src.tar.gz.asc) = 187
+MD5 (bind-8.3.7/bind-doc.tar.gz.asc) = 97261ecda0ad770c359db9229b61b375
+SIZE (bind-8.3.7/bind-doc.tar.gz.asc) = 187
diff --git a/dns/bind84/Makefile b/dns/bind84/Makefile
index d06cf8d9892b..3c6f55108b73 100644
--- a/dns/bind84/Makefile
+++ b/dns/bind84/Makefile
@@ -13,7 +13,8 @@
PORTNAME= bind84
PORTVERSION= 8.4.6
CATEGORIES?= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind/src/${PORTVERSION}
DISTFILES= bind-src.tar.gz bind-doc.tar.gz \
bind-src.tar.gz.asc bind-doc.tar.gz.asc
@@ -55,6 +56,10 @@ PATCH_DIST_ARGS= -s -d ${WRKDIR}
WRKSRC= ${WRKDIR}/src
+verify: checksum
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-src.tar.gz.asc
+ gpg --verify ${DISTDIR}/${DIST_SUBDIR}/bind-doc.tar.gz.asc
+
post-patch:
@${SED} -e "s#\'DESTETC=.*#'DESTETC=${BIND_DESTETC}'#" \
-e "s#-O2 -g#${CFLAGS}#" \
diff --git a/dns/bind9/Makefile b/dns/bind9/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind9/Makefile
+++ b/dns/bind9/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/bind94/Makefile b/dns/bind94/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind94/Makefile
+++ b/dns/bind94/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/bind95/Makefile b/dns/bind95/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind95/Makefile
+++ b/dns/bind95/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
index 8792a0b42e67..1260e6068239 100644
--- a/dns/fpdns/Makefile
+++ b/dns/fpdns/Makefile
@@ -8,7 +8,8 @@
PORTNAME= fpdns
PORTVERSION= 0.9.3
CATEGORIES= dns net perl5
-MASTER_SITES= http://www.rfc.se/fpdns/distfiles/
+MASTER_SITES= http://www.rfc.se/fpdns/distfiles/ \
+ http://dougbarton.us/Downloads/
DISTNAME= Net-DNS-Fingerprint-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -28,6 +29,9 @@ MAN1= fpdns.1
IGNORE= Requires at least Perl version 5.6.0
.endif
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
+
file= ${WRKSRC}/blib/man1/fpdns.1
post-build:
@${SED} -e 's#\\&\\fIperl\\fR\\|(1), \\fINet::DNS\\fR\\|(1)#&, http://www.rfc.se/fpdns/#' \