aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-12-03 23:01:37 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-12-03 23:01:37 +0000
commit2a271253ff49509ae28420db8b778be21d84eb96 (patch)
treed49215c4d0b4e0be611311c3147ed92b169565c9 /dns
parent8a993c4fbb65106bb787e54deb731cef04f02d72 (diff)
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind95/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/dns/bind95/Makefile b/dns/bind95/Makefile
index 14fdb93aa158..b350a28c5593 100644
--- a/dns/bind95/Makefile
+++ b/dns/bind95/Makefile
@@ -33,7 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
-CONFLICTS= bind9*-9.[3467].* bind9-sdb-* host-*
+CONFLICTS= bind9*-9.[467].* bind9-sdb-* host-* bind-tools-9.*
OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
LINKS "Create conf file symlinks in ${PREFIX}" on \
@@ -43,6 +43,7 @@ OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
LARGE_FILE "64-bit file support" off \
SIGCHASE "dig/host/nslookup will do DNSSEC validation" off \
IPV6 "IPv6 Support (autodetected by default)" off \
+ THREADS "Compile with thread support" on \
DLZ_POSTGRESQL "DLZ Postgres driver" off \
DLZ_MYSQL "DLZ MySQL driver (single-threaded BIND)" off \
DLZ_BDB "DLZ BDB driver" off \
@@ -59,14 +60,6 @@ USE_OPENSSL= yes
ARCH= x86_64
.endif
-# We are ok by default from 7.0-RELEASE on
-.if ${OSVERSION} >= 700055
-OPTIONS+= THREADS "Compile with thread support" on
-.else
-OPTIONS+= THREADS "Compile w/threads (Not Recommended <FreeBSD-7)" off
-.endif
-
-
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.else
@@ -205,6 +198,7 @@ post-patch:
${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
.endfor
+PKGINSTALL= ${.CURDIR}/../bind97/pkg-install
post-install:
${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
${BIND_DESTETC}/rndc.conf.sample
@@ -218,12 +212,7 @@ post-install:
${DOCSDIR}/
.endif
.if !defined(WITHOUT_LINKS) && !defined(WITH_REPLACE_BASE)
- ${MKDIR} /var/named${PREFIX}/etc
-.for DIR in ${PREFIX}/etc /var/named${PREFIX}/etc
-.for FILE in named.conf rndc.key
- ${LN} -sf /etc/namedb/${FILE} ${DIR}/${FILE}
-.endfor
-.endfor
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
@${CAT} ${PKGMESSAGE}