aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-09-18 22:27:21 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-09-18 22:27:21 +0000
commit62ba2f0778f4ee4414312b99111589bf3c44a8b2 (patch)
tree51a9d020d254523e6ff3ba74fc629d34dd62acaf /dns
parent9304d10149ecc7a787d7af9263d3ef37974f2c8a (diff)
downloadports-62ba2f0778f4ee4414312b99111589bf3c44a8b2.tar.gz
ports-62ba2f0778f4ee4414312b99111589bf3c44a8b2.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind914/Makefile9
-rw-r--r--dns/bind914/distinfo6
-rw-r--r--dns/bind914/files/patch-configure8
3 files changed, 13 insertions, 10 deletions
diff --git a/dns/bind914/Makefile b/dns/bind914/Makefile
index fefdf57bf340..949de462c705 100644
--- a/dns/bind914/Makefile
+++ b/dns/bind914/Makefile
@@ -36,7 +36,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.14.5
+ISCVERSION= 9.14.6
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -72,7 +72,7 @@ OPTIONS_DEFAULT= DLZ_FILESYSTEM GSSAPI_NONE IDN JSON \
LMDB PYTHON SIGCHASE TCP_FASTOPEN
OPTIONS_DEFINE= DNSTAP DOCS FIXED_RRSET IDN JSON LARGE_FILE \
LMDB MINCACHE PORTREVISION PYTHON QUERYTRACE \
- SIGCHASE START_LATE TCP_FASTOPEN TUNING_LARGE
+ SIGCHASE START_LATE TCP_FASTOPEN TUNING_LARGE GEOIP
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= NATIVE_PKCS11
@@ -87,7 +87,7 @@ OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
.if defined(BIND_TOOLS_SLAVE)
OPTIONS_EXCLUDE= DOCS ${OPTIONS_GROUP_DLZ} \
MINCACHE PORTREVISION QUERYTRACE LMDB DNSTAP \
- START_LATE TUNING_LARGE TCP_FASTOPEN
+ START_LATE TUNING_LARGE TCP_FASTOPEN GEOIP
.else
OPTIONS_EXCLUDE= PYTHON
.endif # BIND_TOOLS_SLAVE
@@ -142,6 +142,9 @@ DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
FIXED_RRSET_CONFIGURE_ENABLE= fixed-rrset
+GEOIP_CONFIGURE_WITH= geoip2
+GEOIP_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
+
GSSAPI_BASE_CONFIGURE_ON=\
--with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_BASE_USES= gssapi
diff --git a/dns/bind914/distinfo b/dns/bind914/distinfo
index 38a919b40704..c075a0d19d84 100644
--- a/dns/bind914/distinfo
+++ b/dns/bind914/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1566490199
-SHA256 (bind-9.14.5.tar.gz) = 12d0672cb83d985b57038ce7eb8a71c6bc7ebd379d67109c5f966f7527988045
-SIZE (bind-9.14.5.tar.gz) = 6313555
+TIMESTAMP = 1568842517
+SHA256 (bind-9.14.6.tar.gz) = 8967a040ed900e1800293b9874357fc2f267f33c723aa617268e163bd921edfe
+SIZE (bind-9.14.6.tar.gz) = 6314291
diff --git a/dns/bind914/files/patch-configure b/dns/bind914/files/patch-configure
index fd4789cb62c5..37911e2dcf67 100644
--- a/dns/bind914/files/patch-configure
+++ b/dns/bind914/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-08-13 12:42:31 UTC
+--- configure.orig 2019-09-09 14:51:54 UTC
+++ configure
-@@ -16837,27 +16837,9 @@ done
+@@ -16836,27 +16836,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16900,47 +16882,7 @@ $as_echo "no" >&6; } ;;
+@@ -16899,47 +16881,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21571,7 +21513,7 @@ $as_echo "" >&6; }
+@@ -21408,7 +21350,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).