aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-10-16 22:54:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-10-16 22:54:07 +0000
commit8aa94801fc64b41df273b7efc1cb9d662fe72ac9 (patch)
treefd6de9845b552ae9ba3265a3bfbd9ab7418d9e9b /dns
parentd14df6c8018d5f6d6fc05bd9adffca635c7cca13 (diff)
downloadports-8aa94801fc64b41df273b7efc1cb9d662fe72ac9.tar.gz
ports-8aa94801fc64b41df273b7efc1cb9d662fe72ac9.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind914/Makefile2
-rw-r--r--dns/bind914/distinfo6
-rw-r--r--dns/bind914/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind914/files/patch-configure8
4 files changed, 14 insertions, 14 deletions
diff --git a/dns/bind914/Makefile b/dns/bind914/Makefile
index 949de462c705..a788ee3c8bf0 100644
--- a/dns/bind914/Makefile
+++ b/dns/bind914/Makefile
@@ -36,7 +36,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.14.6
+ISCVERSION= 9.14.7
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind914/distinfo b/dns/bind914/distinfo
index c075a0d19d84..4744a148ef60 100644
--- a/dns/bind914/distinfo
+++ b/dns/bind914/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1568842517
-SHA256 (bind-9.14.6.tar.gz) = 8967a040ed900e1800293b9874357fc2f267f33c723aa617268e163bd921edfe
-SIZE (bind-9.14.6.tar.gz) = 6314291
+TIMESTAMP = 1571265383
+SHA256 (bind-9.14.7.tar.gz) = cea0f54e5908f77ffd21eb312ee9dd4f3f8f93ca312c6118f27d6c0fba45291d
+SIZE (bind-9.14.7.tar.gz) = 6320994
diff --git a/dns/bind914/files/extrapatch-bind-min-override-ttl b/dns/bind914/files/extrapatch-bind-min-override-ttl
index f9e75a3460fa..812376137e00 100644
--- a/dns/bind914/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind914/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2019-08-13 12:42:31 UTC
+--- bin/named/config.c.orig 2019-10-02 06:24:10 UTC
+++ bin/named/config.c
@@ -181,6 +181,7 @@ options {\n\
notify-source *;\n\
@@ -8,7 +8,7 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-08-13 12:42:31 UTC
+--- bin/named/server.c.orig 2019-10-02 06:24:10 UTC
+++ bin/named/server.c
@@ -4246,6 +4246,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-08-13 12:42:31 UTC
+--- lib/dns/include/dns/view.h.orig 2019-10-02 06:24:10 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,7 @@ struct dns_view {
bool requestnsid;
@@ -32,9 +32,9 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-08-13 12:42:31 UTC
+--- lib/dns/resolver.c.orig 2019-10-02 06:24:10 UTC
+++ lib/dns/resolver.c
-@@ -6035,6 +6035,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6064,6 +6064,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -47,7 +47,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-08-13 12:42:31 UTC
+--- lib/isccfg/namedconf.c.orig 2019-10-02 06:24:10 UTC
+++ lib/isccfg/namedconf.c
@@ -1901,6 +1901,7 @@ view_clauses[] = {
#endif
diff --git a/dns/bind914/files/patch-configure b/dns/bind914/files/patch-configure
index 37911e2dcf67..dcac37925eab 100644
--- a/dns/bind914/files/patch-configure
+++ b/dns/bind914/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-09-09 14:51:54 UTC
+--- configure.orig 2019-10-02 06:24:10 UTC
+++ configure
-@@ -16836,27 +16836,9 @@ done
+@@ -16834,27 +16834,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16899,47 +16881,7 @@ $as_echo "no" >&6; } ;;
+@@ -16897,47 +16879,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21408,7 +21350,7 @@ $as_echo "" >&6; }
+@@ -21355,7 +21297,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).