aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-03-13 14:53:21 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-03-13 14:53:21 +0000
commitd725cb21aa80005feaed7568189ac339193ba8d4 (patch)
tree6fbfd82411b7aeb71fc5ff909f34995ac5128f34 /dns
parent1c16116ec7d6c36df87e44d6e14fd75416aeb8fe (diff)
downloadports-d725cb21aa80005feaed7568189ac339193ba8d4.tar.gz
ports-d725cb21aa80005feaed7568189ac339193ba8d4.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/ddclient/Makefile8
-rw-r--r--dns/ddclient/files/patch-ticket221
2 files changed, 26 insertions, 3 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index fee63c436422..9e6ac186af44 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ddclient
PORTVERSION= 3.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -35,11 +35,13 @@ PORTDOCS= COPYING COPYRIGHT Changelog README README.cisco README.ssl \
post-patch:
@${GREP} -lr '/usr' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g'
@${REINPLACE_CMD} \
- -e 's|/etc/ddclient|${PREFIX}/etc|' \
-e 's|/tmp|/var/tmp|' \
-e 's|/var/cache/ddclient|/var/tmp|' \
-e '/PATH/s|/etc:/usr/local/lib:||' \
- -e 's|/usr.*perl|${PERL}|g' ${WRKSRC}/ddclient
+ -e 's|/usr.*perl|${PERL}|g' \
+ -e 's|/usr/local|${LOCALBASE}|g' \
+ -e 's|/etc/ddclient|${PREFIX}/etc|' \
+ ${WRKSRC}/ddclient
do-install:
@${INSTALL_DATA} ${WRKSRC}/sample-etc_ddclient.conf ${PREFIX}/etc/ddclient.conf.sample
diff --git a/dns/ddclient/files/patch-ticket2 b/dns/ddclient/files/patch-ticket2
new file mode 100644
index 000000000000..ac4d331ff93d
--- /dev/null
+++ b/dns/ddclient/files/patch-ticket2
@@ -0,0 +1,21 @@
+--- ddclient.orig 2011-03-11 00:00:19.394750047 -0800
++++ ddclient 2011-03-11 00:04:28.967751644 -0800
+@@ -2094,10 +2094,14 @@
+ } elsif (defined($sub) && &$sub($host)) {
+ $update = 1;
+
+- } elsif (($cache{$host}{'static'} ne $config{$host}{'static'}) ||
+- ($cache{$host}{'wildcard'} ne $config{$host}{'wildcard'}) ||
+- ($cache{$host}{'mx'} ne $config{$host}{'mx'}) ||
+- ($cache{$host}{'backupmx'} ne $config{$host}{'backupmx'})) {
++ } elsif ((defined($cache{$host}{'static'}) && defined($config{$host}{'static'}) &&
++ ($cache{$host}{'static'} ne $config{$host}{'static'})) ||
++ (defined($cache{$host}{'wildcard'}) && defined($config{$host}{'wildcard'}) &&
++ ($cache{$host}{'wildcard'} ne $config{$host}{'wildcard'})) ||
++ (defined($cache{$host}{'mx'}) && defined($config{$host}{'mx'}) &&
++ ($cache{$host}{'mx'} ne $config{$host}{'mx'})) ||
++ (defined($cache{$host}{'backupmx'}) && defined($config{$host}{'backupmx'}) &&
++ ($cache{$host}{'backupmx'} ne $config{$host}{'backupmx'})) ) {
+ info("updating %s because host settings have been changed.", $host);
+ $update = 1;
+