aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-03-19 11:33:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-03-19 11:33:41 +0000
commit050686d569293d5b19049803a1b60b023dd90010 (patch)
tree646b52aa4f0f11bf328880a77b6df8e96f2922bd /dns
parent37334dd71e5e039d7860f3876fb646422183c828 (diff)
downloadports-050686d569293d5b19049803a1b60b023dd90010.tar.gz
ports-050686d569293d5b19049803a1b60b023dd90010.zip
Update to 9.16.1
Notes
Notes: svn path=/head/; revision=528714
Diffstat (limited to 'dns')
-rw-r--r--dns/bind916/Makefile7
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl20
-rw-r--r--dns/bind916/files/patch-bin_named_include_named_globals.h2
-rw-r--r--dns/bind916/files/patch-configure8
-rw-r--r--dns/bind916/pkg-plist6
6 files changed, 27 insertions, 22 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index 52ffc65e28bd..8369fd3ad7c8 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -8,7 +8,7 @@ PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
PORTREVISION= 0
.else
# dns/bind916 here
-PORTREVISION= 2
+PORTREVISION= 0
.endif
CATEGORIES= dns net
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -41,7 +41,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.0
+ISCVERSION= 9.16.1
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -65,8 +65,7 @@ EXTRA_PATCHES= ${PATCHDIR}/extrapatch-bind-tools
.else
USE_RC_SUBR= named
SUB_FILES= named.conf pkg-message
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-no-bind-tools \
- ${PATCHDIR}/bind-v9.16.0-tcp_quota_fix.patch:-p1
+EXTRA_PATCHES= ${PATCHDIR}/extrapatch-no-bind-tools
PORTDOCS= *
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index 3e09d093d56d..555ba5b7b4fe 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1582188168
-SHA256 (bind-9.16.0.tar.xz) = af4bd9bdaeb1aa7399429972f3a8aa01dd6886b7ae046d703ab8da45330f2e28
-SIZE (bind-9.16.0.tar.xz) = 4533976
+TIMESTAMP = 1584611383
+SHA256 (bind-9.16.1.tar.xz) = a913d7e78135b9123d233215b58102fa0f18130fb1e158465a1c2b6f3bd75e91
+SIZE (bind-9.16.1.tar.xz) = 4541768
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index cc96d758554f..3aa2db28d1dc 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,8 +1,8 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-02-12 20:03:44 UTC
+--- bin/named/config.c.orig 2020-03-11 16:46:53 UTC
+++ bin/named/config.c
-@@ -177,6 +177,7 @@ options {\n\
+@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-02-12 20:03:44 UTC
+--- bin/named/server.c.orig 2020-03-11 16:46:53 UTC
+++ bin/named/server.c
-@@ -4178,6 +4178,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4324,6 +4324,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-02-12 20:03:44 UTC
+--- lib/dns/include/dns/view.h.orig 2020-03-11 16:46:53 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-02-12 20:03:44 UTC
+--- lib/dns/resolver.c.orig 2020-03-11 16:46:53 UTC
+++ lib/dns/resolver.c
-@@ -5975,6 +5975,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6233,6 +6233,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,10 +49,10 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-02-12 20:03:44 UTC
+--- lib/isccfg/namedconf.c.orig 2020-03-11 16:46:53 UTC
+++ lib/isccfg/namedconf.c
-@@ -1993,6 +1993,7 @@ static cfg_clausedef_t view_clauses[] = {
- #endif
+@@ -1990,6 +1990,7 @@ static cfg_clausedef_t view_clauses[] = {
+ #endif /* ifdef HAVE_LMDB */
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
+ { "override-cache-ttl", &cfg_type_duration, 0 },
diff --git a/dns/bind916/files/patch-bin_named_include_named_globals.h b/dns/bind916/files/patch-bin_named_include_named_globals.h
index 9aca892474ff..36cc5a746f75 100644
--- a/dns/bind916/files/patch-bin_named_include_named_globals.h
+++ b/dns/bind916/files/patch-bin_named_include_named_globals.h
@@ -8,6 +8,6 @@ We reference the pid file as being run/named/pid everywere else.
EXTERN const char *named_g_defaultpidfile INIT(NAMED_LOCALSTATEDIR "/run/named/"
- "named.pid");
+ "pid");
- #else
+ #else /* if NAMED_RUN_PID_DIR */
EXTERN const char *named_g_defaultpidfile INIT(NAMED_LOCALSTATEDIR "/run/"
"named.pid");
diff --git a/dns/bind916/files/patch-configure b/dns/bind916/files/patch-configure
index 4a9229cb88f2..323a1cc70524 100644
--- a/dns/bind916/files/patch-configure
+++ b/dns/bind916/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2020-02-12 20:03:44 UTC
+--- configure.orig 2020-03-11 16:46:53 UTC
+++ configure
-@@ -17436,27 +17436,9 @@ done
+@@ -17437,27 +17437,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17499,47 +17481,7 @@ $as_echo "no" >&6; } ;;
+@@ -17500,47 +17482,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23046,7 +22988,7 @@ $as_echo "" >&6; }
+@@ -23049,7 +22991,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind916/pkg-plist b/dns/bind916/pkg-plist
index 7f8a9bff29df..d9bdd6884c28 100644
--- a/dns/bind916/pkg-plist
+++ b/dns/bind916/pkg-plist
@@ -51,6 +51,8 @@ include/dns/iptable.h
include/dns/journal.h
include/dns/keydata.h
include/dns/keyflags.h
+include/dns/kasp.h
+include/dns/keymgr.h
include/dns/keytable.h
include/dns/keyvalues.h
include/dns/lib.h
@@ -122,6 +124,7 @@ include/irs/resconf.h
include/irs/types.h
include/irs/version.h
include/isc/aes.h
+include/isc/align.h
include/isc/app.h
include/isc/assertions.h
include/isc/astack.h
@@ -168,10 +171,12 @@ include/isc/md.h
include/isc/mem.h
include/isc/meminfo.h
include/isc/mutex.h
+include/isc/mutexatomic.h
include/isc/mutexblock.h
include/isc/net.h
include/isc/netaddr.h
include/isc/netdb.h
+include/isc/netmgr.h
include/isc/netscope.h
include/isc/nonce.h
include/isc/offset.h
@@ -233,6 +238,7 @@ include/isccfg/aclconf.h
include/isccfg/cfg.h
include/isccfg/dnsconf.h
include/isccfg/grammar.h
+include/isccfg/kaspconf.h
include/isccfg/log.h
include/isccfg/namedconf.h
include/isccfg/version.h