aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 00:23:40 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 00:23:40 +0000
commit49d9214310549e568c0e8d34623d8bd50cf3af90 (patch)
tree25bfd69dc7a812d4b0dc9fbcc9be2bdb99840460 /dns
parent183765f2f10b67e6089579bda2e2d4ca7fedf3b0 (diff)
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-pgeodns/Makefile26
-rw-r--r--dns/p5-pgeodns/distinfo3
-rw-r--r--dns/p5-pgeodns/pkg-descr10
-rw-r--r--dns/p5-pgeodns/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 8cb929ef5214..3a32d37a694f 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -104,6 +104,7 @@
SUBDIR += p5-POE-Component-Server-DNS
SUBDIR += p5-Stanford-DNSserver
SUBDIR += p5-Tie-DNS
+ SUBDIR += p5-pgeodns
SUBDIR += pdnsd
SUBDIR += pear-File_DNS
SUBDIR += pear-Net_DNS
diff --git a/dns/p5-pgeodns/Makefile b/dns/p5-pgeodns/Makefile
new file mode 100644
index 000000000000..786626567f6e
--- /dev/null
+++ b/dns/p5-pgeodns/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pgeodns
+# Date created: 16 May 2009
+# Whom: Phillip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgeodns
+PORTVERSION= 1.32
+CATEGORIES= dns
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= A Geographic NameServer
+
+BUILD_DEPENDS= p5-Geo-IP>=0:${PORTSDIR}/net/p5-Geo-IP \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= pgeodns.pl.1
+
+.include <bsd.port.mk>
diff --git a/dns/p5-pgeodns/distinfo b/dns/p5-pgeodns/distinfo
new file mode 100644
index 000000000000..1dfb8497dab5
--- /dev/null
+++ b/dns/p5-pgeodns/distinfo
@@ -0,0 +1,3 @@
+MD5 (pgeodns-1.32.tar.gz) = d35ac0749a14e39acf3e45e878fedf77
+SHA256 (pgeodns-1.32.tar.gz) = 38e63eb4986c709864548ea533e61016ac366a6ed521eed7d891ddf742aaca5a
+SIZE (pgeodns-1.32.tar.gz) = 126722
diff --git a/dns/p5-pgeodns/pkg-descr b/dns/p5-pgeodns/pkg-descr
new file mode 100644
index 000000000000..44953d936bd6
--- /dev/null
+++ b/dns/p5-pgeodns/pkg-descr
@@ -0,0 +1,10 @@
+pgeodns is a simple DNS server that can distribute load for a
+hostname to the nearest mirrors (as defined by geography; on the
+country / continent level).
+
+It is used for search.cpan.org/cpansearch.perl.org and for
+ftp.perl.org/ftp.cpan.org; to provide nearby-ish
+servers for the NTP Pool; and to balance svn.apache.org to
+svn.us.apache.org and svn.eu.apache.org.
+
+WWW: http://geo.bitnames.com/
diff --git a/dns/p5-pgeodns/pkg-plist b/dns/p5-pgeodns/pkg-plist
new file mode 100644
index 000000000000..7de8fba3c5b7
--- /dev/null
+++ b/dns/p5-pgeodns/pkg-plist
@@ -0,0 +1,6 @@
+bin/pgeodns.pl
+%%SITE_PERL%%/Countries.pm
+%%SITE_PERL%%/GeoDNS.pm
+%%SITE_PERL%%/pgeodns.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/pgeodns/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/pgeodns/