aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-11-22 12:28:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-11-22 12:28:09 +0000
commit6a7d8f34f48848b09c5228f5677f8f950d084cef (patch)
tree3be9ce677719587c609662bac93eab3fd7dc840e /dns
parent4ef2814bb1c6cee23f05e4852daf2db64998a578 (diff)
downloadports-6a7d8f34f48848b09c5228f5677f8f950d084cef.tar.gz
ports-6a7d8f34f48848b09c5228f5677f8f950d084cef.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/ldns/Makefile4
-rw-r--r--dns/py-ldns/Makefile8
3 files changed, 13 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index e278954f32db..359ff5c10c7d 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -137,6 +137,7 @@
SUBDIR += py-dnspython
SUBDIR += py-easyzone
SUBDIR += py-idnkit2
+ SUBDIR += py-ldns
SUBDIR += py-namebench
SUBDIR += py-publicsuffix
SUBDIR += py-twistedNames
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 9b6cb71ad9af..02f3a7a44c2b 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -29,6 +29,10 @@ PYLDNS_DESC= ${PYTHON_DESC}
.if ${PORT_OPTIONS:MPYLDNS}
USE_PYTHON= yes
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+CONFLICTS= ldns-[0-9]*
+.else
+CONFLICTS= py*-ldns-[0-9]*
.endif
ALL_TARGET= all
diff --git a/dns/py-ldns/Makefile b/dns/py-ldns/Makefile
new file mode 100644
index 000000000000..55a9812e4cd6
--- /dev/null
+++ b/dns/py-ldns/Makefile
@@ -0,0 +1,8 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../../dns/ldns
+
+WITH_PYLDNS= yes
+
+.include "${MASTERDIR}/Makefile"