aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-08-21 09:16:43 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-08-21 09:16:43 +0000
commit39e5eb05d381ad85c7d638f96aa13f8ef7a2f334 (patch)
treeafb73cfda8e0d1feed850e2f57c4e2a8f4df4152 /dns
parenta312bc24ed4c5224089ccec7cbd5bd5edc394b3f (diff)
downloadports-39e5eb05d381ad85c7d638f96aa13f8ef7a2f334.tar.gz
ports-39e5eb05d381ad85c7d638f96aa13f8ef7a2f334.zip
MFH: r542640 r545578 r545579
Update to 9.11.22 and 9.16.6. Security: CVE-2020-8620, CVE-2020-8621, CVE-2020-8622, CVE-2020-8623, CVE-2020-8624 Approved by: ports-secteam (blanket)
Notes
Notes: svn path=/branches/2020Q3/; revision=545580
Diffstat (limited to 'dns')
-rw-r--r--dns/bind911/Makefile2
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind916/files/patch-configure8
6 files changed, 18 insertions, 18 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index 280278b641f8..f3d0f7a19883 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= cpe libedit pkgconfig
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.21
+ISCVERSION= 9.11.22
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index b82c01070c18..e51775d9a093 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594913197
-SHA256 (bind-9.11.21.tar.gz) = 668158b005b3de4328fa0dbbbb3f524b66f28f024c67538aa9412a9e69c9dfbc
-SIZE (bind-9.11.21.tar.gz) = 8248982
+TIMESTAMP = 1597735112
+SHA256 (bind-9.11.22.tar.gz) = afc6d8015006f1cabf699ff19f517bb8fd9c1811e5231f26baf51c3550262ac9
+SIZE (bind-9.11.22.tar.gz) = 8248081
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index 1cfb622803e7..4ec9e0ec12ba 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -41,7 +41,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.5
+ISCVERSION= 9.16.6
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index 8ee7d886ef39..2a5b225abec4 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594913262
-SHA256 (bind-9.16.5.tar.xz) = 6378b3e51fef11a8be4794dc48e8111ba92d211c0dfd129a0c296ed06a3dc075
-SIZE (bind-9.16.5.tar.xz) = 3474044
+TIMESTAMP = 1597735379
+SHA256 (bind-9.16.6.tar.xz) = b567b0f3b47dd03b345a4848af7f2acdd3f5cea2bd804edd85d9ef50743571cb
+SIZE (bind-9.16.6.tar.xz) = 3228368
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index 0eebb6d5eb7b..0d5be6d5fe1f 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-07-03 10:44:14 UTC
+--- bin/named/config.c.orig 2020-08-10 09:31:13 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-07-03 10:44:14 UTC
+--- bin/named/server.c.orig 2020-08-10 09:31:13 UTC
+++ bin/named/server.c
@@ -4330,6 +4330,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-07-03 10:44:14 UTC
+--- lib/dns/include/dns/view.h.orig 2020-08-10 09:31:13 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-07-03 10:44:14 UTC
+--- lib/dns/resolver.c.orig 2020-08-10 09:31:13 UTC
+++ lib/dns/resolver.c
-@@ -6256,6 +6256,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6268,6 +6268,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-07-03 10:44:14 UTC
+--- lib/isccfg/namedconf.c.orig 2020-08-10 09:31:13 UTC
+++ lib/isccfg/namedconf.c
@@ -1990,6 +1990,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind916/files/patch-configure b/dns/bind916/files/patch-configure
index f4c473335473..530869b3f50e 100644
--- a/dns/bind916/files/patch-configure
+++ b/dns/bind916/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2020-07-03 10:44:14 UTC
+--- configure.orig 2020-08-10 09:31:13 UTC
+++ configure
-@@ -17604,27 +17604,9 @@ done
+@@ -17574,27 +17574,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17667,47 +17649,7 @@ $as_echo "no" >&6; } ;;
+@@ -17637,47 +17619,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23213,7 +23155,7 @@ $as_echo "" >&6; }
+@@ -23183,7 +23125,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).