aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-09-05 13:48:51 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-09-05 13:48:51 +0000
commit512af8eae87699f475ec6bd455905638f9feb19d (patch)
treee1e3a76b31c09071782d38c60a01399c862d7bd6 /dns
parentc0e552f7083ecf1c9dd8ee48457e609fa23ae636 (diff)
downloadports-512af8eae87699f475ec6bd455905638f9feb19d.tar.gz
ports-512af8eae87699f475ec6bd455905638f9feb19d.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-sdb-ldap/Makefile5
-rw-r--r--dns/bind9-sdb-ldap/distinfo12
-rw-r--r--dns/bind9-sdb-ldap/files/patch-sdb_ldap23
-rw-r--r--dns/bind9-sdb-ldap/pkg-plist4
4 files changed, 24 insertions, 20 deletions
diff --git a/dns/bind9-sdb-ldap/Makefile b/dns/bind9-sdb-ldap/Makefile
index 0da04c267546..4a1801968f85 100644
--- a/dns/bind9-sdb-ldap/Makefile
+++ b/dns/bind9-sdb-ldap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bind9
-PORTVERSION= 9.3.2
+PORTVERSION= 9.4.1.1
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -23,7 +23,7 @@ USE_OPENLDAP= yes
CONFLICTS= bind-8.* bind84-8.* bind9-9.* bind9-dlz-* host-* skalibs-*
# ISC releases things like 9.3.0rc1, which our versioning doesn't like
-ISCVERSION= 9.3.2
+ISCVERSION= 9.4.1-P1
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps --with-openssl \
@@ -86,6 +86,7 @@ MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+MLINKS= named-checkzone.8 named-compilezone.8
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
diff --git a/dns/bind9-sdb-ldap/distinfo b/dns/bind9-sdb-ldap/distinfo
index 309110894648..f3523f39911c 100644
--- a/dns/bind9-sdb-ldap/distinfo
+++ b/dns/bind9-sdb-ldap/distinfo
@@ -1,6 +1,6 @@
-MD5 (bind-9.3.2.tar.gz) = 55e709501a7780233c36e25ccd15ece2
-SHA256 (bind-9.3.2.tar.gz) = 4d4298abd85d06083a0643091dde05ffbe3db051439524dbe4a81c689735c694
-SIZE (bind-9.3.2.tar.gz) = 5302112
-MD5 (bind-9.3.2.tar.gz.asc) = 06eccb8a9122e0f6efa9502cc61f5006
-SHA256 (bind-9.3.2.tar.gz.asc) = b7a9bc3852bb75e390d457e4449083a90c1c267f68fae00f317b9712ef726cf3
-SIZE (bind-9.3.2.tar.gz.asc) = 187
+MD5 (bind-9.4.1-P1.tar.gz) = 44e0514e6105ddaa235394045d9aeb0c
+SHA256 (bind-9.4.1-P1.tar.gz) = 912d07be9a6b4fa180d38637bf32ac4e802b087e46fbbf2a76314ecc3444b693
+SIZE (bind-9.4.1-P1.tar.gz) = 6341409
+MD5 (bind-9.4.1-P1.tar.gz.asc) = 2d93fd12d3aa9895c23c09784f7fe0b7
+SHA256 (bind-9.4.1-P1.tar.gz.asc) = b66a7ad4a8dd2a375fb961ab9b8a744fa55b034c0b7233b4490b6351e36f5030
+SIZE (bind-9.4.1-P1.tar.gz.asc) = 478
diff --git a/dns/bind9-sdb-ldap/files/patch-sdb_ldap b/dns/bind9-sdb-ldap/files/patch-sdb_ldap
index 14c7ee47110d..dad5fea1eda2 100644
--- a/dns/bind9-sdb-ldap/files/patch-sdb_ldap
+++ b/dns/bind9-sdb-ldap/files/patch-sdb_ldap
@@ -700,28 +700,27 @@ diff -ruN ../bind-9.3.1.org/bin/named/ldapdb.c ./bin/named/ldapdb.c
diff -ruN ../bind-9.3.1.org/bin/named/main.c ./bin/named/main.c
--- ../bind-9.3.1.org/bin/named/main.c Wed Jun 22 22:34:55 2005
+++ ./bin/named/main.c Wed Jun 22 22:47:38 2005
-@@ -71,6 +71,7 @@
+@@ -72,6 +72,7 @@
* Include header files for database drivers here.
*/
/* #include "xxdb.h" */
+#include <ldapdb.h>
- static isc_boolean_t want_stats = ISC_FALSE;
- static char program_name[ISC_DIR_NAMEMAX] = "named";
-@@ -656,6 +657,7 @@
+ /*
+ * Include DLZ drivers if appropriate.
+@@ -681,6 +682,7 @@
* Add calls to register sdb drivers here.
*/
/* xxdb_init(); */
+ ldapdb_init();
- ns_server_create(ns_g_mctx, &ns_g_server);
- }
-@@ -672,7 +674,7 @@
- * Add calls to unregister sdb drivers here.
+ #ifdef DLZ
+ /*
+@@ -707,6 +709,7 @@
+ * Add calls to unregister sdb drivers here.
*/
/* xxdb_clear(); */
--
+ ldapdb_clear();
- isc_log_write(ns_g_lctx, NS_LOGCATEGORY_GENERAL, NS_LOGMODULE_MAIN,
- ISC_LOG_NOTICE, "exiting");
- ns_log_shutdown();
+
+ #ifdef DLZ
+ /*
diff --git a/dns/bind9-sdb-ldap/pkg-plist b/dns/bind9-sdb-ldap/pkg-plist
index 3bafa4d5e1a1..2bd02dfaf584 100644
--- a/dns/bind9-sdb-ldap/pkg-plist
+++ b/dns/bind9-sdb-ldap/pkg-plist
@@ -130,6 +130,7 @@ include/isc/resultclass.h
include/isc/rwlock.h
include/isc/serial.h
include/isc/sha1.h
+include/isc/sha2.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/stdio.h
@@ -159,6 +160,7 @@ include/isccc/symtype.h
include/isccc/types.h
include/isccc/util.h
include/isccc/version.h
+include/isccfg/aclconf.h
include/isccfg/cfg.h
include/isccfg/grammar.h
include/isccfg/log.h
@@ -189,6 +191,7 @@ sbin/lwresd
sbin/named
sbin/named-checkconf
sbin/named-checkzone
+sbin/named-compilezone
sbin/rndc
sbin/rndc-confgen
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
@@ -204,6 +207,7 @@ sbin/rndc-confgen
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch07.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch08.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch09.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch10.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.html
%%PORTDOCS%%%%DOCSDIR%%/misc/dnssec
%%PORTDOCS%%%%DOCSDIR%%/misc/format-options.pl