aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2010-03-12 12:54:34 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2010-03-12 12:54:34 +0000
commit65f3f3ca6254bb8ed42542b8472a0e1359a7afdf (patch)
treea4fa772af38e861216cb68684fff6483b25f4b58 /dns
parent571442219aa75f7d8184cb6228a57169e05801c6 (diff)
downloadports-65f3f3ca6254bb8ed42542b8472a0e1359a7afdf.tar.gz
ports-65f3f3ca6254bb8ed42542b8472a0e1359a7afdf.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/unbound/Makefile3
-rw-r--r--dns/unbound/distinfo6
-rw-r--r--dns/unbound/files/patch-fix-ipv6348
3 files changed, 4 insertions, 353 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 27ad8cb06130..b54f417db7f4 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= unbound
-PORTVERSION= 1.4.1
-PORTREVISION= 1
+PORTVERSION= 1.4.3
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
diff --git a/dns/unbound/distinfo b/dns/unbound/distinfo
index 4cc7abccb7ce..62db1d6f0c5e 100644
--- a/dns/unbound/distinfo
+++ b/dns/unbound/distinfo
@@ -1,3 +1,3 @@
-MD5 (unbound-1.4.1.tar.gz) = 1e03ef9618e4bca02005bd99bc6af75c
-SHA256 (unbound-1.4.1.tar.gz) = 2573db422d7a856a3783b96698f2d5ca18a849d0bd6f0e36eb37a4f0a65b60e2
-SIZE (unbound-1.4.1.tar.gz) = 4191123
+MD5 (unbound-1.4.3.tar.gz) = 2dffdd42f94b8238447a41835439d129
+SHA256 (unbound-1.4.3.tar.gz) = 7c212228234547af776d51067a04a8c32f572e5db493e16a269370da4413070f
+SIZE (unbound-1.4.3.tar.gz) = 4283735
diff --git a/dns/unbound/files/patch-fix-ipv6 b/dns/unbound/files/patch-fix-ipv6
deleted file mode 100644
index 7f7d99e0c715..000000000000
--- a/dns/unbound/files/patch-fix-ipv6
+++ /dev/null
@@ -1,348 +0,0 @@
-Index: iterator/iter_delegpt.c
-===================================================================
---- iterator/iter_delegpt.c (revision 1952)
-+++ iterator/iter_delegpt.c (revision 1953)
-@@ -154,11 +154,13 @@
- /* ignore it */
- return 1;
- }
-- if(addr_is_ip6(addr, addrlen))
-- ns->got6 = 1;
-- else ns->got4 = 1;
-- if(ns->got4 && ns->got6)
-- ns->resolved = 1;
-+ if(!lame) {
-+ if(addr_is_ip6(addr, addrlen))
-+ ns->got6 = 1;
-+ else ns->got4 = 1;
-+ if(ns->got4 && ns->got6)
-+ ns->resolved = 1;
-+ }
- return delegpt_add_addr(dp, region, addr, addrlen, bogus, lame, nodup);
- }
-
-@@ -254,10 +256,11 @@
- (dp->bogus?" BOGUS":"") );
- }
- for(a = dp->target_list; a; a = a->next_target) {
-- if(a->bogus)
-- log_addr(VERB_ALGO, " BOGUS ",
-- &a->addr, a->addrlen);
-- else log_addr(VERB_ALGO, " ", &a->addr, a->addrlen);
-+ const char* str = " ";
-+ if(a->bogus && a->lame) str = " BOGUS ADDR_LAME ";
-+ else if(a->bogus) str = " BOGUS ";
-+ else if(a->lame) str = " ADDR_LAME ";
-+ log_addr(VERB_ALGO, str, &a->addr, a->addrlen);
- }
- }
- }
-@@ -448,3 +451,13 @@
- }
- }
- }
-+
-+void delegpt_no_ipv6(struct delegpt* dp)
-+{
-+ struct delegpt_ns* ns;
-+ for(ns = dp->nslist; ns; ns = ns->next) {
-+ /* no ipv6, so only ipv4 is enough to resolve a nameserver */
-+ if(ns->got4)
-+ ns->resolved = 1;
-+ }
-+}
-Index: iterator/iter_delegpt.h
-===================================================================
---- iterator/iter_delegpt.h (revision 1952)
-+++ iterator/iter_delegpt.h (revision 1953)
-@@ -314,4 +314,11 @@
- */
- void delegpt_add_neg_msg(struct delegpt* dp, struct msgreply_entry* msg);
-
-+/**
-+ * Register the fact that there is no ipv6 and thus AAAAs are not going
-+ * to be queried for or be useful.
-+ * @param dp: the delegation point. Updated to reflect no ipv6.
-+ */
-+void delegpt_no_ipv6(struct delegpt* dp);
-+
- #endif /* ITERATOR_ITER_DELEGPT_H */
-Index: iterator/iterator.c
-===================================================================
---- iterator/iterator.c (revision 1952)
-+++ iterator/iterator.c (revision 1953)
-@@ -1305,6 +1305,8 @@
- verbose(VERB_QUERY, "Failed to get a delegation, giving up");
- return error_response(qstate, id, LDNS_RCODE_SERVFAIL);
- }
-+ if(!ie->supports_ipv6)
-+ delegpt_no_ipv6(iq->dp);
- delegpt_log(VERB_ALGO, iq->dp);
-
- if(iq->num_current_queries>0) {
-Index: doc/Changelog
-===================================================================
---- doc/Changelog (revision 1952)
-+++ doc/Changelog (revision 1953)
-@@ -1,3 +1,11 @@
-+8 January 2010: Wouter
-+ - Fix for parent-child disagreement code which could have trouble
-+ when (a) ipv6 was disabled and (b) the TTL for parent and child
-+ were different. There were two bugs, the parent-side information
-+ is fixed to no longer block lookup of child side information and
-+ the iterator is fixed to no longer attempt to get ipv6 when it is
-+ not enabled and then give up in failure.
-+
- 7 January 2010: Wouter
- - Fixup python documentation (thanks Leo Vandewoestijne).
- - Work on cache prefetch feature.
-Index: testdata/iter_pcttl.rpl
-===================================================================
---- testdata/iter_pcttl.rpl (revision 0)
-+++ testdata/iter_pcttl.rpl (revision 1953)
-@@ -0,0 +1,245 @@
-+; config options
-+server:
-+ target-fetch-policy: "0 0 0 0 0"
-+ do-ip6: no
-+
-+stub-zone:
-+ name: "."
-+ stub-addr: 193.0.14.129 # K.ROOT-SERVERS.NET.
-+CONFIG_END
-+
-+SCENARIO_BEGIN Test cache ttls where parent child differ in ttl
-+; and the lameness for parent suddenly becomes the only information point.
-+
-+; K.ROOT-SERVERS.NET.
-+RANGE_BEGIN 0 100
-+ ADDRESS 193.0.14.129
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY QR NOERROR
-+SECTION QUESTION
-+. IN NS
-+SECTION ANSWER
-+. IN NS K.ROOT-SERVERS.NET.
-+SECTION ADDITIONAL
-+K.ROOT-SERVERS.NET. IN A 193.0.14.129
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode subdomain
-+ADJUST copy_id copy_query
-+REPLY QR NOERROR
-+SECTION QUESTION
-+com. IN NS
-+SECTION AUTHORITY
-+com. IN NS a.gtld-servers.net.
-+SECTION ADDITIONAL
-+a.gtld-servers.net. IN A 192.5.6.30
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode subdomain
-+ADJUST copy_id copy_query
-+REPLY QR NOERROR
-+SECTION QUESTION
-+net. IN NS
-+SECTION AUTHORITY
-+net. IN NS e.gtld-servers.net.
-+SECTION ADDITIONAL
-+e.gtld-servers.net. IN A 192.12.94.30
-+ENTRY_END
-+
-+RANGE_END
-+
-+; a.gtld-servers.net.
-+RANGE_BEGIN 0 100
-+ ADDRESS 192.5.6.30
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY QR NOERROR
-+SECTION QUESTION
-+com. IN NS
-+SECTION ANSWER
-+com. IN NS a.gtld-servers.net.
-+SECTION ADDITIONAL
-+a.gtld-servers.net. IN A 192.5.6.30
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode subdomain
-+ADJUST copy_id copy_query
-+REPLY QR NOERROR
-+SECTION QUESTION
-+example.com. IN NS
-+SECTION AUTHORITY
-+example.com. IN NS ns.foo.com.
-+SECTION ADDITIONAL
-+;ns.foo.com. 200 IN A 1.2.3.44
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode subdomain
-+ADJUST copy_id copy_query
-+REPLY QR NOERROR
-+SECTION QUESTION
-+foo.com. IN NS
-+SECTION AUTHORITY
-+foo.com. 200 IN NS ns.foo.com.
-+SECTION ADDITIONAL
-+ns.foo.com. 200 IN A 1.2.3.44
-+ENTRY_END
-+
-+RANGE_END
-+
-+; e.gtld-servers.net.
-+RANGE_BEGIN 0 100
-+ ADDRESS 192.12.94.30
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY QR NOERROR
-+SECTION QUESTION
-+net. IN NS
-+SECTION ANSWER
-+net. IN NS e.gtld-servers.net.
-+SECTION ADDITIONAL
-+e.gtld-servers.net. IN A 192.12.94.30
-+ENTRY_END
-+
-+RANGE_END
-+
-+; ns.foo.com.
-+; The parent-IP version
-+RANGE_BEGIN 0 100
-+ ADDRESS 1.2.3.44
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY AA QR NOERROR
-+SECTION QUESTION
-+foo.com. IN NS
-+SECTION ANSWER
-+foo.com. 200 IN NS ns.foo.com.
-+SECTION ADDITIONAL
-+ns.foo.com. 100 IN A 1.2.3.44
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY AA QR NOERROR
-+SECTION QUESTION
-+ns.foo.com. IN A
-+SECTION ANSWER
-+ns.foo.com. 100 IN A 1.2.3.44
-+SECTION AUTHORITY
-+foo.com. 200 IN NS ns.foo.com.
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY AA QR NOERROR
-+SECTION QUESTION
-+ns.foo.com. IN AAAA
-+SECTION AUTHORITY
-+foo.com. 100 IN SOA . . 1 2 3 4 5
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY AA QR NOERROR
-+SECTION QUESTION
-+example.com. IN NS
-+SECTION ANSWER
-+example.com. 200 IN NS ns.foo.com.
-+ENTRY_END
-+
-+ENTRY_BEGIN
-+MATCH opcode qtype qname
-+ADJUST copy_id
-+REPLY AA QR NOERROR
-+SECTION QUESTION
-+www.example.com. IN A
-+SECTION ANSWER
-+www.example.com. 100 IN A 10.20.30.40
-+SECTION AUTHORITY
-+example.com. 200 IN NS ns.foo.com.
-+SECTION ADDITIONAL
-+ns.foo.com 100 IN A 1.2.3.44
-+ENTRY_END
-+RANGE_END
-+
-+; NOT USED. The parent side equals child side but not in the cache.
-+; and they have different TTLs only.
-+; ns.foo.com
-+; The child IP version. Does not respond to anything (servfail instead
-+; of timeouts since this is easier to encode in .rpl file format).
-+RANGE_BEGIN 0 100
-+ ADDRESS 1.2.3.55
-+ENTRY_BEGIN
-+MATCH opcode
-+ADJUST copy_id copy_query
-+REPLY QR SERVFAIL
-+SECTION QUESTION
-+foo.com. IN NS
-+SECTION ANSWER
-+ENTRY_END
-+
-+RANGE_END
-+
-+STEP 1 QUERY
-+ENTRY_BEGIN
-+REPLY RD
-+SECTION QUESTION
-+www.example.com. IN A
-+ENTRY_END
-+
-+; recursion happens here.
-+STEP 20 CHECK_ANSWER
-+ENTRY_BEGIN
-+MATCH all
-+REPLY QR RD RA NOERROR
-+SECTION QUESTION
-+www.example.com. IN A
-+SECTION ANSWER
-+www.example.com. 100 IN A 10.20.30.40
-+SECTION AUTHORITY
-+example.com. 100 IN NS ns.foo.com.
-+; scrubbed off
-+;SECTION ADDITIONAL
-+;ns.foo.com IN A 1.2.3.44
-+ENTRY_END
-+
-+; Now we wait 101 seconds, and the child data is gone,
-+; but the parent-side was cached for 200 and it still there.
-+
-+STEP 30 TIME_PASSES ELAPSE 101
-+
-+STEP 40 QUERY
-+ENTRY_BEGIN
-+REPLY RD
-+SECTION QUESTION
-+www.example.com. IN A
-+ENTRY_END
-+
-+; recursion happens here.
-+STEP 50 CHECK_ANSWER
-+ENTRY_BEGIN
-+MATCH all
-+REPLY QR RD RA NOERROR
-+SECTION QUESTION
-+www.example.com. IN A
-+SECTION ANSWER
-+www.example.com. 100 IN A 10.20.30.40
-+SECTION AUTHORITY
-+example.com. 100 IN NS ns.foo.com.
-+; scrubbed off
-+;SECTION ADDITIONAL
-+;ns.foo.com IN A 1.2.3.44
-+ENTRY_END
-+
-+SCENARIO_END