aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
commitc3d8037aeba75366ed06e02fbc981e15b46e7d0a (patch)
tree6074bae79118b7d7d4d3d3a8ac0a4dcd65f18f8b /dns
parentb286f01b6c3af5d674e10da33f8eda0c2011007b (diff)
downloadports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.tar.gz
ports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/dnrd/Makefile2
-rw-r--r--dns/nsd/Makefile2
-rw-r--r--dns/posadis/Makefile2
-rw-r--r--dns/updatedd/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/dns/dnrd/Makefile b/dns/dnrd/Makefile
index 8863ca3003a8..4576bd595125 100644
--- a/dns/dnrd/Makefile
+++ b/dns/dnrd/Makefile
@@ -18,7 +18,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_RC_SUBR= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
.if defined(WITH_TCP)
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 4ff12f8d9fb3..ee191c80b20a 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --with-user=${NSDUSER} \
--with-pidfile=/var/run/nsd.pid \
--with-dbfile=${NSDDBFILE} \
--with-libwrap
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
SED_SCRIPT= -e 's,%%NSDUSER%%,${NSDUSER},g' \
-e 's,%%NSDDIR%%,${NSDDIR},g' \
diff --git a/dns/posadis/Makefile b/dns/posadis/Makefile
index 1ff4a42fe287..bcd290a24dbf 100644
--- a/dns/posadis/Makefile
+++ b/dns/posadis/Makefile
@@ -21,7 +21,7 @@ USE_AUTOCONF_VER= 259
USE_LIBTOOL_VER= 15
USE_LIBLTDL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so)
diff --git a/dns/updatedd/Makefile b/dns/updatedd/Makefile
index fd2eef31fa41..b2b1ff2d1288 100644
--- a/dns/updatedd/Makefile
+++ b/dns/updatedd/Makefile
@@ -18,7 +18,7 @@ COMMENT= Dynamic DNS Update Client supporting multiple services
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LIBDIR= ${PREFIX}/lib/${PORTNAME}