aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-23 12:13:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-23 12:13:11 +0000
commite01844530d93936764399ead9d794a369fc27e81 (patch)
tree1e7da3f423a940dc6d268ff8bb11ea8e0a15a389 /dns
parent7a660f28cd0d465b2ae2e80eb66e33afd5eacaf7 (diff)
downloadports-e01844530d93936764399ead9d794a369fc27e81.tar.gz
ports-e01844530d93936764399ead9d794a369fc27e81.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-dns3/Makefile25
-rw-r--r--dns/py-dns3/distinfo2
-rw-r--r--dns/py-dns3/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 3c21a2b06117..082e2c8c5c20 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -139,6 +139,7 @@
SUBDIR += powerdns-recursor
SUBDIR += py-adns
SUBDIR += py-dns
+ SUBDIR += py-dns3
SUBDIR += py-dnspython
SUBDIR += py-easyzone
SUBDIR += py-idnkit2
diff --git a/dns/py-dns3/Makefile b/dns/py-dns3/Makefile
new file mode 100644
index 000000000000..2720c9fdc014
--- /dev/null
+++ b/dns/py-dns3/Makefile
@@ -0,0 +1,25 @@
+# Created by: Mark Linimon <linimon@lonesome.com>
+# $FreeBSD$
+
+PORTNAME= dns
+PORTVERSION= 3.0.4
+CATEGORIES= dns python
+MASTER_SITES= https://launchpadlibrarian.net/146975379/ \
+ LOCAL/sunpoet
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 3
+DISTNAME= py3dns-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= DNS (Domain Name Service) library for Python 3
+
+LICENSE= CNRI
+LICENSE_NAME= CNRI LICENSE AGREEMENT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+PYDISTUTILS_AUTOPLIST= yes
+USE_PYDISTUTILS=yes
+USE_PYTHON= 3
+
+.include <bsd.port.mk>
diff --git a/dns/py-dns3/distinfo b/dns/py-dns3/distinfo
new file mode 100644
index 000000000000..e534895d1823
--- /dev/null
+++ b/dns/py-dns3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (py3dns-3.0.4.tar.gz) = a487285f725e7c01c4e1e7d511e56ccbc4c1ae5b34eaa5dd09990fec944fae53
+SIZE (py3dns-3.0.4.tar.gz) = 27524
diff --git a/dns/py-dns3/pkg-descr b/dns/py-dns3/pkg-descr
new file mode 100644
index 000000000000..11c606ba2b57
--- /dev/null
+++ b/dns/py-dns3/pkg-descr
@@ -0,0 +1,6 @@
+This directory contains a Python module that implements a DNS (Domain
+Name Server) client, plus additional modules that define some symbolic
+constants used by DNS (dnstype, dnsclass, dnsopcode).
+
+WWW: http://pydns.sourceforge.net/
+WWW: https://launchpad.net/py3dns