aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-07-15 15:08:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-07-15 15:08:14 +0000
commit5b94764eb87bef147cffc5f580bde340985045fa (patch)
treecc24c33fd1ade0315282fbf2f8359c0d5c00c9e0 /dns
parent7b5e2c3ae6d9f5ffcdc7e3356373805653b064da (diff)
downloadports-5b94764eb87bef147cffc5f580bde340985045fa.tar.gz
ports-5b94764eb87bef147cffc5f580bde340985045fa.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-devel/Makefile59
-rw-r--r--dns/powerdns-devel/distinfo4
-rw-r--r--dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in11
-rw-r--r--dns/powerdns-devel/files/patch-pdns_Makefile_in38
-rw-r--r--dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc31
-rw-r--r--dns/powerdns-devel/pkg-descr2
6 files changed, 79 insertions, 66 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index 17af23e5480a..8f9a3d1dd349 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= powerdns
-PORTVERSION= 3.2.r4
-PORTREVISION?= 1
+PORTVERSION= 3.3.r1
+PORTREVISION?= 0
PORTEPOCH= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://powerdnssec.org/downloads/
@@ -23,6 +23,7 @@ CONFLICTS= powerdns-[2-3].[0-9]*
NO_LATEST_LINK= YES
+USES= pkgconfig
USE_GMAKE= YES
USE_SUBMAKE= YES
USE_AUTOTOOLS= libtool
@@ -32,7 +33,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-modules="" \
--with-dynmodules="pipe ${CONFIGURE_MODULES}" \
--sysconfdir="${PREFIX}/etc/pdns" \
- --with-boost="${LOCALBASE}" \
+ --with-boost="${LOCALBASE}"
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
CURDIR2="${.CURDIR}" \
MKDIR="${MKDIR}" \
@@ -42,7 +43,9 @@ MAN8= pdns_control.8 pdns_server.8 zone2sql.8
SUB_FILES= pkg-message
-OPTIONS_DEFINE= PGSQL PGSQL_LOCAL MYSQL MYSQL_LOCAL SQLITE SQLITE3 OPENDBX OPENLDAP OPENLDAP_LOCAL GEO DNSSEC
+OPTIONS_DEFINE= PGSQL PGSQL_LOCAL MYSQL MYSQL_LOCAL SQLITE SQLITE3 OPENDBX OPENLDAP OPENLDAP_LOCAL GEO DNSSEC POLARSSL
+OPTIONS_MULTI= DNSSEC
+OPTIONS_MULTI_DNSSEC= BOTAN110 CRYPTOPP
PGSQL_DESC= PostgreSQL backend
PGSQL_LOCAL_DESC= RUN_DEPEND on PostgreSQL server
@@ -54,9 +57,12 @@ OPENDBX_DESC= OpenDBX backend
OPENLDAP_DESC= OpenLDAP backend
OPENLDAP_LOCAL_DESC= RUN_DEPEND on OpenLDAP server
GEO_DESC= Geo backend
-DNSSEC_DESC= Enable extra DNSSEC algorithms (13 & 14)
+DNSSEC_DESC= Enable extra DNSSEC options
+BOTAN110_DESC= Faster signing + ECDSA & GOST algorithms
+CRYPTOPP_DESC= ECDSA algorithms
+POLARSSL_DESC= Use embedded PolarSSL
-OPTIONS_DEFAULT= PGSQL
+OPTIONS_DEFAULT= PGSQL DNSSEC BOTAN110 POLARSSL
.include <bsd.port.options.mk>
@@ -72,7 +78,7 @@ PLIST_SUB+= WITHGEO="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE} && ${PORT_OPTIONS:MSQLITE3}
-BROKEN= choose only one SQLite backend version
+BROKEN= choose only one SQLite backend version
.endif
.if ${PORT_OPTIONS:MPGSQL}
@@ -89,8 +95,6 @@ PLIST_SUB+= WITHPGSQL="@comment "
USE_MYSQL?= YES
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
CONFIGURE_MODULES+= "gmysql"
-#CXXFLAGS+= -I${LOCALBASE}/include/mysql
-#LDFLAGS+= -L${LOCALBASE}/lib/mysql
PLIST_SUB+= WITHMYSQL=""
.else
CONFIGURE_ARGS+= --without-mysql
@@ -99,21 +103,19 @@ PLIST_SUB+= WITHMYSQL="@comment "
.if ${PORT_OPTIONS:MOPENDBX} || ${PORT_OPTIONS:MPGSQL}
. if ${PORT_OPTIONS:MPGSQL_LOCAL}
-USE_PGSQL?= YES
-RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-SUB_LIST+= PGSQL=postgresql
+USE_PGSQL?= server
+SUB_LIST+= PGSQL=postgresql
. endif
.else
-SUB_LIST+= PGSQL=
+SUB_LIST+= PGSQL=
.endif
.if ${PORT_OPTIONS:MOPENDBX} || ${PORT_OPTIONS:MMYSQL}
. if ${PORT_OPTIONS:MMYSQL_LOCAL}
-USE_MYSQL?= YES
-RUN_DEPENDS+= mysql-server>=0:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
-SUB_LIST+= MYSQL=mysql
+USE_MYSQL?= server
+SUB_LIST+= MYSQL=mysql
. endif
.else
-SUB_LIST+= MYSQL=
+SUB_LIST+= MYSQL=
.endif
.if ${PORT_OPTIONS:MOPENLDAP}
@@ -122,10 +124,10 @@ CONFIGURE_MODULES+= "ldap"
CXXFLAGS+= -L${LOCALBASE}/lib -DLDAP_DEPRECATED=1
PLIST_SUB+= WITHOPENLDAP=""
. if ${PORT_OPTIONS:MOPENLDAP_LOCAL}
-RUN_DEPENDS+= openldap-server>=0:${PORTSDIR}/net/openldap${WANT_OPENLDAP_VER}-server
-SUB_LIST+= SLAPD=slapd
+RUN_DEPENDS+= openldap-server>=0:${PORTSDIR}/net/openldap${WANT_OPENLDAP_VER}-server
+SUB_LIST+= SLAPD=slapd
. else
-SUB_LIST+= SLAPD=
+SUB_LIST+= SLAPD=
. endif
.else
PLIST_SUB+= WITHOPENLDAP="@comment "
@@ -157,8 +159,23 @@ CXXFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= WITHOPENDBX="@comment "
.endif
-.if ${PORT_OPTIONS:MDNSSEC}
+.if ${PORT_OPTIONS:MPOLARSSL}
+CONFIGURE_ARGS+= --without-system-polarssl
+.else
+LIB_DEPENDS+= polarssl:${PORTSDIR}/security/polarssl
+.endif
+
+.if ${PORT_OPTIONS:MBOTAN110}
+CONFIGURE_ARGS+= --enable-botan1.10
+LIB_DEPENDS+= botan-1.10:${PORTSDIR}/security/botan110
+.endif
+
+.if ${PORT_OPTIONS:MCRYPTOPP}
+. if exists(${LOCALBASE}/lib/libcryptopp.so)
+LIB_DEPENDS+= cryptopp:${PORTSDIR}/security/cryptopp
+. else
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
+. endif
CONFIGURE_ARGS+= --enable-cryptopp
.endif
diff --git a/dns/powerdns-devel/distinfo b/dns/powerdns-devel/distinfo
index c8d7a52dd5d3..1ba5f0cc2f31 100644
--- a/dns/powerdns-devel/distinfo
+++ b/dns/powerdns-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pdns-3.2-rc4.tar.gz) = adcf5f651811fb979f9033a3c156492c5637b3f9c872f335ac24ffa046a60934
-SIZE (pdns-3.2-rc4.tar.gz) = 1292662
+SHA256 (pdns-3.3-rc1.tar.gz) = 06269412693aae5925c338f8f03ea32d60584e1b206310dffc451a15039694e9
+SIZE (pdns-3.3-rc1.tar.gz) = 1333561
diff --git a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in b/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
index 91e11a68ef41..e69de29bb2d1 100644
--- a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
+++ b/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
@@ -1,11 +0,0 @@
---- modules/gpgsqlbackend/Makefile.in.org 2009-01-28 10:55:21.000000000 +0100
-+++ modules/gpgsqlbackend/Makefile.in 2009-01-28 11:02:29.000000000 +0100
-@@ -217,8 +217,8 @@
- AM_CPPFLAGS = @THREADFLAGS@
- lib_LTLIBRARIES = libgpgsqlbackend.la
- EXTRA_DIST = OBJECTFILES OBJECTLIBS
--INCLUDES = -I@PGSQL_incdir@
-+INCLUDES = -I@includedir@ -I@PGSQL_incdir@
- libgpgsqlbackend_la_SOURCES = gpgsqlbackend.cc gpgsqlbackend.hh \
- spgsql.hh spgsql.cc
-
diff --git a/dns/powerdns-devel/files/patch-pdns_Makefile_in b/dns/powerdns-devel/files/patch-pdns_Makefile_in
new file mode 100644
index 000000000000..e87fba9566c1
--- /dev/null
+++ b/dns/powerdns-devel/files/patch-pdns_Makefile_in
@@ -0,0 +1,38 @@
+--- pdns/Makefile.in.orig 2013-05-28 08:12:43.000000000 +0200
++++ pdns/Makefile.in 2013-06-03 11:39:18.377503664 +0200
+@@ -53,7 +53,7 @@
+ dnsscan$(EXEEXT) nproxy$(EXEEXT) notify$(EXEEXT) \
+ pdnssec$(EXEEXT) dnsbulktest$(EXEEXT) nsec3dig$(EXEEXT)
+ @BOTAN110_TRUE@am__append_3 = botan110signers.cc botansigners.cc
+-@BOTAN110_TRUE@am__append_4 = $(BOTAN110_LIBS) -lgmp -lrt
++@BOTAN110_TRUE@am__append_4 = $(BOTAN110_LIBS)
+ @BOTAN18_TRUE@am__append_5 = botan18signers.cc botansigners.cc
+ @BOTAN18_TRUE@am__append_6 = $(BOTAN18_LIBS) -lgmp
+ @CRYPTOPP_TRUE@am__append_7 = cryptoppsigners.cc
+@@ -61,7 +61,7 @@
+ @SQLITE3_TRUE@am__append_9 = ssqlite3.cc ssqlite3.hh
+ @ORACLE_TRUE@am__append_10 = $(ORACLE_LIBS)
+ @BOTAN110_TRUE@am__append_11 = botan110signers.cc botansigners.cc
+-@BOTAN110_TRUE@am__append_12 = $(BOTAN110_LIBS) -lgmp -lrt
++@BOTAN110_TRUE@am__append_12 = $(BOTAN110_LIBS)
+ @BOTAN18_TRUE@am__append_13 = botan18signers.cc botansigners.cc
+ @BOTAN18_TRUE@am__append_14 = $(BOTAN18_LIBS) -lgmp
+ @CRYPTOPP_TRUE@am__append_15 = cryptoppsigners.cc
+@@ -752,7 +752,7 @@
+ pdns_server_LDFLAGS = @moduleobjects@ @modulelibs@ @DYNLINKFLAGS@ @LIBDL@ @THREADFLAGS@ $(BOOST_SERIALIZATION_LDFLAGS) -rdynamic
+ pdns_server_LDADD = ext/polarssl-1.1.2/library/libpolarssl.a \
+ $(BOOST_SERIALIZATION_LIBS) $(LUA_LIBS) $(SQLITE3_LIBS) \
+- $(LIBCURL_LIBS) $(MYSQL_lib) $(am__append_4) $(am__append_6) \
++ $(am__append_4) $(am__append_6) \
+ $(am__append_8) $(am__append_10)
+ pdnssec_SOURCES = pdnssec.cc dbdnsseckeeper.cc sstuff.hh dnsparser.cc \
+ dnsparser.hh dnsrecords.cc dnswriter.cc dnswriter.hh misc.cc \
+@@ -775,7 +775,7 @@
+ pdnssec_LDFLAGS = @moduleobjects@ @modulelibs@ @DYNLINKFLAGS@ @LIBDL@ @THREADFLAGS@ $(BOOST_PROGRAM_OPTIONS_LDFLAGS) $(BOOST_SERIALIZATION_LDFLAGS)
+ pdnssec_LDADD = ext/polarssl-1.1.2/library/libpolarssl.a \
+ $(BOOST_PROGRAM_OPTIONS_LIBS) $(BOOST_SERIALIZATION_LIBS) \
+- $(SQLITE3_LIBS) $(LIBCURL_LIBS) $(MYSQL_lib) $(am__append_12) \
++ $(SQLITE3_LIBS) $(am__append_12) \
+ $(am__append_14) $(am__append_16) $(am__append_18)
+ sdig_SOURCES = sdig.cc sstuff.hh dnsparser.cc dnsparser.hh dnsrecords.cc dnswriter.cc dnslabeltext.cc dnswriter.hh \
+ misc.cc misc.hh rcpgenerator.cc rcpgenerator.hh base64.cc base64.hh unix_utility.cc \
diff --git a/dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc b/dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc
deleted file mode 100644
index 66de02685293..000000000000
--- a/dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc
+++ /dev/null
@@ -1,31 +0,0 @@
---- pdns/cryptoppsigners.cc (revision 3032)
-+++ pdns/cryptoppsigners.cc (working copy)
-@@ -82,18 +82,26 @@
- storvect.push_back(make_pair("PrivateKey", string((char*)buffer, sizeof(buffer))));
- return storvect;
- }
-+
- template<class HASHER, class CURVE, int BITS>
- void CryptoPPECDSADNSCryptoKeyEngine<HASHER,CURVE,BITS>::fromISCMap(DNSKEYRecordContent& drc, std::map<std::string, std::string>& stormap )
- {
-+ AutoSeededRandomPool prng;
- privatekey_t* privateKey = new privatekey_t;
-- const CryptoPP::Integer x;
-+ const CryptoPP::Integer x(reinterpret_cast<const unsigned char*>(stormap["privatekey"].c_str()), BITS/8); // well it should be this long
- CryptoPP::OID oid=CURVE();
-- privateKey->Initialize(oid, x );
-+ privateKey->Initialize(oid, x);
-+ bool result = privateKey->Validate(prng, 3);
-+ if (!result) {
-+ throw "Cannot load private key - validation failed!";
-+ }
- d_key = shared_ptr<privatekey_t>(privateKey);
- publickey_t* publicKey = new publickey_t();
- d_key->MakePublicKey(*publicKey);
- d_pubkey = shared_ptr<publickey_t>(publicKey);
-+ drc.d_algorithm = atoi(stormap["algorithm"].c_str());
- }
-+
- template<class HASHER, class CURVE, int BITS>
- std::string CryptoPPECDSADNSCryptoKeyEngine<HASHER,CURVE,BITS>::getPubKeyHash() const
- {
diff --git a/dns/powerdns-devel/pkg-descr b/dns/powerdns-devel/pkg-descr
index df31acd7a636..4e448bb16bb3 100644
--- a/dns/powerdns-devel/pkg-descr
+++ b/dns/powerdns-devel/pkg-descr
@@ -1,4 +1,4 @@
PowerDNS is an advanced DNS server, which allows for several different
backends. Current backends include MySQL, PostgreSQL, bind, etc.
-WWW: http://www.powerdns.com/
+WWW: http://www.powerdns.com/