aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2018-05-29 12:29:16 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2018-05-29 12:29:16 +0000
commit2bea94a572baa5d5e74109429ec662cc2692c42f (patch)
tree8b2e58881a7d67cb07099bfa7ce19e2994ebbcfe /dns
parent78bd5b65c8788cd1f1594e7251323bbd3dbb71e2 (diff)
downloadports-2bea94a572baa5d5e74109429ec662cc2692c42f.tar.gz
ports-2bea94a572baa5d5e74109429ec662cc2692c42f.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-aiodns/Makefile28
-rw-r--r--dns/py-aiodns/distinfo3
-rw-r--r--dns/py-aiodns/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 64dedb98d972..2b7a09c49085 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -181,6 +181,7 @@
SUBDIR += powerdns-recursor
SUBDIR += powerdns-recursor40
SUBDIR += public_suffix_list
+ SUBDIR += py-aiodns
SUBDIR += py-cloudflare
SUBDIR += py-dns
SUBDIR += py-dns-lexicon
diff --git a/dns/py-aiodns/Makefile b/dns/py-aiodns/Makefile
new file mode 100644
index 000000000000..80eb5e37e36e
--- /dev/null
+++ b/dns/py-aiodns/Makefile
@@ -0,0 +1,28 @@
+# Created by: Waitman Gobble <waitman@waitman.net>
+# $FreeBSD$
+
+PORTNAME= aiodns
+PORTVERSION= 1.1.1
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= waitman@waitman.net
+COMMENT= Simple DNS resolver for asyncio
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= DOCS
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+PORTDOCS= README.rst
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/dns/py-aiodns/distinfo b/dns/py-aiodns/distinfo
new file mode 100644
index 000000000000..288c29b255fe
--- /dev/null
+++ b/dns/py-aiodns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527547369
+SHA256 (aiodns-1.1.1.tar.gz) = d8677adc679ce8d0ef706c14d9c3d2f27a0e0cc11d59730cdbaf218ad52dd9ea
+SIZE (aiodns-1.1.1.tar.gz) = 6084
diff --git a/dns/py-aiodns/pkg-descr b/dns/py-aiodns/pkg-descr
new file mode 100644
index 000000000000..b565e6b0cfbd
--- /dev/null
+++ b/dns/py-aiodns/pkg-descr
@@ -0,0 +1,4 @@
+aiodns provides a simple way for doing asynchronous DNS resolutions
+with a synchronous looking interface by using pycares.
+
+WWW: https://pypi.org/project/aiodns/