aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-05-21 12:32:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-05-21 12:32:59 +0000
commit51d67d40291b37e54a8abee85e1aa454ec7d3252 (patch)
treebfb2b0382f40b206ebed9d4cabe2101196eff962 /dns
parentc736b75f3701c79dfdaf95d38d3f664b6e1a3ef1 (diff)
downloadports-51d67d40291b37e54a8abee85e1aa454ec7d3252.tar.gz
ports-51d67d40291b37e54a8abee85e1aa454ec7d3252.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-bin_named_include_named_globals.h4
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in11
-rw-r--r--dns/bind9-devel/pkg-plist3
7 files changed, 29 insertions, 21 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 3fe1d87ce03b..c4ec370c1596 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -34,13 +34,13 @@ LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.0a0.2018.05.14
+ISCVERSION= 9.13.0a0.2018.05.18
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 34de85dab844040f896f56d4891bc5afd4f30d1b
+GL_COMMIT= e8dd921ef96582c1dbed099015f8e45e00ede439
# XXX: remove tar:bz2
USES= cpe libedit ssl tar:bz2
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 4fc6f15be32f..fb2a6f2c8b7a 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526294640
-SHA256 (isc-projects-bind9-34de85dab844040f896f56d4891bc5afd4f30d1b_GL0.tar.gz) = 2346a94f464d971084157a5fff91f6c16805bb9596ee54a731dd04cc52a5d789
-SIZE (isc-projects-bind9-34de85dab844040f896f56d4891bc5afd4f30d1b_GL0.tar.gz) = 8955815
+TIMESTAMP = 1526897763
+SHA256 (isc-projects-bind9-e8dd921ef96582c1dbed099015f8e45e00ede439_GL0.tar.gz) = 986f430c0e814dfd06ed457eb8c39955e6e61a3b628a03f5ffd103de4313bdfb
+SIZE (isc-projects-bind9-e8dd921ef96582c1dbed099015f8e45e00ede439_GL0.tar.gz) = 8922126
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 49c87f961176..d659e08099dc 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2018-05-05 00:51:14 UTC
+--- bin/named/config.c.orig 2018-05-18 05:44:02 UTC
+++ bin/named/config.c
-@@ -175,12 +175,14 @@ options {\n\
+@@ -174,12 +174,14 @@ options {\n\
max-recursion-queries 75;\n\
max-stale-ttl 604800; /* 1 week */\n\
message-compression yes;\n\
@@ -15,9 +15,9 @@
provide-ixfr true;\n\
query-source address *;\n\
query-source-v6 address *;\n\
---- bin/named/server.c.orig 2018-05-05 00:51:14 UTC
+--- bin/named/server.c.orig 2018-05-18 05:44:02 UTC
+++ bin/named/server.c
-@@ -4068,6 +4068,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4072,6 +4072,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-05-05 00:51:14 UTC
+--- lib/dns/include/dns/view.h.orig 2018-05-18 05:44:02 UTC
+++ lib/dns/include/dns/view.h
@@ -149,6 +149,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -45,7 +45,7 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-05-05 00:51:14 UTC
+--- lib/dns/resolver.c.orig 2018-05-18 05:44:02 UTC
+++ lib/dns/resolver.c
@@ -5746,6 +5746,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -66,7 +66,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-05-05 00:51:14 UTC
+--- lib/isccfg/namedconf.c.orig 2018-05-18 05:44:02 UTC
+++ lib/isccfg/namedconf.c
@@ -1916,6 +1916,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
diff --git a/dns/bind9-devel/files/patch-bin_named_include_named_globals.h b/dns/bind9-devel/files/patch-bin_named_include_named_globals.h
index 3e953906012b..dba6a591278d 100644
--- a/dns/bind9-devel/files/patch-bin_named_include_named_globals.h
+++ b/dns/bind9-devel/files/patch-bin_named_include_named_globals.h
@@ -1,8 +1,8 @@
We reference the pid file as being run/named/pid everywere else.
---- bin/named/include/named/globals.h.orig 2018-02-26 06:30:28 UTC
+--- bin/named/include/named/globals.h.orig 2018-05-18 05:44:02 UTC
+++ bin/named/include/named/globals.h
-@@ -128,7 +128,7 @@ EXTERN isc_boolean_t named_g_forcelock
+@@ -126,7 +126,7 @@ EXTERN isc_boolean_t named_g_forcelock
#if NAMED_RUN_PID_DIR
EXTERN const char * named_g_defaultpidfile INIT(NAMED_LOCALSTATEDIR
"/run/named/"
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index a24ea582f25d..bcc648ba45e4 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-05-14 07:26:43 UTC
+--- configure.orig 2018-05-18 05:44:02 UTC
+++ configure
-@@ -14772,27 +14772,9 @@ done
+@@ -14770,27 +14770,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14835,47 +14817,7 @@ $as_echo "no" >&6; } ;;
+@@ -14833,47 +14815,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23436,7 +23378,7 @@ $as_echo "" >&6; }
+@@ -23338,7 +23280,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in b/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in
new file mode 100644
index 000000000000..013dd1db0de0
--- /dev/null
+++ b/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in
@@ -0,0 +1,11 @@
+--- lib/isc/include/isc/Makefile.in.orig 2018-05-18 05:44:02 UTC
++++ lib/isc/include/isc/Makefile.in
+@@ -21,7 +21,7 @@ VERSION=@BIND9_VERSION@
+ HEADERS = aes.h app.h assertions.h backtrace.h base32.h base64.h \
+ bind9.h boolean.h buffer.h bufferlist.h \
+ commandline.h counter.h crc64.h deprecated.h \
+- entropy.h errno.h error.h event.h eventclass.h \
++ errno.h error.h event.h eventclass.h \
+ file.h formatcheck.h fsaccess.h fuzz.h \
+ hash.h heap.h hex.h hmacmd5.h hmacsha.h ht.h httpd.h \
+ interfaceiter.h @ISC_IPV6_H@ iterated_hash.h \
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index b986cedcfa73..d16500756e98 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -149,7 +149,6 @@ include/isc/counter.h
include/isc/crc64.h
include/isc/deprecated.h
include/isc/dir.h
-include/isc/entropy.h
include/isc/errno.h
include/isc/error.h
include/isc/event.h
@@ -311,7 +310,6 @@ man/man8/dnssec-revoke.8.gz
man/man8/dnssec-settime.8.gz
man/man8/dnssec-signzone.8.gz
man/man8/dnssec-verify.8.gz
-man/man8/genrandom.8.gz
man/man8/named-checkconf.8.gz
man/man8/named-checkzone.8.gz
man/man8/named-compilezone.8.gz
@@ -339,7 +337,6 @@ sbin/dnssec-revoke
sbin/dnssec-settime
sbin/dnssec-signzone
sbin/dnssec-verify
-sbin/genrandom
sbin/named
sbin/named-checkconf
sbin/named-checkzone