aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-02-06 02:10:45 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-02-06 02:10:45 +0000
commit546f1a49025fd3b86982898bb07ec216e1643857 (patch)
tree14cc7e6bd1718eaea65fd4f7d0fb43c7eef0d4f3 /dns
parent7bddd6aa83bdc8163e9c29d52108c8cbffd34c02 (diff)
downloadports-546f1a49025fd3b86982898bb07ec216e1643857.tar.gz
ports-546f1a49025fd3b86982898bb07ec216e1643857.zip
MFH: r564177
dns/powerdns-recursor: unbreak build with lua54 Switch to autoreconf to avoid heavy multilina patching of configure script PR: 253078 Submitted by: fluffy Approved by: maintainer
Notes
Notes: svn path=/branches/2021Q1/; revision=564179
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-recursor/Makefile4
-rw-r--r--dns/powerdns-recursor/files/patch-configure15
-rw-r--r--dns/powerdns-recursor/files/patch-m4_pdns__check__libcrypto.m415
-rw-r--r--dns/powerdns-recursor/files/patch-m4_pdns__with__lua.m411
4 files changed, 28 insertions, 17 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 67a4b773eb94..64e7f5ed8a02 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -23,8 +23,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_context.so:devel/boost-libs \
libprotobuf.so:devel/protobuf
-USES= compiler:c++11-lib cpe gmake localbase:ldflags pkgconfig ssl \
- tar:bzip2
+USES= autoreconf compiler:c++11-lib cpe gmake libtool localbase:ldflags \
+ pkgconfig ssl tar:bzip2
CPE_VENDOR= powerdns
USE_RC_SUBR= pdns-recursor
diff --git a/dns/powerdns-recursor/files/patch-configure b/dns/powerdns-recursor/files/patch-configure
deleted file mode 100644
index fa0470671ce0..000000000000
--- a/dns/powerdns-recursor/files/patch-configure
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.orig 2020-05-08 09:56:25 UTC
-+++ configure
-@@ -21467,8 +21467,10 @@ fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for openssl/crypto.h in $ssldir" >&5
- $as_echo_n "checking for openssl/crypto.h in $ssldir... " >&6; }
- if test -f "$ssldir/include/openssl/crypto.h"; then
-- LIBCRYPTO_INCLUDES="-I$ssldir/include"
-- LIBCRYPTO_LDFLAGS="-L$ssldir/lib"
-+ if test $ssldir != /usr; then
-+ LIBCRYPTO_INCLUDES="-I$ssldir/include"
-+ LIBCRYPTO_LDFLAGS="-L$ssldir/lib"
-+ fi
- LIBCRYPTO_LIBS="-lcrypto"
- found=true
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
diff --git a/dns/powerdns-recursor/files/patch-m4_pdns__check__libcrypto.m4 b/dns/powerdns-recursor/files/patch-m4_pdns__check__libcrypto.m4
new file mode 100644
index 000000000000..7d4a832a79e6
--- /dev/null
+++ b/dns/powerdns-recursor/files/patch-m4_pdns__check__libcrypto.m4
@@ -0,0 +1,15 @@
+--- m4/pdns_check_libcrypto.m4.orig 2020-11-16 16:30:04 UTC
++++ m4/pdns_check_libcrypto.m4
+@@ -75,8 +75,10 @@ AC_DEFUN([PDNS_CHECK_LIBCRYPTO], [
+ for ssldir in $ssldirs; do
+ AC_MSG_CHECKING([for openssl/crypto.h in $ssldir])
+ if test -f "$ssldir/include/openssl/crypto.h"; then
+- LIBCRYPTO_INCLUDES="-I$ssldir/include"
+- LIBCRYPTO_LDFLAGS="-L$ssldir/lib"
++ if test $ssldir != /usr; then
++ LIBCRYPTO_INCLUDES="-I$ssldir/include"
++ LIBCRYPTO_LDFLAGS="-L$ssldir/lib"
++ fi
+ LIBCRYPTO_LIBS="-lcrypto"
+ found=true
+ AC_MSG_RESULT([yes])
diff --git a/dns/powerdns-recursor/files/patch-m4_pdns__with__lua.m4 b/dns/powerdns-recursor/files/patch-m4_pdns__with__lua.m4
new file mode 100644
index 000000000000..ca71a8619a53
--- /dev/null
+++ b/dns/powerdns-recursor/files/patch-m4_pdns__with__lua.m4
@@ -0,0 +1,11 @@
+--- m4/pdns_with_lua.m4.orig 2020-09-30 10:42:53 UTC
++++ m4/pdns_with_lua.m4
+@@ -41,7 +41,7 @@ AC_DEFUN([PDNS_WITH_LUA],[
+ ], [ : ])
+ AS_IF([test -z "$LUAPC"], [
+ found_lua=n
+- m4_foreach_w([luapc], [lua5.3 lua-5.3 lua53 lua5.2 lua-5.2 lua52 lua5.1 lua-5.1 lua51 lua], [
++ m4_foreach_w([luapc], [lua5.4 lua-5.4 lua54 lua5.3 lua-5.3 lua53 lua5.2 lua-5.2 lua52 lua5.1 lua-5.1 lua51 lua], [
+ AS_IF([test "$found_lua" != "y"], [
+ PKG_CHECK_MODULES([LUA], [luapc >= ${lua_min_version}], [
+ AC_DEFINE([HAVE_LUA], [1], [Define to 1 if you have lua])