aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-07-16 01:23:02 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-07-16 01:23:02 +0000
commit751004fcf2073c9701f87ce3bb5dfbd5d07f4a6d (patch)
treecb72ab959cc1bc1f902b5beea10f56027559797d /dns
parent1120a18a32d1a8c68c4bff223dd5de3a06b19884 (diff)
downloadports-751004fcf2073c9701f87ce3bb5dfbd5d07f4a6d.tar.gz
ports-751004fcf2073c9701f87ce3bb5dfbd5d07f4a6d.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsmasq/Makefile27
-rw-r--r--dns/dnsmasq/files/dnsmasq.sh.in (renamed from dns/dnsmasq/files/dnsmasq.sh)10
2 files changed, 17 insertions, 20 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index f3cf22ce5310..687af49afdc0 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -13,28 +13,27 @@ MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
MAINTAINER= steven@honson.org
COMMENT= Lightweight, easy to configure DNS forwarder and DHCP server
-USE_REINPLACE= yes
-USE_RC_SUBR= yes
-
MAN8= dnsmasq.8
-PLIST_FILES= sbin/dnsmasq etc/dnsmasq.conf.example etc/rc.d/dnsmasq.sh
+PLIST_FILES= sbin/dnsmasq etc/dnsmasq.conf.example
+
+USE_GETOPT_LONG=yes
+MAKE_ENV= LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}"
-USE_GETOPT_LONG= yes
-MAKE_ENV+= "LIBS=${LDFLAGS}"
.if defined(WITHOUT_IPV6)
-MAKE_ENV+= RPM_OPT_FLAGS="${CPPFLAGS} -DNO_IPV6"
-.else
-MAKE_ENV+= RPM_OPT_FLAGS="${CPPFLAGS}"
+MAKE_ENV+= -DNO_IPV6
.endif
-post-build:
- @${SED} -e "s|%%RC_SUBR%%|${RC_SUBR}|g;s|%%PREFIX%%|${PREFIX}|g" \
- <${FILESDIR}/dnsmasq.sh >${WRKDIR}/dnsmasq.sh
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500037
+USE_RC_SUBR= dnsmasq.sh
+.else
+USE_RCORDER= dnsmasq.sh
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${PREFIX}/etc
- ${INSTALL_SCRIPT} ${WRKDIR}/dnsmasq.sh ${PREFIX}/etc/rc.d
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/dnsmasq/files/dnsmasq.sh b/dns/dnsmasq/files/dnsmasq.sh.in
index c723b1ec3361..2f661e4a132c 100644
--- a/dns/dnsmasq/files/dnsmasq.sh
+++ b/dns/dnsmasq/files/dnsmasq.sh.in
@@ -1,9 +1,9 @@
#! /bin/sh
#
-#
-# PROVIDE: dnsmasq
-# REQUIRE: DAEMON NETWORKING SERVERS
-# KEYWORD: FreeBSD
+# PROVIDE: named dnsmasq
+# REQUIRE: SERVERS cleanvar
+# BEFORE: DAEMON
+# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf to enable dnsmasq:
#
@@ -13,7 +13,6 @@
# override these variables in /etc/rc.conf
dnsmasq_enable=NO
-
. %%RC_SUBR%%
name=dnsmasq
@@ -22,7 +21,6 @@ rcvar=$(set_rcvar)
command=%%PREFIX%%/sbin/${name}
pidfile=/var/run/${name}.pid
required_files=${dnsmasq_conf}
-#start_precmd=${name}_precmd
load_rc_config ${name}
run_rc_command "$1"