aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-02-17 13:11:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-02-17 13:11:25 +0000
commitc55354ffc898e173d71753991ae26eb059da7c28 (patch)
tree69c92e01e05c6c1a77ccf36b2f764bbff2b2d47e /dns
parenta76dec2a6e84b83f5325cdc90bfe4b4f96c44ccd (diff)
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/totd/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/dns/totd/Makefile b/dns/totd/Makefile
index 9f7ac020f466..e28d1d50e957 100644
--- a/dns/totd/Makefile
+++ b/dns/totd/Makefile
@@ -10,20 +10,23 @@ MASTER_SITES= ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/
MAINTAINER= ed@FreeBSD.org
COMMENT= DNS proxy that supports IPv6 <==> IPv4 record translation
+USES= desthack uidfix
+
USE_RC_SUBR= totd
GNU_CONFIGURE= yes
-MAN8= totd.8
-PLIST_FILES= etc/totd.conf.sample sbin/totd
+PLIST_FILES= etc/totd.conf.sample sbin/totd \
+ man/man8/totd.8.gz
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ne_mesg.c \
${FILESDIR}/extra-patch-tcp_response.c
-NO_STAGE= yes
+MAKE_ARGS= CC="${CC}"
+
post-patch:
- @${REINPLACE_CMD} -e '/^CC/d' ${WRKSRC}/${MAKEFILE}.in
+ ${REINPLACE_CMD} -e 's/-o bin -g bin//g; s/-o root -g wheel//g' ${WRKSRC}/Makefile.in
post-install:
- ${INSTALL_DATA} ${FILESDIR}/totd.conf.sample ${PREFIX}/etc
+ ${INSTALL_DATA} ${FILESDIR}/totd.conf.sample ${STAGEDIR}${PREFIX}/etc
.include <bsd.port.mk>