aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
commitb59621d3ae883bef429a8fae6073bfa293a55222 (patch)
treeb415c7b2903cf47ada68c5557c3c6ac33a25fc41 /dns
parente93c09b8f3675471a176b72ae1e6f085f7a607ad (diff)
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/p5-Net-DNS-SEC/Makefile10
-rw-r--r--dns/p5-Net-Domain-ExpireDate/Makefile8
-rw-r--r--dns/p5-POE-Component-Resolver/Makefile11
3 files changed, 25 insertions, 4 deletions
diff --git a/dns/p5-Net-DNS-SEC/Makefile b/dns/p5-Net-DNS-SEC/Makefile
index bee921dde190..5f16c79a55a7 100644
--- a/dns/p5-Net-DNS-SEC/Makefile
+++ b/dns/p5-Net-DNS-SEC/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0.03:${PORTSDIR}/security/p5-Crypt-OpenSSL
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-MIME-Base32>=0:${PORTSDIR}/converters/p5-MIME-Base32 \
p5-Net-DNS>=0.64:${PORTSDIR}/dns/p5-Net-DNS
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -33,4 +33,10 @@ MAN3= Net::DNS::Keyset.3 Net::DNS::RR::DS.3 Net::DNS::RR::KEY.3 \
Net::DNS::RR::NSEC.3 Net::DNS::RR::DNSKEY.3 \
Net::DNS::RR::NSEC3.3 Net::DNS::RR::NSEC3PARAM.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-Digest-SHA>=5.23:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/dns/p5-Net-Domain-ExpireDate/Makefile b/dns/p5-Net-Domain-ExpireDate/Makefile
index a1c78f4ab828..b88534e8e667 100644
--- a/dns/p5-Net-Domain-ExpireDate/Makefile
+++ b/dns/p5-Net-Domain-ExpireDate/Makefile
@@ -24,4 +24,10 @@ MAN3= Net::Domain::ExpireDate.3
post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -delete
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/dns/p5-POE-Component-Resolver/Makefile b/dns/p5-POE-Component-Resolver/Makefile
index 45a1baaaa356..2f13ae509627 100644
--- a/dns/p5-POE-Component-Resolver/Makefile
+++ b/dns/p5-POE-Component-Resolver/Makefile
@@ -29,4 +29,13 @@ PERL_CONFIGURE= yes
MAN3= POE::Component::Resolver.3 \
POE::Component::Resolver::Sidecar.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Storable>=2.18:${PORTSDIR}/devel/p5-Storable \
+ p5-Time-HiRes>=1.9711:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS+= p5-Storable>=2.18:${PORTSDIR}/devel/p5-Storable \
+ p5-Time-HiRes>=1.9711:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>