aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-02-07 08:48:01 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-02-07 08:48:01 +0000
commitd72d4d13a847884eb2c61e2e2553d1e7ff0dae60 (patch)
treeb43f3edf9f95556538ce3c665a349c53c5ee0cbf /dns
parentfbf768112611943ad8bc64a758dda2fe6ee0c85d (diff)
downloadports-d72d4d13a847884eb2c61e2e2553d1e7ff0dae60.tar.gz
ports-d72d4d13a847884eb2c61e2e2553d1e7ff0dae60.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsmasq-devel/Makefile5
-rw-r--r--dns/dnsmasq-devel/distinfo4
-rw-r--r--dns/dnsmasq-devel/files/patch-dnsmasq.conf.example13
-rw-r--r--dns/dnsmasq-devel/files/patch-git-e243c07-AD-flag-treatment77
4 files changed, 4 insertions, 95 deletions
diff --git a/dns/dnsmasq-devel/Makefile b/dns/dnsmasq-devel/Makefile
index 6e274f39702e..2752b85cb4c6 100644
--- a/dns/dnsmasq-devel/Makefile
+++ b/dns/dnsmasq-devel/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= dnsmasq
-PORTVERSION= 2.69.0test6
-DISTVERSION= 2.69test6
-PORTREVISION= 2
+PORTVERSION= 2.69.0test7
+DISTVERSION= 2.69test7
CATEGORIES= dns ipv6
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/test-releases/
PKGNAMESUFFIX= -devel
diff --git a/dns/dnsmasq-devel/distinfo b/dns/dnsmasq-devel/distinfo
index 25301241df44..55f70c326671 100644
--- a/dns/dnsmasq-devel/distinfo
+++ b/dns/dnsmasq-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dnsmasq-2.69test6.tar.xz) = 36d753a913bdfad658dfd558ffd2dca59defb0d1ea3df3a423d7af436bfdff2e
-SIZE (dnsmasq-2.69test6.tar.xz) = 453140
+SHA256 (dnsmasq-2.69test7.tar.xz) = 455e9df162117a160b50454a7e8dff9ca1c4f3af19926342a3584662b930ff70
+SIZE (dnsmasq-2.69test7.tar.xz) = 453368
diff --git a/dns/dnsmasq-devel/files/patch-dnsmasq.conf.example b/dns/dnsmasq-devel/files/patch-dnsmasq.conf.example
deleted file mode 100644
index 84f9185d8bcf..000000000000
--- a/dns/dnsmasq-devel/files/patch-dnsmasq.conf.example
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./dnsmasq.conf.example.orig 2014-02-04 21:20:35.000000000 +0100
-+++ ./dnsmasq.conf.example 2014-02-05 02:04:00.000000000 +0100
-@@ -20,6 +20,10 @@
- # Never forward addresses in the non-routed address spaces.
- #bogus-priv
-
-+# Uncomment these to enable DNSSEC validation and caching:
-+# (Requires dnsmasq to be built with DNSSEC option.)
-+#conf-file=%%PREFIX%%/share/dnsmasq/trust-anchors.conf
-+#dnssec
-
- # Uncomment this to filter useless windows-originated DNS requests
- # which can trigger dial-on-demand links needlessly.
diff --git a/dns/dnsmasq-devel/files/patch-git-e243c07-AD-flag-treatment b/dns/dnsmasq-devel/files/patch-git-e243c07-AD-flag-treatment
deleted file mode 100644
index ec97d09ec3b4..000000000000
--- a/dns/dnsmasq-devel/files/patch-git-e243c07-AD-flag-treatment
+++ /dev/null
@@ -1,77 +0,0 @@
-From e243c072b591cdeff8ac00483f5a9e426729534b Mon Sep 17 00:00:00 2001
-From: Simon Kelley <simon@thekelleys.org.uk>
-Date: Thu, 6 Feb 2014 18:14:09 +0000
-Subject: [PATCH] AD bit in queries handled as RFC6840 p5.7
-
----
- src/forward.c | 6 ------
- src/rfc1035.c | 17 ++++++++++-------
- 2 files changed, 10 insertions(+), 13 deletions(-)
-
-diff --git a/src/forward.c b/src/forward.c
-index 073b2c9..2088f98 100644
---- ./src/forward.c
-+++ ./src/forward.c
-@@ -249,9 +249,6 @@ static int forward_query(int udpfd, union mysockaddr *udpaddr,
- #endif
- unsigned int gotname = extract_request(header, plen, daemon->namebuff, NULL);
-
-- /* RFC 4035: sect 4.6 para 2 */
-- header->hb4 &= ~HB4_AD;
--
- /* may be no servers available. */
- if (!daemon->servers)
- forward = NULL;
-@@ -1283,9 +1280,6 @@ unsigned char *tcp_request(int confd, time_t now,
- if ((checking_disabled = header->hb4 & HB4_CD))
- no_cache_dnssec = 1;
-
-- /* RFC 4035: sect 4.6 para 2 */
-- header->hb4 &= ~HB4_AD;
--
- if ((gotname = extract_request(header, (unsigned int)size, daemon->namebuff, &qtype)))
- {
- #ifdef HAVE_AUTH
-diff --git a/src/rfc1035.c b/src/rfc1035.c
-index ac8c4ae..5515ea5 100644
---- ./src/rfc1035.c
-+++ ./src/rfc1035.c
-@@ -1468,7 +1468,7 @@ size_t answer_request(struct dns_header *header, char *limit, size_t qlen,
- struct mx_srv_record *rec;
- size_t len;
-
-- /* Don't return AD set even for local data if checking disabled. */
-+ /* Don't return AD set if checking disabled. */
- if (header->hb4 & HB4_CD)
- sec_data = 0;
-
-@@ -2260,17 +2260,20 @@ size_t answer_request(struct dns_header *header, char *limit, size_t qlen,
- header->ancount = htons(anscount);
- header->nscount = htons(0);
- header->arcount = htons(addncount);
-+
-+ /* RFC 6840 5.7 */
-+ if (header->hb4 & HB4_AD)
-+ sec_reqd = 1;
-
- header->hb4 &= ~HB4_AD;
-+
- len = ansp - (unsigned char *)header;
-
- if (have_pseudoheader)
-- {
-- len = add_pseudoheader(header, len, (unsigned char *)limit, 0, NULL, 0, sec_reqd);
-- if (sec_reqd && sec_data)
-- header->hb4 |= HB4_AD;
--
-- }
-+ len = add_pseudoheader(header, len, (unsigned char *)limit, 0, NULL, 0, sec_reqd);
-+
-+ if (sec_reqd && sec_data)
-+ header->hb4 |= HB4_AD;
-
- return len;
- }
---
-1.7.2.5
-