aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2017-01-18 17:58:53 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2017-01-18 17:58:53 +0000
commitec526eba4cd8462bbc5374e02234d382970ec3a1 (patch)
tree6c0370b1b86add9fb2d100f792487ed98f1312f4 /dns
parenteeb47ebfaa7d93d3c1c6c40f553c3f78e6ea6f63 (diff)
downloadports-ec526eba4cd8462bbc5374e02234d382970ec3a1.tar.gz
ports-ec526eba4cd8462bbc5374e02234d382970ec3a1.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsdist/Makefile1
-rw-r--r--dns/dnsdist/files/patch-ext_json11_json11.cpp36
2 files changed, 37 insertions, 0 deletions
diff --git a/dns/dnsdist/Makefile b/dns/dnsdist/Makefile
index 575339937a0a..d925952ce4e9 100644
--- a/dns/dnsdist/Makefile
+++ b/dns/dnsdist/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dnsdist
DISTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= dns net
MASTER_SITES= https://downloads.powerdns.com/releases/ \
LOCAL/cpm
diff --git a/dns/dnsdist/files/patch-ext_json11_json11.cpp b/dns/dnsdist/files/patch-ext_json11_json11.cpp
new file mode 100644
index 000000000000..600308eaa51b
--- /dev/null
+++ b/dns/dnsdist/files/patch-ext_json11_json11.cpp
@@ -0,0 +1,36 @@
+--- ext/json11/json11.cpp.orig 2017-01-18 02:13:48 UTC
++++ ext/json11/json11.cpp
+@@ -37,11 +37,20 @@ using std::make_shared;
+ using std::initializer_list;
+ using std::move;
+
++/* Helper for representing null - just a do-nothing struct, plus comparison
++ * operators so the helpers in JsonValue work. We can't use nullptr_t because
++ * it may not be orderable.
++*/
++struct NullStruct {
++ bool operator==(NullStruct) const { return true; }
++ bool operator<(NullStruct) const { return false; }
++};
++
+ /* * * * * * * * * * * * * * * * * * * *
+ * Serialization
+ */
+
+-static void dump(std::nullptr_t, string &out) {
++static void dump(NullStruct, string &out) {
+ out += "null";
+ }
+
+@@ -204,9 +213,9 @@ public:
+ explicit JsonObject(Json::object &&value) : Value(move(value)) {}
+ };
+
+-class JsonNull final : public Value<Json::NUL, std::nullptr_t> {
++class JsonNull final : public Value<Json::NUL, NullStruct> {
+ public:
+- JsonNull() : Value(nullptr) {}
++ JsonNull() : Value({}) {}
+ };
+
+ /* * * * * * * * * * * * * * * * * * * *