aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-01-25 17:44:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-01-25 17:44:15 +0000
commit1dd78273941c466661ba57b08aec7bd55859b653 (patch)
treed59736dce53bb21aed6cccf3bc85bddb547f5342 /dns
parente3803923a4703611b2b25753100bd6c32764c10f (diff)
downloadports-1dd78273941c466661ba57b08aec7bd55859b653.tar.gz
ports-1dd78273941c466661ba57b08aec7bd55859b653.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind916/files/patch-configure8
4 files changed, 14 insertions, 14 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index df23e3f6ec2e..5c18d74d779e 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -41,7 +41,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.10
+ISCVERSION= 9.16.11
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index f64217da211a..6ac7bda84e1f 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608153504
-SHA256 (bind-9.16.10.tar.xz) = bc47fc019c6205e6a6bfb839c544a1472321df0537ba905b846a4cbffe3362b3
-SIZE (bind-9.16.10.tar.xz) = 3269696
+TIMESTAMP = 1611312333
+SHA256 (bind-9.16.11.tar.xz) = 0111f64dd7d8f515cfa129e181cce96ff82070d1b27f11a21f6856110d0699c1
+SIZE (bind-9.16.11.tar.xz) = 5007520
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index c64d9c1ffd12..87349769dd03 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-12-07 08:16:53 UTC
+--- bin/named/config.c.orig 2021-01-11 13:23:31 UTC
+++ bin/named/config.c
@@ -179,6 +179,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-12-07 08:16:53 UTC
+--- bin/named/server.c.orig 2021-01-11 13:23:31 UTC
+++ bin/named/server.c
-@@ -4345,6 +4345,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4347,6 +4347,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-12-07 08:16:53 UTC
+--- lib/dns/include/dns/view.h.orig 2021-01-11 13:23:31 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-12-07 08:16:53 UTC
+--- lib/dns/resolver.c.orig 2021-01-11 13:23:31 UTC
+++ lib/dns/resolver.c
@@ -6281,6 +6281,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-12-07 08:16:53 UTC
+--- lib/isccfg/namedconf.c.orig 2021-01-11 13:23:31 UTC
+++ lib/isccfg/namedconf.c
@@ -2023,6 +2023,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind916/files/patch-configure b/dns/bind916/files/patch-configure
index 5671b13eae28..1ba4499b28a1 100644
--- a/dns/bind916/files/patch-configure
+++ b/dns/bind916/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2020-12-07 08:16:53 UTC
+--- configure.orig 2021-01-11 13:23:31 UTC
+++ configure
-@@ -17696,27 +17696,9 @@ done
+@@ -17708,27 +17708,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17759,47 +17741,7 @@ $as_echo "no" >&6; } ;;
+@@ -17771,47 +17753,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23215,7 +23157,7 @@ $as_echo "" >&6; }
+@@ -23227,7 +23169,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).