aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-05-06 06:03:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-05-06 06:03:58 +0000
commita2c4a5c233c0693a18d4e2e27663be4b4b006636 (patch)
treecac2aab8c60284d1f82bf2aa48840f41de9319bc /dns
parent4d0c2962c55255741df25a511a6268b079142be6 (diff)
downloadports-a2c4a5c233c0693a18d4e2e27663be4b4b006636.tar.gz
ports-a2c4a5c233c0693a18d4e2e27663be4b4b006636.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-dns-lexicon/Makefile23
-rw-r--r--dns/py-dns-lexicon/distinfo3
-rw-r--r--dns/py-dns-lexicon/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index eccd130b07d2..8f377ff9ff27 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -168,6 +168,7 @@
SUBDIR += powerdns-recursor
SUBDIR += public_suffix_list
SUBDIR += py-dns
+ SUBDIR += py-dns-lexicon
SUBDIR += py-dnschain
SUBDIR += py-dnspython
SUBDIR += py-easyzone
diff --git a/dns/py-dns-lexicon/Makefile b/dns/py-dns-lexicon/Makefile
new file mode 100644
index 000000000000..78b820b7f1aa
--- /dev/null
+++ b/dns/py-dns-lexicon/Makefile
@@ -0,0 +1,23 @@
+# Created by: Goran Mekić <meka@tilda.center>
+# $FreeBSD$
+
+PORTNAME= dns-lexicon
+PORTVERSION= 2.0.7
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= meka@tilda.center
+COMMENT= Manipulate DNS records on various DNS providers in a standardized way
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>=0.16:devel/py-future \
+ ${PYTHON_PKGNAMEPREFIX}tldextract>=1.7.5:dns/py-tldextract \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.11:www/py-requests
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ACRH= yes
+
+.include <bsd.port.mk>
diff --git a/dns/py-dns-lexicon/distinfo b/dns/py-dns-lexicon/distinfo
new file mode 100644
index 000000000000..c7d6fe8c9a4f
--- /dev/null
+++ b/dns/py-dns-lexicon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492705960
+SHA256 (dns-lexicon-2.0.7.tar.gz) = e22b5ce4476e6c1658dc5e504b268403e752212abe3c0710fbc1c4d89cfa2a8f
+SIZE (dns-lexicon-2.0.7.tar.gz) = 26225
diff --git a/dns/py-dns-lexicon/pkg-descr b/dns/py-dns-lexicon/pkg-descr
new file mode 100644
index 000000000000..eb97a42d20af
--- /dev/null
+++ b/dns/py-dns-lexicon/pkg-descr
@@ -0,0 +1,6 @@
+Lexicon provides a way to manipulate DNS records on multiple DNS providers in a
+standardized way. Lexicon has a CLI but it can also be used as a python library.
+
+Lexicon was designed to be used in automation, specifically letsencrypt.
+
+WWW: https://github.com/AnalogJ/lexicon