aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2007-12-12 08:48:31 +0000
committerAndrej Zverev <az@FreeBSD.org>2007-12-12 08:48:31 +0000
commit0e9e546b77815c2d61d43ccafe1ff77418657ee6 (patch)
tree0f268d5f9fbcd89e71316c52abb897cc8fd66aa3 /dns
parentcf6d47a08bc1d44b309605d7fef0d5181259c6d5 (diff)
downloadports-0e9e546b77815c2d61d43ccafe1ff77418657ee6.tar.gz
ports-0e9e546b77815c2d61d43ccafe1ff77418657ee6.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsproxy/Makefile11
-rw-r--r--dns/dnsproxy/files/dnsproxy.in32
-rw-r--r--dns/dnsproxy/files/pkg-message.in14
3 files changed, 56 insertions, 1 deletions
diff --git a/dns/dnsproxy/Makefile b/dns/dnsproxy/Makefile
index 691bcf91c10a..da116256b8a1 100644
--- a/dns/dnsproxy/Makefile
+++ b/dns/dnsproxy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dnsproxy
PORTVERSION= 1.15
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://www.wolfermann.org/
@@ -16,8 +17,11 @@ COMMENT= A proxy for DNS queries
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_RC_SUBR= dnsproxy
+
MAN1= dnsproxy.1
-PLIST_FILES= sbin/dnsproxy
+PLIST_FILES= sbin/dnsproxy etc/${PORTNAME}/dnsproxy.conf.sample
+SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
@@ -29,5 +33,10 @@ pre-configure:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/dnsproxy ${PREFIX}/sbin
@${INSTALL_MAN} ${WRKSRC}/dnsproxy.1 ${MAN1PREFIX}/man/man1
+ @${MKDIR} ${ETCDIR}
+ @${INSTALL_DATA} -v ${WRKSRC}/dnsproxy.conf ${ETCDIR}/dnsproxy.conf.sample
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/dns/dnsproxy/files/dnsproxy.in b/dns/dnsproxy/files/dnsproxy.in
new file mode 100644
index 000000000000..65815da63b91
--- /dev/null
+++ b/dns/dnsproxy/files/dnsproxy.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: dnsproxy
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Define these dnsproxy_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+#
+# dnsproxy_enable="YES" # Run the dnsproxy(1) daemon (YES/NO).
+# dnsproxy_flags="" # Extra flags for dnsproxy(1) (if enabled).
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+#
+dnsproxy_enable=${dnsproxy_enable:-"NO"}
+command_args=${dnsproxy_flags:-"-c %%ETCDIR%%/dnsproxy.conf -d"}
+
+. %%RC_SUBR%%
+
+name="dnsproxy"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/dnsproxy"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/dns/dnsproxy/files/pkg-message.in b/dns/dnsproxy/files/pkg-message.in
new file mode 100644
index 000000000000..1434e9d15655
--- /dev/null
+++ b/dns/dnsproxy/files/pkg-message.in
@@ -0,0 +1,14 @@
+**********************************************************************
+To enable dnsproxy you need:
+
+1) Enable dnsproxy in /etc/rc.conf with the following line:
+ dnsproxy_enable="YES"
+
+2) Configuration template is available in %%ETCDIR%%/ as
+ dnsproxy.conf.sample file.
+
+For more information see man dnsproxy(1)
+
+**********************************************************************
+
+