aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-06-01 08:53:22 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-06-01 08:53:22 +0000
commit1abd16b102b18cafdc35a5ad634e8b667d084578 (patch)
tree6e04c75482f0c443139836667442305a7a421824 /dns
parentafdab4d17e4113d3f41a24278ca49f9c7618494a (diff)
downloadports-1abd16b102b18cafdc35a5ad634e8b667d084578.tar.gz
ports-1abd16b102b18cafdc35a5ad634e8b667d084578.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-DNS-Check/Makefile35
-rw-r--r--dns/p5-Net-DNS-Check/distinfo2
-rw-r--r--dns/p5-Net-DNS-Check/pkg-descr9
-rw-r--r--dns/p5-Net-DNS-Check/pkg-plist34
5 files changed, 81 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 27e616a1f5ad..76f799e9bfd3 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -95,6 +95,7 @@
SUBDIR += p5-Net-Bonjour
SUBDIR += p5-Net-DNS
SUBDIR += p5-Net-DNS-Async
+ SUBDIR += p5-Net-DNS-Check
SUBDIR += p5-Net-DNS-Codes
SUBDIR += p5-Net-DNS-Lite
SUBDIR += p5-Net-DNS-RR-SRV-Helper
diff --git a/dns/p5-Net-DNS-Check/Makefile b/dns/p5-Net-DNS-Check/Makefile
new file mode 100644
index 000000000000..1cddc419ba18
--- /dev/null
+++ b/dns/p5-Net-DNS-Check/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: dns/p5-Net-DNS-Check
+# Date created: 2011-05-30
+# Whom: Ryan Steinmetz <rpsfa@rit.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNS-Check
+PORTVERSION= 0.45
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= Module for easy domain name checking
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNS::Check::Test::ns_count.3 Net::DNS::Check::Test::soa_expire_compare.3 \
+ Net::DNS::Check::NSQuery.3 Net::DNS::Check::Test::soa_master_compare.3 \
+ Net::DNS::Check::Test::mx_present.3 Net::DNS::Check::Test::mx_compare.3 \
+ Net::DNS::Check::Test::soa_retry_compare.3 Net::DNS::Check::Test::unknown.3 \
+ Net::DNS::Check::Test::host_ip_vs_ip_orig.3 Net::DNS::Check::Test::ns_vs_delegated.3 \
+ Net::DNS::Check::Test::soa_serial_compare.3 Net::DNS::Check::Test::soa_retry_range.3 \
+ Net::DNS::Check::HostsList.3 Net::DNS::Check::Test::host_ip_private.3 \
+ Net::DNS::Check::Test::soa_expire_range.3 Net::DNS::Check::Config.3 \
+ Net::DNS::Check::Test::soa_master_in_ns.3 Net::DNS::Check::Test::host_syntax.3 \
+ Net::DNS::Check::Test::soa_refresh_range.3 Net::DNS::Check::Test::host_not_cname.3 \
+ Net::DNS::Check::Test::ns_compare.3 Net::DNS::Check::Host.3 \
+ Net::DNS::Check::Test.3 Net::DNS::Check::Test::soa_refresh_compare.3 \
+ Net::DNS::Check::Test::soa_serial_syntax.3 Net::DNS::Check.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-Check/distinfo b/dns/p5-Net-DNS-Check/distinfo
new file mode 100644
index 000000000000..908579f00c2b
--- /dev/null
+++ b/dns/p5-Net-DNS-Check/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-DNS-Check-0.45.tar.gz) = 13a7eefb660426d0fcc3b3ddb7ea1848e4d919f112df16f33384b88b25476de1
+SIZE (Net-DNS-Check-0.45.tar.gz) = 23466
diff --git a/dns/p5-Net-DNS-Check/pkg-descr b/dns/p5-Net-DNS-Check/pkg-descr
new file mode 100644
index 000000000000..717c5579b79c
--- /dev/null
+++ b/dns/p5-Net-DNS-Check/pkg-descr
@@ -0,0 +1,9 @@
+Net::DNS::Check is a collection of OOP Perl modules allowing easy
+implementation of applications for domain name checking.
+
+The Net::DNS::Check was built to be as easy as possible to use and
+highly configurable and flexible: it allow easy implementation
+of your custom test and deeper configuration of what you want
+to check and how.
+
+WWW: http://search.cpan.org/dist/Net-DNS-Check/
diff --git a/dns/p5-Net-DNS-Check/pkg-plist b/dns/p5-Net-DNS-Check/pkg-plist
new file mode 100644
index 000000000000..085246e41d3d
--- /dev/null
+++ b/dns/p5-Net-DNS-Check/pkg-plist
@@ -0,0 +1,34 @@
+%%SITE_PERL%%/Net/DNS/Check/Test/ns_count.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_expire_compare.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_master_compare.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/mx_compare.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/mx_present.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_retry_compare.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/unknown.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/host_ip_vs_ip_orig.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/ns_vs_delegated.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_retry_range.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_serial_compare.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/host_ip_private.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_expire_range.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_master_in_ns.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/host_syntax.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_refresh_range.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/ns_compare.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/host_not_cname.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_refresh_compare.pm
+%%SITE_PERL%%/Net/DNS/Check/Test/soa_serial_syntax.pm
+%%SITE_PERL%%/Net/DNS/Check/NSQuery.pm
+%%SITE_PERL%%/Net/DNS/Check/HostsList.pm
+%%SITE_PERL%%/Net/DNS/Check/Config.pm
+%%SITE_PERL%%/Net/DNS/Check/Host.pm
+%%SITE_PERL%%/Net/DNS/Check/Test.pm
+%%SITE_PERL%%/Net/DNS/Check.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/Check/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/Check
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/DNS/Check/Test
+@dirrmtry %%SITE_PERL%%/Net/DNS/Check
+@dirrmtry %%SITE_PERL%%/Net/DNS
+@dirrmtry %%SITE_PERL%%/Net