aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-26 18:33:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-26 18:33:10 +0000
commitd322d675a61abb931612d4d80e3be42f97947846 (patch)
tree53e4ea4f90779fe759f4682cb2ca6d9fa616dc3c /dns
parent0b8c095727d18ad6ca87acdccfb3716e436fd080 (diff)
downloadports-d322d675a61abb931612d4d80e3be42f97947846.tar.gz
ports-d322d675a61abb931612d4d80e3be42f97947846.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-Amazon-Route53/Makefile33
-rw-r--r--dns/p5-Net-Amazon-Route53/distinfo2
-rw-r--r--dns/p5-Net-Amazon-Route53/pkg-descr6
-rw-r--r--dns/p5-Net-Amazon-Route53/pkg-plist12
5 files changed, 54 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 68146327fc59..a11ef9764202 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -92,6 +92,7 @@
SUBDIR += p5-DNS-Zone
SUBDIR += p5-DNS-ZoneParse
SUBDIR += p5-Data-Validate-Domain
+ SUBDIR += p5-Net-Amazon-Route53
SUBDIR += p5-Net-Bonjour
SUBDIR += p5-Net-DNS
SUBDIR += p5-Net-DNS-Async
diff --git a/dns/p5-Net-Amazon-Route53/Makefile b/dns/p5-Net-Amazon-Route53/Makefile
new file mode 100644
index 000000000000..76c3b048d85d
--- /dev/null
+++ b/dns/p5-Net-Amazon-Route53/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Net-Amazon-Route53
+# Date created: 2011-04-24
+# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Amazon-Route53
+PORTVERSION= 0.110310
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jnlin@csie.nctu.edu.tw
+COMMENT= Manage your DNS entries on Amazon's Route53 service
+
+RUN_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-XML-Bare>=0:${PORTSDIR}/textproc/p5-XML-Bare \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= route53.1
+MAN3= Net::Amazon::Route53.3 \
+ Net::Amazon::Route53::HostedZone.3 \
+ Net::Amazon::Route53::ResourceRecordSet.3 \
+ Net::Amazon::Route53::Change.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-Amazon-Route53/distinfo b/dns/p5-Net-Amazon-Route53/distinfo
new file mode 100644
index 000000000000..5da807ab8ec1
--- /dev/null
+++ b/dns/p5-Net-Amazon-Route53/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Amazon-Route53-0.110310.tar.gz) = 553c958a4c646b44b09ee312625e5a74349c26cb234edad2ba9adcf7e352bbf2
+SIZE (Net-Amazon-Route53-0.110310.tar.gz) = 17916
diff --git a/dns/p5-Net-Amazon-Route53/pkg-descr b/dns/p5-Net-Amazon-Route53/pkg-descr
new file mode 100644
index 000000000000..33bce6fc38d0
--- /dev/null
+++ b/dns/p5-Net-Amazon-Route53/pkg-descr
@@ -0,0 +1,6 @@
+The Net::Amazon::Route53 Perl module allows you to manage DNS
+records for your domains via Amazon's Route 53 service.
+
+For more information, visit http://aws.amazon.com/route53/
+
+WWW: http://search.cpan.org/dist/Net-Amazon-Route53/
diff --git a/dns/p5-Net-Amazon-Route53/pkg-plist b/dns/p5-Net-Amazon-Route53/pkg-plist
new file mode 100644
index 000000000000..f44009569f6f
--- /dev/null
+++ b/dns/p5-Net-Amazon-Route53/pkg-plist
@@ -0,0 +1,12 @@
+bin/route53
+%%SITE_PERL%%/Net/Amazon/Route53.pm
+%%SITE_PERL%%/Net/Amazon/Route53/Change.pm
+%%SITE_PERL%%/Net/Amazon/Route53/HostedZone.pm
+%%SITE_PERL%%/Net/Amazon/Route53/ResourceRecordSet.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon/Route53/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon/Route53
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Amazon/Route53
+@dirrmtry %%SITE_PERL%%/Net/Amazon
+@dirrmtry %%SITE_PERL%%/Net