aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-13 16:15:29 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-13 16:15:29 +0000
commit220d9dcd4fc72452314f8f2a21e2635cf3d38f3a (patch)
treed623d28a176f8db8048e262d8bc0a268b4b30a0a /dns
parent6f83ad1234ed37301f6e05fbcd7ab0f477d1f70c (diff)
downloadports-220d9dcd4fc72452314f8f2a21e2635cf3d38f3a.tar.gz
ports-220d9dcd4fc72452314f8f2a21e2635cf3d38f3a.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/knot/Makefile25
-rw-r--r--dns/knot/distinfo4
-rw-r--r--dns/knot/files/knotd.in12
-rw-r--r--dns/knot/files/pkg-message.in13
-rw-r--r--dns/knot/pkg-descr2
-rw-r--r--dns/knot/pkg-plist15
6 files changed, 33 insertions, 38 deletions
diff --git a/dns/knot/Makefile b/dns/knot/Makefile
index d6f461c75f37..ec0e7f58e462 100644
--- a/dns/knot/Makefile
+++ b/dns/knot/Makefile
@@ -2,10 +2,11 @@
# $FreeBSD$
PORTNAME= knot
-DISTVERSION= 1.2.0
+DISTVERSION= 1.3.0r1
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
http://www.dns-lab.com/downloads/knot-dns/
+DISTNAME= knot-1.3.0-rc1
MAINTAINER= freebsd@dns-lab.com
COMMENT= Knot DNS is a high performance authoritative-only DNS server
@@ -16,34 +17,34 @@ BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
flex>=2.5.35_1:${PORTSDIR}/textproc/flex
LIB_DEPENDS= urcu:${PORTSDIR}/sysutils/liburcu
-CONFIGURE_ARGS= --sysconfdir=${ETCDIR}
-GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool
-USE_OPENSSL= yes
-.include <bsd.port.pre.mk>
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --sysconfdir=${ETCDIR}
SUB_FILES= pkg-message
USE_RC_SUBR= ${PORTNAME}d
-MAN8= knotc.8 knotd.8
+MAN8= knotc.8 knotd.8 kdig.8 khost.8 knsupdate.8
MAN5= knot.conf.5
INFO= knot
-PORTDOCS= AUTHORS ChangeLog CodingStyle \
- INSTALL KNOWN_ISSUES NEWS README RELNOTES
+PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS
+
+.include <bsd.port.options.mk>
post-install:
@${MKDIR} ${ETCDIR}
- @${INSTALL_DATA} ${WRKSRC}/samples/knot.min.conf ${ETCDIR}
- @${INSTALL_DATA} ${WRKSRC}/samples/knot.full.conf ${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/knot.sample.conf ${ETCDIR}
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
@${CAT} ${WRKDIR}/pkg-message
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/knot/distinfo b/dns/knot/distinfo
index 3434be01a65a..fcff0d01b8f4 100644
--- a/dns/knot/distinfo
+++ b/dns/knot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (knot-1.2.0.tar.gz) = 7c585ebae5543807db257b14f0e15af79f7cdf83ef90af89eec3d6af304440b0
-SIZE (knot-1.2.0.tar.gz) = 1241376
+SHA256 (knot-1.3.0-rc1.tar.gz) = 7f79dd4e2cf5e4346f9571cdc6667744298b0a0e98d56655287074bac95b3a5b
+SIZE (knot-1.3.0-rc1.tar.gz) = 1157222
diff --git a/dns/knot/files/knotd.in b/dns/knot/files/knotd.in
index 8605c706e97b..d6b87d2b258b 100644
--- a/dns/knot/files/knotd.in
+++ b/dns/knot/files/knotd.in
@@ -18,10 +18,8 @@
name=knot
rcvar=knot_enable
-extra_commands="reload compile"
-compile_cmd="${name}_compile"
+extra_commands="reload"
reload_cmd="${name}_reload"
-start_precmd="${name}_compile"
status_cmd="${name}_status"
stop_cmd="${name}_stop"
@@ -37,16 +35,12 @@ pidfile=/var/run/${name}.pid
command_args="-c ${knot_config} -w start"
required_files=${knot_config}
-knot_compile() {
- echo "Compiling zone(s)..."
- ${command} -c ${knot_config} compile
- }
knot_reload() {
echo "Reloading ${name}."
- ${command} -c ${knot_config} -a reload
+ ${command} -c ${knot_config} reload
}
knot_status() {
- ${command} -c ${knot_config} running
+ ${command} -c ${knot_config} status
}
knot_stop() {
echo "Stopping ${name}."
diff --git a/dns/knot/files/pkg-message.in b/dns/knot/files/pkg-message.in
index fd398cb07e65..19e4ad2af30d 100644
--- a/dns/knot/files/pkg-message.in
+++ b/dns/knot/files/pkg-message.in
@@ -5,10 +5,8 @@
#
# ----- configure --------------------------------------------------
#
- $EDITOR %%ETCDIR%%/knot.min.conf
-# -or-
-# $EDITOR %%ETCDIR%%/knot.full.conf
-# and save it as %%ETCDIR%%/knot.conf
+ cp %%ETCDIR%%/knot.sample.conf %%ETCDIR%%/knot.conf
+ $EDITOR %%ETCDIR%%/knot.conf
#
# ----- prepare ----------------------------------------------------
#
@@ -23,3 +21,10 @@
#
####################################################################
+
+ When upgrading from version of before 1.3.0-RC1:
+ mind the default config file location has changed.
+
+
+====================================================================
+
diff --git a/dns/knot/pkg-descr b/dns/knot/pkg-descr
index 68dc6c2f15b1..9da00fe3da7c 100644
--- a/dns/knot/pkg-descr
+++ b/dns/knot/pkg-descr
@@ -1,6 +1,6 @@
Knot DNS is a high-performance authoritative-only DNS server
which supports all key features of the domain name system
-including zone transfers, dynamic updates and DNSSEC.
+including zone AXFR and IXFR, DDNS and DNSSEC.
Key features:
diff --git a/dns/knot/pkg-plist b/dns/knot/pkg-plist
index e7b3a965b6dd..c7215096b4d9 100644
--- a/dns/knot/pkg-plist
+++ b/dns/knot/pkg-plist
@@ -1,16 +1,11 @@
@stopdaemon knotd
-%%ETCDIR%%/example.com.zone
-@unexec if cmp -s %B/knot.min.conf %B/knot.conf; then rm -f %B/knot.conf; fi
-%%ETCDIR%%/knot.full.conf
-%%ETCDIR%%/knot.min.conf
+@unexec if cmp -s %B/knot.sample.conf %B/knot.conf; then rm -f %B/knot.conf; fi
@exec [ -f %B/knot.conf ] || cp %B/%f %B/knot.conf
+%%ETCDIR%%/example.com.zone
%%ETCDIR%%/knot.sample.conf
@dirrmtry %%ETCDIR%%
-libexec/knot-zcompile
-libexec/unittests
-libexec/unittests-libknot
-libexec/unittests-libknot-realdata
-libexec/unittests-xfr
-libexec/unittests-zcompile
+sbin/kdig
+sbin/khost
sbin/knotc
sbin/knotd
+sbin/knsupdate