aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-10-06 07:59:36 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-10-06 07:59:36 +0000
commit0d2f629ee764e14e3e82bc2e6a305f40f67dd897 (patch)
treef9ea9c71684223778ccca1d127ebb70a15fe3477 /dns
parent59775693ef5062badbbacec195c4a8fdd36c3400 (diff)
downloadports-0d2f629ee764e14e3e82bc2e6a305f40f67dd897.tar.gz
ports-0d2f629ee764e14e3e82bc2e6a305f40f67dd897.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/ddup/Makefile55
-rw-r--r--dns/ddup/distinfo2
-rw-r--r--dns/ddup/files/Makefile17
-rw-r--r--dns/ddup/files/patch-ddup.c48
-rw-r--r--dns/ddup/files/patch-ddup.h12
-rw-r--r--dns/ddup/files/patch-ddupcron.sh41
-rw-r--r--dns/ddup/files/patch-parse_option.c31
-rw-r--r--dns/ddup/files/patch-update.c30
-rw-r--r--dns/ddup/pkg-descr17
-rw-r--r--dns/ddup/pkg-message5
-rw-r--r--dns/ddup/pkg-plist5
12 files changed, 0 insertions, 264 deletions
diff --git a/dns/Makefile b/dns/Makefile
index edc3f0c2ee17..68c3da2ab966 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -13,7 +13,6 @@
SUBDIR += checkdns
SUBDIR += crossip
SUBDIR += ddclient
- SUBDIR += ddup
SUBDIR += dhid
SUBDIR += dhisd
SUBDIR += djbdns
diff --git a/dns/ddup/Makefile b/dns/ddup/Makefile
deleted file mode 100644
index 215133a368ee..000000000000
--- a/dns/ddup/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# New ports collection makefile for: ddup
-# Date created: 30 September 1999
-# Whom: cjm2
-#
-# $FreeBSD$
-#
-
-PORTNAME= ddup
-PORTVERSION= 3.0.1
-PORTREVISION= 3
-CATEGORIES= dns
-MASTER_SITES= ${MASTER_SITES_LOCAL}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-unix
-
-DEPRECATED= "master site disappeared, try dns/ipcheck"
-EXPIRATION_DATE=2005-08-31
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A DynDNS.org client for UNIX (Now support NIC v2.0)
-
-USE_REINPLACE= yes
-
-MAN1= ddup.1
-MANCOMPRESSED= maybe
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-# Uncomment this if you want to enable debugging.
-#DEBUG= -g
-
-MAKE_ARGS= DEBUG="${DEBUG}"
-
-.include <bsd.port.pre.mk>
-
-post-extract:
- @${GUNZIP_CMD} ${WRKSRC}/ddup.1.gz
-
-post-patch:
- @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/ddupcron.sh
- @${REINPLACE_CMD} -e 's,/etc\b,${PREFIX}$$&,' ${WRKSRC}/ddup.1
-
-pre-build:
- @${CP} ${FILESDIR}/Makefile ${WRKSRC}/
- @${ECHO_CMD} "#define file_name \"${PREFIX}/etc/ddup.conf\"" \
- > ${WRKSRC}/options.h
-
-post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/ddupcron.sh ${PREFIX}/sbin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/dns/ddup/distinfo b/dns/ddup/distinfo
deleted file mode 100644
index 7409ce366f03..000000000000
--- a/dns/ddup/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (ddup-3.0.1-unix.tar.gz) = 6c3ee8158f994de4cbbaf0593fb0226c
-SIZE (ddup-3.0.1-unix.tar.gz) = 26787
diff --git a/dns/ddup/files/Makefile b/dns/ddup/files/Makefile
deleted file mode 100644
index 10b38361b6e6..000000000000
--- a/dns/ddup/files/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PROG= ddup
-SRCS= ddup.c \
- ddup_functions.c \
- getopt.c \
- getopt1.c \
- parse_config.c \
- parse_option.c \
- update.c
-CFLAGS+= ${DEBUG}
-MAN1= ddup.1
-BINDIR= ${PREFIX}/sbin
-MANDIR= ${PREFIX}/man/man
-
-.include <bsd.prog.mk>
-
diff --git a/dns/ddup/files/patch-ddup.c b/dns/ddup/files/patch-ddup.c
deleted file mode 100644
index 4a177c3070c9..000000000000
--- a/dns/ddup/files/patch-ddup.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- ddup.c.orig Tue Oct 31 01:13:23 2000
-+++ ddup.c Thu Jul 25 07:25:54 2002
-@@ -26,25 +26,29 @@
- void usage(void)
- {
- printf("DD-UP version %s by Thomas Gandy and Tom Groves (ddupwww@ddup.org)\n", AGENT_VER);
-- printf("Usage: ddup --host host.domain.ext (multiple hosts separated by ,)\n");
-- printf(" (host.domain.ext,host2.domain.ext) [--ip address] [--wildcard]\n");
-- printf(" [--proxyserv server] [--proxyport port] [--help] [--debug] [--mx mxhost]\n");
-- printf(" [--backmx] [--static]\n");
-- printf(" --host host.domain.ext : REQUIRED to update.\n");
-- printf(" Where host.domain.ext is your domain.\n");
-- printf(" eg. gandy.dyndns.org, gandy.ath.cx\n");
-- printf(" --ip address : Forces manual ip specification\n");
-- printf(" Where address is your IP address.\n");
-- printf(" --wildcard : Enables wildcards.\n");
-+ printf("Usage: ddup --host host.domain.ext [--ip address] [--wildcard]\n");
-+ printf(" [--mx mxhost] [--backmx] [--static | --dynamic | --custom]\n");
-+ printf(" [--proxyserv server] [--proxyport port] [--debug]\n");
-+ printf(" ddup [--help | --makeconf]\n");
-+ printf("\n");
-+ printf(" --host host.domain.ext : REQUIRED to update.\n");
-+ printf(" Where host.domain.ext is your domain.\n");
-+ printf(" Multiple hosts separated by a `,' (comma) may be specified.\n");
-+ printf(" e.g. gandy.dyndns.org,gandy.ath.cx\n");
-+ printf(" --ip address : Forces manual ip specification\n");
-+ printf(" Where address is your IP address.\n");
-+ printf(" --wildcard : Enables wildcards.\n");
- printf(" --mx mxhost : Sets your MX to mxhost.\n");
- printf(" --backmx : Needs --mx and sets mxhost to be a backup MX.\n");
-- printf(" --proxyserv server : Uses server as proxy.\n");
-- printf(" --proxyport port : connects to proxy with port.\n");
-- printf(" --help : Prints this message.\n");
-- printf(" --debug : Prints debug output of what is sent to server.\n");
- printf(" --static : Use the Static DNS service. (Added by Patrick D.)\n");
-- printf("\n");
-- printf(" --makeconf : Creates the config file for you. (Base64 Encodes your password)\n");
-+ printf(" --dynamic : Use the Dyanmic DNS service. (Added by rwc.)\n");
-+ printf(" --custom : Use the Custom DNS service. (Added by rwc.)\n");
-+ printf(" --proxyserv server : Uses server as proxy.\n");
-+ printf(" --proxyport port : connects to proxy with port.\n");
-+ printf(" --debug : Prints debug output of what is sent to server.\n");
-+ printf(" --help : Prints this message.\n");
-+ printf(" --makeconf : Creates the config file for you.\n");
-+ printf(" Base64 Encodes your password.\n");
- exit(0);
- }
-
diff --git a/dns/ddup/files/patch-ddup.h b/dns/ddup/files/patch-ddup.h
deleted file mode 100644
index 85bf7c7bf881..000000000000
--- a/dns/ddup/files/patch-ddup.h
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -x CVS -x work -x core -x *.core -x #* -x *~ -x *.orig -x *.rej -I $Id.*$ -I $.+BSD.*$ ddup.h.orig ddup.h
---- ddup.h.orig Tue Oct 31 01:09:48 2000
-+++ ddup.h Mon Jul 22 21:51:52 2002
-@@ -5,7 +5,7 @@
- #include "options.h"
-
- #define AGENT_NAME "ddup"
--#define AGENT_VER "3.0.1"
-+#define AGENT_VER "3.0.1.1"
- #define MEMBERS_HOST "members.dyndns.org"
-
- /* ddup_functions.c */
diff --git a/dns/ddup/files/patch-ddupcron.sh b/dns/ddup/files/patch-ddupcron.sh
deleted file mode 100644
index 52d2a0d7da54..000000000000
--- a/dns/ddup/files/patch-ddupcron.sh
+++ /dev/null
@@ -1,41 +0,0 @@
---- ddupcron.sh.orig Sun Oct 22 19:11:48 2000
-+++ ddupcron.sh Thu Jul 25 06:21:51 2002
-@@ -2,26 +2,30 @@
-
- # Define the host to be updated as 1st arguement to script
- if [ -z $1 ]; then
-- echo "Usage: ddupcron.sh hostname"
-+ echo "Usage: ddupcron.sh hostname [interface]"
- exit
- else
- HOST=$1
- fi
- # Define interface to grep address from
--IFACE="eth0"
--IFCHECK=$(/sbin/ifconfig $IFACE|grep ask|awk '{print $2}'|cut -d ':' -f2)
-+if [ -z $2 ]; then
-+ IFACE=fxp0
-+else
-+ IFACE=$2
-+fi
-+IFCHECK=$(/sbin/ifconfig $IFACE|awk '/netmask/{print $2; exit}')
- # Define where we should store last IP
--IPFILE="/tmp/ddupip"
-+IPFILE="/var/db/ddup.ip"
- IPCHECK=$(cat $IPFILE)
-+FILECHECK=$(find $IPFILE -mtime -25)
-+
- # Define path to ddup and ddup arguments (except --host)
--DDUP_PATH="/home/ddup/ddup"
-+DDUP_PATH="%%PREFIX%%/sbin/ddup"
- DDUP_ARGS="--debug"
-
--
--if [ "$IFCHECK" = "$IPCHECK" ]; then
-+if [ "$IFCHECK" = "$IPCHECK" ] && [ "x$FILECHECK" != x ]; then
- echo "looks like we are still the same ip"
- else
- $DDUP_PATH --host $HOST $DDUP_ARGS
- echo "$IFCHECK" > $IPFILE
- fi
--
diff --git a/dns/ddup/files/patch-parse_option.c b/dns/ddup/files/patch-parse_option.c
deleted file mode 100644
index 43bd0f4ae625..000000000000
--- a/dns/ddup/files/patch-parse_option.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- parse_option.c.orig Sat Sep 30 21:06:27 2000
-+++ parse_option.c Thu Jul 25 06:46:57 2002
-@@ -30,6 +30,8 @@
- int backmx_flag = 0;
- /* Flag set by '--static' (Added by Patrick D.) */
- int static_flag = 0;
-+int dynamic_flag = 0;
-+int custom_flag = 0;
- /* Vars for other options */
- char *ip_address;
- char *host_id;
-@@ -51,6 +53,8 @@
- {"version", 0, &ver_flag, 1},
- /* Added by Patrick D. */
- {"static", 0, &static_flag, 1},
-+ {"dynamic", 0, &dynamic_flag, 1},
-+ {"custom", 0, &custom_flag, 1},
- /* These options don't set a flag.
- We distinguish them by their indices. */
- {"ip", 1, 0, 0},
-@@ -98,6 +102,10 @@
- }
- }
-
-+ if (static_flag+dynamic_flag+custom_flag > 1) {
-+ fprintf(stderr, "ddup: --static, --dynamic and --custom options are mutually exclusive.\n");
-+ help_flag = 1;
-+ }
- if (help_flag) {
- usage();
- }
diff --git a/dns/ddup/files/patch-update.c b/dns/ddup/files/patch-update.c
deleted file mode 100644
index 52674af985e7..000000000000
--- a/dns/ddup/files/patch-update.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- update.c.orig Tue Oct 31 01:10:02 2000
-+++ update.c Thu Jul 25 06:47:36 2002
-@@ -26,6 +26,8 @@
- extern int backmx_flag;
- /* Flag set by '--static' (Added by Patrick D.) */
- extern int static_flag;
-+extern int dynamic_flag;
-+extern int custom_flag;
- /* Vars for other options */
- extern char *ip_address;
- extern char *host_id;
-@@ -125,11 +127,14 @@
- strcat(buf_out, "/nic/update?system=");
-
- if (static_flag)
-- strcat(buf_out, "stat");
-- else
-- strcat(buf_out, "dyn");
-+ strcat(buf_out, "statdns");
-+ else if (custom_flag)
-+ strcat(buf_out, "custom");
-+ else
-+ strcat(buf_out, "dyndns");
-
-- strcat(buf_out, "dns&hostname=");
-+
-+ strcat(buf_out, "&hostname=");
- strcat(buf_out, host_id);
-
- if (ip_address)
diff --git a/dns/ddup/pkg-descr b/dns/ddup/pkg-descr
deleted file mode 100644
index 7d300c01eb1a..000000000000
--- a/dns/ddup/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-DD-UP is a program that is used to update a host provided by the Free
-DynDNS service of dyndns.org.
-
-This version supports:
- - Dynamic Hostnames
- - Static Hostnames
- - DynDNS.Org NIC v2.0
-
-Features in this version include:
- - Automatic IP Detection
- - Manual IP Specification
- - Wildcard hosts
- - Backup MX hosts
- - Operation through a proxy server
-
-Author: Thomas Gandy <tegandy@enid.com>
-WWW: http://www.ddup.org/
diff --git a/dns/ddup/pkg-message b/dns/ddup/pkg-message
deleted file mode 100644
index 74555f9fa182..000000000000
--- a/dns/ddup/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-********************************************************
-*** If you are upgrading or are a first time user ***
-*** you MUST make your configuration file by typing ***
-*** ddup --makeconf ***
-********************************************************
diff --git a/dns/ddup/pkg-plist b/dns/ddup/pkg-plist
deleted file mode 100644
index e2000f7714e5..000000000000
--- a/dns/ddup/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-@comment $FreeBSD$
-sbin/ddup
-sbin/ddupcron.sh
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%