aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-09-16 08:03:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-09-16 08:03:36 +0000
commit26363fab726a4b1301e818733cc5f06bb71b8fcf (patch)
treefbe77a09398f71381d04e5665b0a7f7fc2f70e15 /dns
parentaa8061d1c1a2f583f73aab0d631dec7a7d8afa0e (diff)
downloadports-26363fab726a4b1301e818733cc5f06bb71b8fcf.tar.gz
ports-26363fab726a4b1301e818733cc5f06bb71b8fcf.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-adns/Makefile25
-rw-r--r--dns/py-adns/distinfo3
-rw-r--r--dns/py-adns/files/patch-adnsmodule.c10
-rw-r--r--dns/py-adns/pkg-descr8
5 files changed, 47 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 66859f45ca95..da5e19f5f66e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -183,6 +183,7 @@
SUBDIR += powerdns-recursor
SUBDIR += powerdns-recursor40
SUBDIR += public_suffix_list
+ SUBDIR += py-adns
SUBDIR += py-aiodns
SUBDIR += py-cloudflare
SUBDIR += py-dns
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
new file mode 100644
index 000000000000..176a0d71333c
--- /dev/null
+++ b/dns/py-adns/Makefile
@@ -0,0 +1,25 @@
+# Created by: Hye-Shik Chang <perky@fallin.lv>
+# $FreeBSD$
+
+PORTNAME= adns
+DISTVERSION= 1.4
+DISTVERSIONSUFFIX= -py1
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lebarondemerde@privacychain.ch
+COMMENT= Python module to resolve IPs to host names
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/GPL
+
+LIB_DEPENDS= libadns.so:dns/adns
+
+USES= localbase python:3.4+
+USE_PYTHON= autoplist distutils
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.4-py1|1.4|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/dns/py-adns/distinfo b/dns/py-adns/distinfo
new file mode 100644
index 000000000000..2a62ee895d53
--- /dev/null
+++ b/dns/py-adns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537084332
+SHA256 (adns-1.4-py1.tar.gz) = 675567453caf5843fabd1c2312aad13a93b61c3699dda2ceba67f1a2687ccddc
+SIZE (adns-1.4-py1.tar.gz) = 18868
diff --git a/dns/py-adns/files/patch-adnsmodule.c b/dns/py-adns/files/patch-adnsmodule.c
new file mode 100644
index 000000000000..58e2e5a2f1f6
--- /dev/null
+++ b/dns/py-adns/files/patch-adnsmodule.c
@@ -0,0 +1,10 @@
+--- adnsmodule.c.orig 2018-08-11 22:10:36 UTC
++++ adnsmodule.c
+@@ -6,6 +6,7 @@ any later version.
+ */
+
+ #include <Python.h>
++#include <sys/endian.h>
+ #include <adns.h>
+ #include <string.h>
+ #include <assert.h>
diff --git a/dns/py-adns/pkg-descr b/dns/py-adns/pkg-descr
new file mode 100644
index 000000000000..d521d6e0cc1d
--- /dev/null
+++ b/dns/py-adns/pkg-descr
@@ -0,0 +1,8 @@
+Python module to resolve IPs to host names.
+
+python3-adns is a Python 3 module that interfaces to the adns: an advanced easy
+to use, asynchronous-capable DNS client library and utilities. Adns is a
+resolver library for C (and C++) programs, and a collection of useful DNS
+resolver utilities.
+
+WWW: https://github.com/trolldbois/python3-adns/