aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-08 18:45:38 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-08 18:45:38 +0000
commit2cf4c1e2c8f35d7e8d8df1acc5a582d916a7d608 (patch)
treefffa16c225e5c8c0a72ed5f5d5c9a88be4d7839c /dns
parent346415e3c06029d36c899250a77aa33df43cf6fc (diff)
downloadports-2cf4c1e2c8f35d7e8d8df1acc5a582d916a7d608.tar.gz
ports-2cf4c1e2c8f35d7e8d8df1acc5a582d916a7d608.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/p5-Net-DNS-SEC/Makefile10
-rw-r--r--dns/p5-Net-DNS/Makefile8
-rw-r--r--dns/p5-Net-Domain-ExpireDate/Makefile8
-rw-r--r--dns/p5-POE-Component-Resolver/Makefile11
4 files changed, 5 insertions, 32 deletions
diff --git a/dns/p5-Net-DNS-SEC/Makefile b/dns/p5-Net-DNS-SEC/Makefile
index 5f16c79a55a7..bee921dde190 100644
--- a/dns/p5-Net-DNS-SEC/Makefile
+++ b/dns/p5-Net-DNS-SEC/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0.03:${PORTSDIR}/security/p5-Crypt-OpenSSL
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-MIME-Base32>=0:${PORTSDIR}/converters/p5-MIME-Base32 \
p5-Net-DNS>=0.64:${PORTSDIR}/dns/p5-Net-DNS
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -33,10 +33,4 @@ MAN3= Net::DNS::Keyset.3 Net::DNS::RR::DS.3 Net::DNS::RR::KEY.3 \
Net::DNS::RR::NSEC.3 Net::DNS::RR::DNSKEY.3 \
Net::DNS::RR::NSEC3.3 Net::DNS::RR::NSEC3PARAM.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-Digest-SHA>=5.23:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS/Makefile b/dns/p5-Net-DNS/Makefile
index 7f597bc0bbdb..a2275b4c9ffb 100644
--- a/dns/p5-Net-DNS/Makefile
+++ b/dns/p5-Net-DNS/Makefile
@@ -55,12 +55,6 @@ MAN3= Net::DNS.3 Net::DNS::Header.3 Net::DNS::Packet.3 \
PORTDOCS= *
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
.if !defined(WITHOUT_IPV6)
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6
.endif
@@ -78,4 +72,4 @@ post-install:
@${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-Domain-ExpireDate/Makefile b/dns/p5-Net-Domain-ExpireDate/Makefile
index b88534e8e667..a1c78f4ab828 100644
--- a/dns/p5-Net-Domain-ExpireDate/Makefile
+++ b/dns/p5-Net-Domain-ExpireDate/Makefile
@@ -24,10 +24,4 @@ MAN3= Net::Domain::ExpireDate.3
post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -delete
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500905
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-POE-Component-Resolver/Makefile b/dns/p5-POE-Component-Resolver/Makefile
index 2f13ae509627..45a1baaaa356 100644
--- a/dns/p5-POE-Component-Resolver/Makefile
+++ b/dns/p5-POE-Component-Resolver/Makefile
@@ -29,13 +29,4 @@ PERL_CONFIGURE= yes
MAN3= POE::Component::Resolver.3 \
POE::Component::Resolver::Sidecar.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Storable>=2.18:${PORTSDIR}/devel/p5-Storable \
- p5-Time-HiRes>=1.9711:${PORTSDIR}/devel/p5-Time-HiRes
-RUN_DEPENDS+= p5-Storable>=2.18:${PORTSDIR}/devel/p5-Storable \
- p5-Time-HiRes>=1.9711:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>