aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-27 19:30:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-27 19:30:12 +0000
commit64217076cc1beb6d5cb08051ab28783a231964a6 (patch)
treecf2e9974294cd10f84e5a2cccfdad35d483321f8 /dns
parent399cdbe7ef8a30c7c37fddee57f04337f07c3cbf (diff)
downloadports-64217076cc1beb6d5cb08051ab28783a231964a6.tar.gz
ports-64217076cc1beb6d5cb08051ab28783a231964a6.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/rubygem-zonefile/Makefile19
-rw-r--r--dns/rubygem-zonefile/distinfo3
-rw-r--r--dns/rubygem-zonefile/pkg-descr9
4 files changed, 32 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index c6f132966c29..c5a7375d8f77 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -214,6 +214,7 @@
SUBDIR += rubygem-public_suffix_service
SUBDIR += rubygem-simpleidn
SUBDIR += rubygem-validates_hostname
+ SUBDIR += rubygem-zonefile
SUBDIR += samba-nsupdate
SUBDIR += scavenge
SUBDIR += sheerdns
diff --git a/dns/rubygem-zonefile/Makefile b/dns/rubygem-zonefile/Makefile
new file mode 100644
index 000000000000..8c54d6927ea5
--- /dev/null
+++ b/dns/rubygem-zonefile/Makefile
@@ -0,0 +1,19 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= zonefile
+PORTVERSION= 1.06
+CATEGORIES= dns rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library to manipulate BIND compatible Zonefiles (RFC1035)
+
+LICENSE= MIT
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/dns/rubygem-zonefile/distinfo b/dns/rubygem-zonefile/distinfo
new file mode 100644
index 000000000000..11ea787fda31
--- /dev/null
+++ b/dns/rubygem-zonefile/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1601021622
+SHA256 (rubygem/zonefile-1.06.gem) = 86e69db76af9d9e2a54229919681960ba0307f6b45eab29898affb24bbcd4631
+SIZE (rubygem/zonefile-1.06.gem) = 12800
diff --git a/dns/rubygem-zonefile/pkg-descr b/dns/rubygem-zonefile/pkg-descr
new file mode 100644
index 000000000000..39b5264e355d
--- /dev/null
+++ b/dns/rubygem-zonefile/pkg-descr
@@ -0,0 +1,9 @@
+Ruby Zonefile - Parse and manipulate DNS Zone Files
+
+This class can read, manipulate and create DNS zone files. It supports A, AAAA,
+MX, NS, SOA, TXT, CNAME, PTR and SRV records. The data can be accessed by the
+instance method of the same name. All except SOA return an array of hashes
+containing the named data. SOA directly returns the hash since there can only be
+one SOA information.
+
+WWW: https://github.com/boesemar/zonefile