aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-26 16:02:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-26 16:02:50 +0000
commitc3f6bc24f36f96da7c91965bdd1310871d20e811 (patch)
tree9196837e407f2a1ef2caf5ab5f5d0ff8eaddf105 /dns
parent6a42eb9ec9416afbe983a7f4f4e4cb574cf4ace2 (diff)
downloadports-c3f6bc24f36f96da7c91965bdd1310871d20e811.tar.gz
ports-c3f6bc24f36f96da7c91965bdd1310871d20e811.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/knot/Makefile5
-rw-r--r--dns/knot/files/knotd.in25
-rw-r--r--dns/knot/files/pkg-message.in17
3 files changed, 16 insertions, 31 deletions
diff --git a/dns/knot/Makefile b/dns/knot/Makefile
index b1d5ad87fc5e..3e92ded8bb3f 100644
--- a/dns/knot/Makefile
+++ b/dns/knot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= knot
DISTVERSION= 1.3.3
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
http://dns-lab.com/downloads/knot-dns/
@@ -37,5 +38,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/samples/knot.sample.conf ${STAGEDIR}${ETCDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
+ @${MKDIR} ${PREFIX}/var/lib/knot
+ @${MKDIR} ${PREFIX}/var/run/knot
+ @${CHOWN} 53:53 ${PREFIX}/var/lib/knot
+ @${CHOWN} 53:53 ${PREFIX}/var/run/knot
.include <bsd.port.mk>
diff --git a/dns/knot/files/knotd.in b/dns/knot/files/knotd.in
index d6b87d2b258b..eed0d803263b 100644
--- a/dns/knot/files/knotd.in
+++ b/dns/knot/files/knotd.in
@@ -19,32 +19,21 @@ name=knot
rcvar=knot_enable
extra_commands="reload"
-reload_cmd="${name}_reload"
-status_cmd="${name}_status"
-stop_cmd="${name}_stop"
+reload_cmd="${name}_x reload"
+status_cmd="${name}_x status"
+stop_cmd=" ${name}_x stop"
load_rc_config ${name}
: ${knot_enable:="NO"}
: ${knot_config="%%PREFIX%%/etc/knot/knot.conf"}
-command=%%PREFIX%%/sbin/${name}c
-procname=%%PREFIX%%/sbin/${name}d
-pidfile=/var/run/${name}.pid
-
-command_args="-c ${knot_config} -w start"
+command=%%PREFIX%%/sbin/${name}d
+command_args="-c ${knot_config} -d"
required_files=${knot_config}
-knot_reload() {
- echo "Reloading ${name}."
- ${command} -c ${knot_config} reload
- }
-knot_status() {
- ${command} -c ${knot_config} status
- }
-knot_stop() {
- echo "Stopping ${name}."
- ${command} -c ${knot_config} stop
+knot_x() {
+ %%PREFIX%%/sbin/${name}c -c ${knot_config} "$1"
}
run_rc_command "$1"
diff --git a/dns/knot/files/pkg-message.in b/dns/knot/files/pkg-message.in
index 19e4ad2af30d..5237fbe007c3 100644
--- a/dns/knot/files/pkg-message.in
+++ b/dns/knot/files/pkg-message.in
@@ -1,30 +1,21 @@
####################################################################
#
-# To start using Knot DNS, you should complete the following tasks:
-#
-# ----- configure --------------------------------------------------
+# To get Knot DNS started:
#
cp %%ETCDIR%%/knot.sample.conf %%ETCDIR%%/knot.conf
$EDITOR %%ETCDIR%%/knot.conf
-#
-# ----- prepare ----------------------------------------------------
-#
-# required:
echo knot_enable=\"YES\" >> /etc/rc.conf
-# for customization if desired:
# echo knot_config=\"%%PREFIX%%/etc/knot/knot.conf\" >> /etc/rc.conf
-#
-# ----- startup ----------------------------------------------------
-#
%%PREFIX%%/etc/rc.d/knotd start
#
####################################################################
-
When upgrading from version of before 1.3.0-RC1:
mind the default config file location has changed.
+ When upgrading from version of 1.3.1-RC1 or before:
+ the startup script has changed due to parameter changes.
+ That problem reapeared in port 1.3.3 and was fixed in 1.3.3_1.
====================================================================
-