aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-04-16 20:44:14 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-04-16 20:44:14 +0000
commitee6849718b22f1c1d92190ec4d118745dcf42614 (patch)
tree938011683ec6a2c978a161269b3baf7020c05ebc /dns
parent20ab4dcc976aa7bd3eeca20dc9ac91eff5be0744 (diff)
downloadports-ee6849718b22f1c1d92190ec4d118745dcf42614.tar.gz
ports-ee6849718b22f1c1d92190ec4d118745dcf42614.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/sshfp/Makefile23
-rw-r--r--dns/sshfp/distinfo4
-rw-r--r--dns/sshfp/files/patch-dane14
3 files changed, 31 insertions, 10 deletions
diff --git a/dns/sshfp/Makefile b/dns/sshfp/Makefile
index 7dbb27f2906b..901f9ac7e0f6 100644
--- a/dns/sshfp/Makefile
+++ b/dns/sshfp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sshfp
-PORTVERSION= 1.1.6
-PORTREVISION= 1
+PORTVERSION= 1.2.0
CATEGORIES= dns security
MASTER_SITES= ftp://ftp.xelerance.com/sshfp/ \
CRITICAL
@@ -15,21 +14,29 @@ MASTER_SITES= ftp://ftp.xelerance.com/sshfp/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Generate SSHFP DNS records from knownhosts files or ssh-keyscan
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython \
+ ${PYTHON_PKGNAMEPREFIX}argparse>=0.8.0:${PORTSDIR}/devel/py-argparse
+LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
NO_BUILD= yes
USE_PYTHON= 2.5+
LICENSE= GPLv2
-MAN1= sshfp.1
-PLIST_FILES= bin/sshfp
+MAN1= sshfp.1 dane.1
+PLIST_FILES= bin/sshfp bin/dane
+
+PY_FILES= sshfp dane
post-patch:
- @${REINPLACE_CMD} -e '1s|.*|#!${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
+.for f in ${PY_FILES}
+ @${REINPLACE_CMD} -e '1s|.*|#!${PYTHON_CMD}|' ${WRKSRC}/${f}
+.endfor
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+.for f in ${PY_FILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${f}.1 ${MANPREFIX}/man/man1
+.endfor
.include <bsd.port.mk>
diff --git a/dns/sshfp/distinfo b/dns/sshfp/distinfo
index 00e0244cf0b8..9d11e12cdb8d 100644
--- a/dns/sshfp/distinfo
+++ b/dns/sshfp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sshfp-1.1.6.tar.gz) = 3e89de259966c4a4e5dec03117192c301c5b7d5b34f929c7a9baf7273bb196bc
-SIZE (sshfp-1.1.6.tar.gz) = 17625
+SHA256 (sshfp-1.2.0.tar.gz) = 3b5ef1304e10642e04a11fc5e70b107d0b326f45bb145efaa55b3508a2a8d5ed
+SIZE (sshfp-1.2.0.tar.gz) = 28109
diff --git a/dns/sshfp/files/patch-dane b/dns/sshfp/files/patch-dane
new file mode 100644
index 000000000000..8525b43bfd2c
--- /dev/null
+++ b/dns/sshfp/files/patch-dane
@@ -0,0 +1,14 @@
+--- dane.orig 2011-04-15 15:47:31.000000000 +0200
++++ dane 2011-04-15 15:49:44.000000000 +0200
+@@ -27,9 +27,8 @@
+ try:
+ import ldns
+ except ImportError:
+- print "dane requires the ldns-python sub-package from http://www.nlnetlabs.nl/projects/ldns/"
+- print "Fedora/CentOS: yum install ldns-python"
+- print "Debian/Ubuntu: apt-get install python-ldns"
++ print "dane requires the ldns python bindings. Please reinstall dns/ldns with the"
++ print "python binding option enabled."
+ sys.exit()
+
+