aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-06-01 17:55:27 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-06-01 17:55:27 +0000
commit56117f87e151bd10e16553f2a30a7c4f7bf20827 (patch)
treee7d8d6716bcf2c9d57f145865c998a43c626c190 /dns
parent1817eddea2a22ebe63f425e22bb1aae938f047fc (diff)
downloadports-56117f87e151bd10e16553f2a30a7c4f7bf20827.tar.gz
ports-56117f87e151bd10e16553f2a30a7c4f7bf20827.zip
Update to new release 2.77.
Notes
Notes: svn path=/head/; revision=442303
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsmasq/Makefile21
-rw-r--r--dns/dnsmasq/distinfo6
-rw-r--r--dns/dnsmasq/files/patch-dnsmasq.conf.example15
3 files changed, 14 insertions, 28 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 914228f06850..908dee564892 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dnsmasq
-DISTVERSION= 2.76
+DISTVERSION= 2.77
PORTREVISION= 0 # leave this in even if 0 to avoid PORTEPOCH bumps
PORTEPOCH= 1
CATEGORIES= dns ipv6
@@ -20,7 +20,7 @@ PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
SUB_FILES= pkg-message
-CFLAGS+= -Wall -Wno-unused-value -Wno-unused-parameter
+CFLAGS+= -Wall -Wno-unused-value -Wno-unused-parameter -Wno-unused-variable -Wno-unused-function
CPPFLAGS+= -I${LOCALBASE}/include
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" COPTS="${CFLAGS}" LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}"
@@ -47,18 +47,19 @@ IPSET_CFLAGS_OFF=-DNO_IPSET
.if ${PORT_OPTIONS:MNLS}
USES+= gettext gmake iconv pkgconfig
-LIB_DEPENDS+= libidn.so:dns/libidn
+CFLAGS+= -DHAVE_LIBIDN2
+LIB_DEPENDS+= libidn2.so:dns/libidn2
PLIST_SUB+= NLS=""
ALL_TARGET= all-i18n
-_intllibs= -lintl
+_intllibs= -lidn2 -lintl
.else
_intllibs=
PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MIDN}
USES+= iconv
-CFLAGS+= -DHAVE_IDN
-LIB_DEPENDS+= libidn.so:dns/libidn
-_intllibs+= -lidn
+CFLAGS+= -DHAVE_LIBIDN2
+LIB_DEPENDS+= libidn2.so:dns/libidn2
+_intllibs+= -lidn2
.endif
.endif
@@ -96,10 +97,10 @@ post-patch:
pre-configure: pretty-print-config
.if ${PORT_OPTIONS:MIDN}
.if empty(PORT_OPTIONS:MNLS)
- @if ${READELF} -d ${LOCALBASE}/lib/libidn.so \
+ @if ${READELF} -d ${LOCALBASE}/lib/libidn2.so \
| ${EGREP} -q '\<NEEDED\>.*\[libintl\.so' ; \
- then ${ECHO} ; ${ECHO} 'WARNING: dns/libidn was compiled with NLS support!' ; \
- ${ECHO} 'Recompile libidn WITHOUT_NLS to get rid of NLS dependencies.' ; ${ECHO} ; \
+ then ${ECHO} ; ${ECHO} 'WARNING: dns/libidn2 was compiled with NLS support!' ; \
+ ${ECHO} 'Recompile libidn2 WITHOUT_NLS to get rid of NLS dependencies.' ; ${ECHO} ; \
fi
.else
@${ECHO} 'WARNING: IDN and NLS enabled, building IDN WITH NLS.'
diff --git a/dns/dnsmasq/distinfo b/dns/dnsmasq/distinfo
index 6c4469bece5e..c6427e8adb89 100644
--- a/dns/dnsmasq/distinfo
+++ b/dns/dnsmasq/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463608856
-SHA256 (dnsmasq-2.76.tar.xz) = 4b92698dee19ca0cb2a8f2e48f1d2dffd01a21eb15d1fbed4cf085630c8c9f96
-SIZE (dnsmasq-2.76.tar.xz) = 480796
+TIMESTAMP = 1496338430
+SHA256 (dnsmasq-2.77.tar.xz) = 6eac3b1c50ae25170e3ff8c96ddb55236cf45007633fdb8a35b1f3e02f5f8b8a
+SIZE (dnsmasq-2.77.tar.xz) = 487244
diff --git a/dns/dnsmasq/files/patch-dnsmasq.conf.example b/dns/dnsmasq/files/patch-dnsmasq.conf.example
deleted file mode 100644
index 2ec44e871198..000000000000
--- a/dns/dnsmasq/files/patch-dnsmasq.conf.example
+++ /dev/null
@@ -1,15 +0,0 @@
---- dnsmasq.conf.example.orig 2015-06-12 20:39:11 UTC
-+++ dnsmasq.conf.example
-@@ -123,6 +123,12 @@
- # running another nameserver on the same machine.
- #bind-interfaces
-
-+# Accept DNS queries only from hosts whose address is on a local
-+# subnet, ie a subnet for which an interface exists on the server.
-+# This option only has effect if there are no --interface
-+# --except-interface, --listen-address or --auth-server options.
-+local-service
-+
- # If you don't want dnsmasq to read /etc/hosts, uncomment the
- # following line.
- #no-hosts