aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2018-11-20 10:18:48 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2018-11-20 10:18:48 +0000
commit29bbd4bacd4e0d06c58aa0ad61f00b8d039c65c6 (patch)
treeb9d51f8f81f2596284fe8b945ac7f552c468d172 /dns
parent1d5c90a57dc980eb413c33aea965e79b0596d43d (diff)
downloadports-29bbd4bacd4e0d06c58aa0ad61f00b8d039c65c6.tar.gz
ports-29bbd4bacd4e0d06c58aa0ad61f00b8d039c65c6.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns/Makefile4
-rw-r--r--dns/powerdns/distinfo6
-rw-r--r--dns/powerdns/files/patch-pdns_opensslsigners.cc12
3 files changed, 5 insertions, 17 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index e7a01e69d1fa..3e29470a9d7e 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= powerdns
-DISTVERSION= 4.1.4
-PORTREVISION= 1
+DISTVERSION= 4.1.5
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${DISTVERSION}
@@ -19,6 +18,7 @@ LIB_DEPENDS= libboost_serialization.so:devel/boost-libs
USES= compiler:c++11-lib cpe gmake libtool localbase:ldflags pathfix pkgconfig ssl \
tar:bzip2
+
USE_LDCONFIG= YES
USE_SUBMAKE= YES
GNU_CONFIGURE= YES
diff --git a/dns/powerdns/distinfo b/dns/powerdns/distinfo
index 1d2e67d34b9b..100285e64f65 100644
--- a/dns/powerdns/distinfo
+++ b/dns/powerdns/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1535616205
-SHA256 (pdns-4.1.4.tar.bz2) = e9408603383d529b3bbee2509b73187d2186c502a9b052d07e250cd8f3873ed5
-SIZE (pdns-4.1.4.tar.bz2) = 1089376
+TIMESTAMP = 1541580311
+SHA256 (pdns-4.1.5.tar.bz2) = c329570a66d8c7340d38fd582cb23ad642799b83c7276fb0fdea4303759b4f8a
+SIZE (pdns-4.1.5.tar.bz2) = 1116238
diff --git a/dns/powerdns/files/patch-pdns_opensslsigners.cc b/dns/powerdns/files/patch-pdns_opensslsigners.cc
deleted file mode 100644
index ca8679c3de57..000000000000
--- a/dns/powerdns/files/patch-pdns_opensslsigners.cc
+++ /dev/null
@@ -1,12 +0,0 @@
---- pdns/opensslsigners.cc.orig 2018-02-16 09:52:29 UTC
-+++ pdns/opensslsigners.cc
-@@ -33,7 +33,8 @@
- #include "opensslsigners.hh"
- #include "dnssecinfra.hh"
-
--#if (OPENSSL_VERSION_NUMBER < 0x1010000fL || defined LIBRESSL_VERSION_NUMBER)
-+#if (OPENSSL_VERSION_NUMBER < 0x1010000fL || \
-+ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL))
- /* OpenSSL < 1.1.0 needs support for threading/locking in the calling application. */
- static pthread_mutex_t *openssllocks;
-