aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-09-02 17:44:20 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-09-02 17:44:20 +0000
commit043e594f3f82e30dcdcf41c48fbadf398998b5d0 (patch)
tree131b0b682070279cade5f395cf860a548a8aa368 /dns
parent595ac6ed9adf75af3bf28f5d2c248b27c12d9817 (diff)
downloadports-043e594f3f82e30dcdcf41c48fbadf398998b5d0.tar.gz
ports-043e594f3f82e30dcdcf41c48fbadf398998b5d0.zip
Update to latest commit.
Notes
Notes: svn path=/head/; revision=510829
Diffstat (limited to 'dns')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
3 files changed, 12 insertions, 12 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index d0b0b323b69f..e69200b1a6a7 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -41,13 +41,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.3a0.2019.08.25
+ISCVERSION= 9.15.3a0.2019.08.30
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 417df8cfbc08c9c08cad29402f3827d43b77148a
+GL_COMMIT= 2367d61016304b19dadfadea70dffcab536ce4dc
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index bac28cbee431..25fb061837a2 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1566810353
-SHA256 (isc-projects-bind9-417df8cfbc08c9c08cad29402f3827d43b77148a_GL0.tar.gz) = 4afe9cca4dd429c1469930d7780483f28701d613675865cc56d97dcc30d5fa6f
-SIZE (isc-projects-bind9-417df8cfbc08c9c08cad29402f3827d43b77148a_GL0.tar.gz) = 6335775
+TIMESTAMP = 1567419416
+SHA256 (isc-projects-bind9-2367d61016304b19dadfadea70dffcab536ce4dc_GL0.tar.gz) = f5bbdd799f32ead9a46fda46ff78cbe17c6b6b05a8be725008f4d485f4317e6e
+SIZE (isc-projects-bind9-2367d61016304b19dadfadea70dffcab536ce4dc_GL0.tar.gz) = 6337913
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 70c5bce86955..7a4242d55bc5 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2019-08-12 08:39:30 UTC
+--- bin/named/config.c.orig 2019-08-30 19:08:30 UTC
+++ bin/named/config.c
@@ -177,6 +177,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-08-12 08:39:30 UTC
+--- bin/named/server.c.orig 2019-08-30 19:08:30 UTC
+++ bin/named/server.c
-@@ -4217,6 +4217,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4215,6 +4215,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-08-12 08:39:30 UTC
+--- lib/dns/include/dns/view.h.orig 2019-08-30 19:08:30 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-08-12 08:39:30 UTC
+--- lib/dns/resolver.c.orig 2019-08-30 19:08:30 UTC
+++ lib/dns/resolver.c
-@@ -6011,6 +6011,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6007,6 +6007,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-08-12 08:39:30 UTC
+--- lib/isccfg/namedconf.c.orig 2019-08-30 19:08:30 UTC
+++ lib/isccfg/namedconf.c
@@ -1907,6 +1907,7 @@ view_clauses[] = {
#endif