aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-09-16 19:15:21 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-09-16 19:15:21 +0000
commit3a2a218caed32bf0b62432b99bdd138959bf89f6 (patch)
treef4a14885086c847d8cfd85f09040f11e8692561a /dns
parent363636e3f506c33cd2e20901dad251f1770e83b1 (diff)
downloadports-3a2a218caed32bf0b62432b99bdd138959bf89f6.tar.gz
ports-3a2a218caed32bf0b62432b99bdd138959bf89f6.zip
New port: dns/rdap
OpenRDAP is a command line client for the Registration Data Access Protocol, written in Go. RDAP is a replacement for WHOIS, which provides domain name & IP address registration information in JSON format over HTTP. WWW: https://www.openrdap.org/
Notes
Notes: svn path=/head/; revision=512182
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/rdap/Makefile30
-rw-r--r--dns/rdap/distinfo17
-rw-r--r--dns/rdap/pkg-descr7
4 files changed, 55 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 96270101610d..d38564a844ce 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -209,6 +209,7 @@
SUBDIR += rbldnsd
SUBDIR += rbllookup
SUBDIR += rbllookup-ng
+ SUBDIR += rdap
SUBDIR += renewck
SUBDIR += rpsl2acl
SUBDIR += rubygem-dnsruby
diff --git a/dns/rdap/Makefile b/dns/rdap/Makefile
new file mode 100644
index 000000000000..63f072dc6e5a
--- /dev/null
+++ b/dns/rdap/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= rdap
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9.0
+CATEGORIES= dns
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= CLI for the Registration Data Access Protocol, RDAP
+
+LICENSE= MIT
+
+USES= go:modules
+USE_GITHUB= yes
+
+GH_ACCOUNT= openrdap
+GH_TAGNAME= e2ea151
+GH_TUPLE= \
+ alecthomas:kingpin:v2.2.6:alecthomas_kingpin/vendor/gopkg.in/alecthomas/kingpin.v2 \
+ alecthomas:template:fb15b899a751:alecthomas_template/vendor/github.com/alecthomas/template \
+ alecthomas:units:c3de453c63f4:alecthomas_units/vendor/github.com/alecthomas/units \
+ davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-spew \
+ golang:crypto:4def268fd1a4:golang_crypto/vendor/golang.org/x/crypto \
+ jarcoal:httpmock:v1.0.4:jarcoal_httpmock/vendor/github.com/jarcoal/httpmock \
+ mitchellh:go-homedir:v1.1.0:mitchellh_go_homedir/vendor/github.com/mitchellh/go-homedir
+
+GO_TARGET= cmd/rdap/main.go:rdap
+PLIST_FILES= bin/rdap
+
+.include <bsd.port.mk>
diff --git a/dns/rdap/distinfo b/dns/rdap/distinfo
new file mode 100644
index 000000000000..fae0886117b8
--- /dev/null
+++ b/dns/rdap/distinfo
@@ -0,0 +1,17 @@
+TIMESTAMP = 1568574348
+SHA256 (openrdap-rdap-v0.9.0-e2ea151_GH0.tar.gz) = 087f5ec154db813948e9e546ef85f15bd0d49350c708af3bbde2d9911dbc22bd
+SIZE (openrdap-rdap-v0.9.0-e2ea151_GH0.tar.gz) = 78024
+SHA256 (alecthomas-kingpin-v2.2.6_GH0.tar.gz) = 4624eae43489de8a71ea60efaf6744c581b6bd62909f7514c484c1ea0efaba5a
+SIZE (alecthomas-kingpin-v2.2.6_GH0.tar.gz) = 44383
+SHA256 (alecthomas-template-fb15b899a751_GH0.tar.gz) = 2e2a44375eca48ce941182504b5d13aa98182b9a3f64ace33bfda52208bd0f5e
+SIZE (alecthomas-template-fb15b899a751_GH0.tar.gz) = 55339
+SHA256 (alecthomas-units-c3de453c63f4_GH0.tar.gz) = b2eb77de46e677edb150bb4bf81d213416a477525980e315264cbd70b22d0ece
+SIZE (alecthomas-units-c3de453c63f4_GH0.tar.gz) = 3485
+SHA256 (davecgh-go-spew-v1.1.1_GH0.tar.gz) = 7d82b9bb7291adbe7498fe946920ab3e7fc9e6cbfc3b2294693fad00bf0dd17e
+SIZE (davecgh-go-spew-v1.1.1_GH0.tar.gz) = 42152
+SHA256 (golang-crypto-4def268fd1a4_GH0.tar.gz) = eaf2ba9df95911f41a340478d1fbb540d7bc21939e4688273995dabf58e8c7b0
+SIZE (golang-crypto-4def268fd1a4_GH0.tar.gz) = 1693117
+SHA256 (jarcoal-httpmock-v1.0.4_GH0.tar.gz) = a1d804455a31dc91db474224ce0190b63f405c86a5335c9f3801b01a90bd23f4
+SIZE (jarcoal-httpmock-v1.0.4_GH0.tar.gz) = 20389
+SHA256 (mitchellh-go-homedir-v1.1.0_GH0.tar.gz) = 646671c73a84a8dfb4a5a76b80c7b63549ffefa906524d45077301bc7da76600
+SIZE (mitchellh-go-homedir-v1.1.0_GH0.tar.gz) = 3362
diff --git a/dns/rdap/pkg-descr b/dns/rdap/pkg-descr
new file mode 100644
index 000000000000..11f6d6b4fbb2
--- /dev/null
+++ b/dns/rdap/pkg-descr
@@ -0,0 +1,7 @@
+OpenRDAP is a command line client for the Registration Data Access
+Protocol, written in Go.
+
+RDAP is a replacement for WHOIS, which provides domain name & IP
+address registration information in JSON format over HTTP.
+
+WWW: https://www.openrdap.org/