aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2013-04-29 16:10:07 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2013-04-29 16:10:07 +0000
commitecec69fbc311162911f66439dedf61b8176ef964 (patch)
tree7fd7a121e9126df429d538622fdd7d0acbd80543 /dns
parent39e480425abf3a256b3743234921873c85f7d027 (diff)
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/unbound/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 5f96b9da9b5d..cc3b612be854 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -45,10 +45,15 @@ PORTDOCS= CREDITS Changelog FEATURES LICENSE README README.svn \
ietf67-design-02.pdf requirements.txt
PLIST_SUB+= PYTHON=${PYTHON} MUNIN=${MUNIN}
-OPTIONS_DEFINE= LIBEVENT THREADS PYTHON GOST ECDSA MUNIN
+OPTIONS_DEFINE= THREADS PYTHON GOST ECDSA MUNIN
OPTIONS_DEFAULT=THREADS ECDSA
+OPTIONS_RADIO= LIBEVENT
+OPTIONS_RADIO_LIBEVENT= LIBEVENT14 LIBEVENT20
+
LIBEVENT_DESC= Enable whenever using many (10000) outgoing ports
+LIBEVENT14_DESC=Build against libevent-1.4 (devel/libevent)
+LIBEVENT20_DESC=Build against libevent-2.0 (devel/libevent2)
GOST_DESC= Enable GOST support (requires OpenSSL from ports)
ECDSA_DESC= Enable ECDSA (elliptic curve) support
MUNIN_DESC= Install Munin plugin
@@ -90,9 +95,16 @@ MUNIN=
MUNIN= "@comment "
.endif
-.if ${PORT_OPTIONS:MLIBEVENT}
+.if ${PORT_OPTIONS:MLIBEVENT14}
LIB_DEPENDS+= event-1:${PORTSDIR}/devel/libevent
CONFIGURE_ARGS+=--with-libevent=${LOCALBASE}
+.elif ${PORT_OPTIONS:MLIBEVENT20}
+LIB_DEPENDS+= event-2:${PORTSDIR}/devel/libevent2
+USES+= pkgconfig
+CONFIGURE_ARGS+=--with-libevent=${NONEXISTENT}
+CONFIGURE_ENV+= found_libevent=yes
+CPPFLAGS+= $$(pkg-config libevent --cflags-only-I)
+LDFLAGS+= $$(pkg-config libevent --libs-only-L)
.else
CONFIGURE_ARGS+=--with-libevent=no
.endif