aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /dns
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/linux-c6-libasyncns/Makefile18
-rw-r--r--dns/linux-c6-libasyncns/distinfo.i6864
-rw-r--r--dns/linux-c6-libasyncns/pkg-descr20
-rw-r--r--dns/linux-f10-libasyncns/Makefile3
5 files changed, 44 insertions, 2 deletions
diff --git a/dns/Makefile b/dns/Makefile
index b10d4f89517c..5897daf11354 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -75,6 +75,7 @@
SUBDIR += libbind
SUBDIR += libdjbdns
SUBDIR += libidn
+ SUBDIR += linux-c6-libasyncns
SUBDIR += linux-f10-libasyncns
SUBDIR += mDNSResponder_nss
SUBDIR += maradns
diff --git a/dns/linux-c6-libasyncns/Makefile b/dns/linux-c6-libasyncns/Makefile
new file mode 100644
index 000000000000..b0133e8e1480
--- /dev/null
+++ b/dns/linux-c6-libasyncns/Makefile
@@ -0,0 +1,18 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= libasyncns
+PORTVERSION= 0.8
+CATEGORIES= dns devel linux
+PKGNAMEPREFIX= linux-c6-
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= C library for executing DNS queries asynchronously (Linux CentOS ${LINUX_DIST_VER})
+
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+RPMVERSION= 1.1.el6
+USE_LDCONFIG= yes
+AUTOMATIC_PLIST= yes
+
+.include <bsd.port.mk>
diff --git a/dns/linux-c6-libasyncns/distinfo.i686 b/dns/linux-c6-libasyncns/distinfo.i686
new file mode 100644
index 000000000000..7020869de3e2
--- /dev/null
+++ b/dns/linux-c6-libasyncns/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/libasyncns-0.8-1.1.el6.i686.rpm) = 29b5986a6ed47b9c54857df3238f8a6348792cfeb9c8923f75208d9738c49748
+SIZE (rpm/i686/centos/6.5/libasyncns-0.8-1.1.el6.i686.rpm) = 24888
+SHA256 (rpm/i686/centos/6.5/libasyncns-0.8-1.1.el6.src.rpm) = 6d0b1cd3002d4d79c43bc121e28f5c9bd65b69a80f9cd117cef234caecc47537
+SIZE (rpm/i686/centos/6.5/libasyncns-0.8-1.1.el6.src.rpm) = 346427
diff --git a/dns/linux-c6-libasyncns/pkg-descr b/dns/linux-c6-libasyncns/pkg-descr
new file mode 100644
index 000000000000..36b59b4cd45c
--- /dev/null
+++ b/dns/linux-c6-libasyncns/pkg-descr
@@ -0,0 +1,20 @@
+libasyncns is a C library for Linux/Unix for executing name service queries
+asynchronously. It is an asynchronous wrapper around getaddrinfo(3),
+getnameinfo(3), res_query(3) and res_search(3) from libc and libresolv.
+
+In contrast to GNU's asynchronous name resolving API getaddrinfo_a(),
+libasyncns does not make use of UNIX signals for reporting completion of name
+queries. Instead, the API exports a standard UNIX file descriptor which may be
+integerated cleanly into custom main loops.
+
+In contrast to asynchronous DNS resolving libraries like libdenise, skadns,
+adns, libasyncns is just an asynchronous wrapper around the libc's synchronous
+getaddrinfo() API, which has the advantage of allowing name resolution using
+techniques like Multicast DNS, LDAP or NIS using standard libc NSS (Name
+Service Switch) modules. libasyncns is compatible with IPv6 if the underlying
+libc is.
+
+libasyncns is very tiny, consisting of just one header and one source file. It
+has no dependencies besides libc.
+
+WWW: http://0pointer.de/lennart/projects/libasyncns/
diff --git a/dns/linux-f10-libasyncns/Makefile b/dns/linux-f10-libasyncns/Makefile
index 441c2a9295e2..f27306ab963b 100644
--- a/dns/linux-f10-libasyncns/Makefile
+++ b/dns/linux-f10-libasyncns/Makefile
@@ -5,13 +5,12 @@ PORTNAME= libasyncns
PORTVERSION= 0.7
CATEGORIES= dns devel linux
PKGNAMEPREFIX= linux-f10-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= itetcu@FreeBSD.org
COMMENT= C library for executing DNS queries asynchronously (Linux Fedora 10)
+USE_LINUX= f10
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 10
RPMVERSION= 1.fc10
USE_LDCONFIG= yes
AUTOMATIC_PLIST=yes