aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-27 19:30:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-27 19:30:02 +0000
commit399cdbe7ef8a30c7c37fddee57f04337f07c3cbf (patch)
tree6c23e39981b5ed92940ecaa0056551facc3e1d38 /dns
parent20e01801965f4dad6b5a5159f974f3aae3a1460c (diff)
downloadports-399cdbe7ef8a30c7c37fddee57f04337f07c3cbf.tar.gz
ports-399cdbe7ef8a30c7c37fddee57f04337f07c3cbf.zip
Add rubygem-google-cloud-dns 0.33.0
Google Cloud DNS is a high-performance, resilient, global DNS service that provides a cost-effective way to make your applications and services available to your users. This programmable, authoritative DNS service can be used to easily publish and manage DNS records using the same infrastructure relied upon by Google. WWW: https://github.com/googleapis/google-cloud-ruby/tree/master/google-cloud-dns
Notes
Notes: svn path=/head/; revision=550297
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/rubygem-google-cloud-dns/Makefile25
-rw-r--r--dns/rubygem-google-cloud-dns/distinfo3
-rw-r--r--dns/rubygem-google-cloud-dns/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 03f6a758e08b..c6f132966c29 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -207,6 +207,7 @@
SUBDIR += rpsl2acl
SUBDIR += rubygem-dnsruby
SUBDIR += rubygem-gitlab-net-dns
+ SUBDIR += rubygem-google-cloud-dns
SUBDIR += rubygem-idn-ruby
SUBDIR += rubygem-net-dns
SUBDIR += rubygem-public_suffix
diff --git a/dns/rubygem-google-cloud-dns/Makefile b/dns/rubygem-google-cloud-dns/Makefile
new file mode 100644
index 000000000000..370a8d6f723b
--- /dev/null
+++ b/dns/rubygem-google-cloud-dns/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= google-cloud-dns
+PORTVERSION= 0.33.0
+CATEGORIES= dns rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Official library for Google Cloud DNS
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-google-api-client>=0.33<1:devel/rubygem-google-api-client \
+ rubygem-google-cloud-core>=1.2<2:net/rubygem-google-cloud-core \
+ rubygem-googleauth>=0.9<1:security/rubygem-googleauth \
+ rubygem-zonefile>=1.04<2:dns/rubygem-zonefile
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/dns/rubygem-google-cloud-dns/distinfo b/dns/rubygem-google-cloud-dns/distinfo
new file mode 100644
index 000000000000..58c03fdc8a11
--- /dev/null
+++ b/dns/rubygem-google-cloud-dns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1601021620
+SHA256 (rubygem/google-cloud-dns-0.33.0.gem) = ccfa6a855ec83ec461c815ee70392c6b8ab33289ae8584ffebe03a3619d0595b
+SIZE (rubygem/google-cloud-dns-0.33.0.gem) = 33280
diff --git a/dns/rubygem-google-cloud-dns/pkg-descr b/dns/rubygem-google-cloud-dns/pkg-descr
new file mode 100644
index 000000000000..cde3bdfe28f3
--- /dev/null
+++ b/dns/rubygem-google-cloud-dns/pkg-descr
@@ -0,0 +1,7 @@
+Google Cloud DNS is a high-performance, resilient, global DNS service that
+provides a cost-effective way to make your applications and services available
+to your users. This programmable, authoritative DNS service can be used to
+easily publish and manage DNS records using the same infrastructure relied upon
+by Google.
+
+WWW: https://github.com/googleapis/google-cloud-ruby/tree/master/google-cloud-dns