aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-10-16 13:52:42 +0000
committerMark Felder <feld@FreeBSD.org>2014-10-16 13:52:42 +0000
commit805615e7ee41efc87bbeefc891c2ae7eb5f61a00 (patch)
tree96dbe9f7f393707dcced10ae07e6ed7de2796331 /dns
parentd0da337c5af251d882e64822a2d050e6be012d3e (diff)
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/unbound/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 6874667ffecd..05532d4f5ddf 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -32,7 +32,7 @@ PLIST_SUB+= PYTHON=${PYTHON} MUNIN=${MUNIN}
OPTIONS_DEFINE= THREADS PYTHON GOST ECDSA MUNIN DOCS LIBEVENT
OPTIONS_DEFAULT=THREADS ECDSA
-LIBEVENT_DESC= Build against libevent (devel/libevent2)
+LIBEVENT_DESC= Build against libevent (devel/libevent2) (BROKEN on >=10)
GOST_DESC= Enable GOST support (requires OpenSSL >= 1.0)
ECDSA_DESC= Enable ECDSA (elliptic curve) support (OpenSSL >= 1.0)
MUNIN_DESC= Install Munin plugin
@@ -79,6 +79,9 @@ MUNIN= "@comment "
.endif
.if ${PORT_OPTIONS:MLIBEVENT}
+.if ${OSVERSION} >= 1000015
+BROKEN= Unbound with libevent crashes on FreeBSD 10+ due to Capsicum
+.endif
LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
USES+= pkgconfig
CONFIGURE_ARGS+=--with-libevent
@@ -88,12 +91,6 @@ LDFLAGS+= $$(pkg-config libevent --libs-only-L)
CONFIGURE_ARGS+=--with-libevent=no
.endif
-.if ${PORT_OPTIONS:MLIBEVENT14} || ${PORT_OPTIONS:MLIBEVENT20}
-.if ${OSVERSION} >= 1000015
-BROKEN= Unbound with libevent crashes on FreeBSD 10+ due to Capsicum
-.endif
-.endif
-
.if empty(PORT_OPTIONS:MTHREADS)
CONFIGURE_ARGS+=--without-pthreads
.endif